PDA

View Full Version : Album art not showing up when playing music via AirPlay




duelingdragons
Nov 10, 2011, 09:04 PM
The songs stream perfectly, but the album art isn't showing up, just a big ugly music note.

The album art displays perfectly on my iPhone, however.
Any ideas?



Robb138
Aug 12, 2012, 09:34 AM
Same thing here. It worked one time, but most of the time it doesn't. Anyone know?

Skoopman
Oct 6, 2012, 09:14 AM
I bought a Pioneer X-HM71 HiFi-system a few days ago and have the same problem. Some artwork does not show up. Sometimes I try to get the artwork from Apple via "Get Album Artwork" and it works. But some of my music is not available in the iTunes store, so the download fails. It's really annoying because I invested quite some time to get all the album artwork for my music.

It seems to be a Airplay problem and has nothing to do with the Apple TV. I don't stream my music that often to my ATV3, but I will check for the same bug.

MoodyM
Dec 22, 2012, 03:31 AM
Happens here too, streaming from a 2011 Mac Mini with OS X Lion 10.7.5 running iTunes 11.0.1 and a Pioneer X-SMC3. Some albums show artwork, some show a grey music note.

All my albums are tagged correctly with art in iTunes, and they were all tagged the same way (I added the art by pasting an image from Google Images into the artwork field)

Skoopman
Dec 23, 2012, 05:40 AM
I found the problem: The cover must be embed by any other program than iTunes, I use XLD. Simply re-encode the music, but put the cover in the same folder, I labelled the cover "cover" and XLD recognises it automatically. If I add the cover in iTunes it will not display on my Pioneer system.