PDA

View Full Version : Cd wont eject. Pls advice in replacing.


jm2005
May 22, 2005, 08:48 PM
Hi Guys,
This is the first time I've encountered this after 4 years. Can't seem to eject the cd from the drive. I tried using the F12 eject key and the apple + E keys but to no avail. I also tried shutting down the laptop then ejecting the cd but that doesn't work either. I'm afraid I might need to change my (Powerbook G4's 7rpm 400mhz) internal cd/dvd drive.
In that case, I need your advice on how to change the cd/dvd drive and what is the best brand that's in the market now. I'm opting for buying a cd/dvd r/rw.
Thanks heap,
jm2005

iMeowbot
May 22, 2005, 09:06 PM
Two more things to try before tearing your computer apart:

Boot while holding down the mouse or trackpad button (wait for up to a minute after booting before giving up)

Boot into open firmware (hold down command, option, O and F) and at the prompt type eject cd -- again, wait a minute or so before giving up.

bodeh6
May 22, 2005, 10:01 PM
400MHz? Might be time to upgrade maybe.