PDA

View Full Version : Problem with PowerMac dual 2.7 and Tiger




TBombadil
Nov 26, 2011, 08:27 AM
Hello, new to this forum. Spent many hours last two weeks digging and searching in these topics and found lots of great info. Thanks.

My problem in a nutshell is a used PowerMac dual 2.7 having some issues with Tiger and iTunes. Do not have the original disks, so I bought a retail version of Apple 10.4.11 Tiger that I am awaiting arrival of to reinstall the os. Hopefully this will cure what ails my PowerPC.

Now if I decide to upgrade to 10.5 Leopard do I need to find a retail version of 10.5.8 to use as this is the highest version of Leopard my PowerMac will take or can I use 10.5.1 or 10.5.4 and then use Apples site to update to 10.5.8? Or does Apple no longer support Leopard.

My apologies if this has been answered before but all my searches did not yield any answer to this question. Thanks again.



zen.state
Nov 26, 2011, 08:47 AM
You would need a retail copy of Leopard if you choose to upgrade since there were no G5's released with it.

To answer your download update question.. even OS 9 updates are still available on Apple's server. Don't even worry about that. 10.5 just had a new security update a few months back even.

chrfr
Nov 26, 2011, 08:59 AM
Now if I decide to upgrade to 10.5 Leopard do I need to find a retail version of 10.5.8 to use as this is the highest version of Leopard my PowerMac will take or can I use 10.5.1 or 10.5.4 and then use Apples site to update to 10.5.8? Or does Apple no longer support Leopard.

You can use any retail Leopard disc with the G5. Apple is no longer making new updates for 10.5 but the existing updates are still available.

TBombadil
Nov 26, 2011, 11:29 AM
...that was good news and fast to boot. Thanks, hopefully the installs go as they should. Now to find a retail Leopard that doesn't break the bank.