PDA

View Full Version : ATV 2 audio question




murph1134
Nov 27, 2011, 09:01 PM
So I have an audio question that I'm having trouble finding an answer to using google/search function on this forum...

I plugged my Apple TV 2 into my receiver using an optical cord for the first time today and am getting no 5.1 sound on files that I encoded using handbrake (DVD rips or converted .mkv files).

If I turn off Dolby Digital completely, the stereo tracks play, but once I turn on Dolby Digital on everything is silent. When I encoded using Handbrake, the 5.1 audio is encoded as AC3 passthrough (default for Apple TV preset).

Is there a way to fix it so the sound will work on my home theater? And, if I need to re-encode the sound, is there a fast way to do it rather than running everything through Handbrake again?



Alrescha
Nov 27, 2011, 11:33 PM
It should work. Handbrake with the Apple TV/Apple TV2 preset should produce compatible files. You may have a basic problem between your Apple TV and receiver (for instance, does the receiver work with other optical sources?).

For what it's worth, of the three choices under Settings/Audio & Video for Dolby Digital (Auto/On/Off), I have to use 'On' I suspect my television does not accept DD input, and won't negotiate it which disables it everywhere.

A.

murph1134
Nov 28, 2011, 06:38 AM
I've had my PS3 plugged in with an optical cord with no problems.

The other strange thing is - I have a few movies that I downloaded from iTunes, and Dolby Digital works with no problems for them. It's just the ones that I've ripped from DVD or converted from .mkw

adbe
Nov 28, 2011, 09:24 AM
This happens when your Handbrake profile is slightly wrong. I've had it happen a few times too. I don't recall the exact configuration that creates issues, but I have in mind that it happened when I had dual audio encoding for both stereo and 5.1.

Check your handbrake settings, or reset them to the defaults.

(If on the off chance no-one pipes in with the actual settings, you could always encode a could of trailers as quick tests and see which configs work for your setup).

murph1134
Nov 28, 2011, 11:25 AM
This happens when your Handbrake profile is slightly wrong. I've had it happen a few times too. I don't recall the exact configuration that creates issues, but I have in mind that it happened when I had dual audio encoding for both stereo and 5.1.

Check your handbrake settings, or reset them to the defaults.

(If on the off chance no-one pipes in with the actual settings, you could always encode a could of trailers as quick tests and see which configs work for your setup).

Interesting, I'll probably play around with it a bit and see what I get.

From what you know - does having it configured wrong make it so you lose the 5.1 and have to re-do it from the original DVD? Or can you just re-encode the file to the right format? Would hate to have to do all my DVDs one by one again.

murph1134
Nov 28, 2011, 08:28 PM
Got my answer. Ever since MetaX went down I've been using Subler to tag my movies. Anything that I tagged with MetaX works - anything I've tagged with Subler doesn't.

Too bad because Subler is awesome for tagging. Anyone out there use Subler that knows how to fix this?

Alrescha
Nov 28, 2011, 09:30 PM
anything I've tagged with Subler doesn't

I'm going to make a wild guess and say that you're changing something that shouldn't be changed. I tag my movies using Subler, and they work fine. I only touch the movie metadata (title, director, actors, etc.).

A.

aidan22
Nov 28, 2011, 09:58 PM
I'm going to make a wild guess and say that you're changing something that shouldn't be changed. I tag my movies using Subler, and they work fine. I only touch the movie metadata (title, director, actors, etc.).

A.

I have this problem before, here how i fix it...

When i open the file using subler, make sure the Surround Audio Track is unchecked (I think Subler will check all the tracks video, stereo and surround).

Also, make sure when you click on Stereo Audio, under sound setting alternate group should be 1 and then click on Surround audio, under sound setting the alternate group should also be listed as 1.

hope this will solve your problem.

murph1134
Nov 28, 2011, 10:02 PM
I have this problem before, here how i fix it...

When i open the file using subler, make sure the Surround Audio Track is unchecked (I think Subler will check all the tracks video, stereo and surround).

Also, make sure when you click on Stereo Audio, under sound setting alternate group should be 1 and then click on Surround audio, under sound setting the alternate group should also be listed as 1.

hope this will solve your problem.


And there's my answer. Subler automatically checks off everything on my computer, once I uncheck it, everything works.

Thanks for the help everyone!