PDA

View Full Version : Apple TV 2 and no audio to Denon, tried every possible connection




minitech
Dec 15, 2011, 10:08 PM
Brand new out of the box apple TV 2, new LG 720p with 2 HDMI connections, I've tried them both into the ATV, ATV to receiver every possible way, ATV digital optical into the TV, and into the receiver, EVERY OPTION. I only get audio out of my TV. Denon receiver is a AVR-1612 6 months old. Please help. Thanks.



omni
Dec 15, 2011, 10:19 PM
What are you using to test the audio?

My suggestion is to have it play music - its constant and in 2 channel aka the simplest to debug.

From there in the apple tv itself in the settings is an option for audio out. I believe default is auto (auto what I forget) so maybe there is some setting there that is worth exploring.

Last but not least maybe try restoring to factory default and see if that helps.

minitech
Dec 15, 2011, 10:44 PM
What are you using to test the audio?

My suggestion is to have it play music - its constant and in 2 channel aka the simplest to debug.

From there in the apple tv itself in the settings is an option for audio out. I believe default is auto (auto what I forget) so maybe there is some setting there that is worth exploring.

Last but not least maybe try restoring to factory default and see if that helps.

I have been using a music podcast for all testing, the only other option in that setting is 16 bit and I've tried that too. I've done the restore too, its brand new and has the newest update. From what I'm reading it might be the Denon/Apple TV interface which may be brand specific. Very frustrating when my entire system is brand new.

Devie
Dec 16, 2011, 01:48 AM
I have a Denon amp (about 10 years old) with a Samsung TV (about 4 months old). I do it like this:

ATV HDMI -> TV

TV -> Fiber Optical -> Amp

Works a treat. You'll have to tell the TV to output the audio on the optical out.


EDIT: Oh and its an ATV2 all updated etc.

omni
Dec 16, 2011, 10:28 AM
I have been using a music podcast for all testing, the only other option in that setting is 16 bit and I've tried that too. I've done the restore too, its brand new and has the newest update. From what I'm reading it might be the Denon/Apple TV interface which may be brand specific. Very frustrating when my entire system is brand new.

Hmm..I have a Denon 3806 but I run the hdmi for both video/audio into the receiver then run video out from the receiver to the TV.

Is it something weird with the Denon not handshaking properly?

I have 3 AppleTV's and on another setup in my house - I run HDMI straight to the TV and Optical out to the receiver...maybe thats worth exploring? Although I think you already mentioned you tried that.

jca24
Dec 16, 2011, 02:18 PM
I have an older receiver, no hdmi.

hdmi from atv to tv
optical from atv to receiver

no need to run the audio to the tv

works great.

:apple:

maestrokev
Dec 19, 2011, 04:14 AM
Does your Samsung TV send Dolby Digital or DTS via fiber to your amp? I have two Samsung LED TV's and the problem is that Samsung TV's optical output will not pass through DD or DTS.

I have a Denon amp (about 10 years old) with a Samsung TV (about 4 months old). I do it like this:

ATV HDMI -> TV

TV -> Fiber Optical -> Amp

Works a treat. You'll have to tell the TV to output the audio on the optical out.


EDIT: Oh and its an ATV2 all updated etc.