PDA

View Full Version : Address book archive issue




Loke2112
Dec 16, 2011, 03:16 PM
I recently backed up my address book as I was going to try syncing with my google contacts. When I didn't get the result I was looking for I tried to import the archive from my desktop. When I do it the contact appear for a few seconds and then disappear. I figured this had something to do with iCloud since I blanked out those contact along the way. I have tried turning off iCloud for my address book and on my iPod touch but nothing seems to work can anyone help? I have two copies of archives, one from today and one from 5 days ago on a back up drive.



Weaselboy
Dec 17, 2011, 09:55 AM
I jacked around with this same issue with iCloud and here is what I discovered.

I'm guessing you exported the Address Book (AB) in the AB archive format? That is the problem. When you import that format it is not an import but a replacement of the AB entries and iCloud just writes over top of that and you are back to blank!

You need to export the AB data to the vcard format using the first export choice in the AB export menu.

Here is what I had to do to get there. Create a new user account in OS X and login to that account. Import your AB archive to the AB then export it in the vcard format. To do that do a select all in your AB then export using the vcard option. Copy that vcard file to your original user account. Now import the vcard file to the AB in your user account. That should merge the AB data into the AB and sync it to iCloud.

Once done just delete the test user account you made.

Loke2112
Dec 17, 2011, 12:27 PM
Thanks WB I'll give this a try. I used to be able to pull back from an archive before, I think Apple should address this.

I'll let you know if it worked.

----------

Import your AB archive to the AB then export it in the vcard format.

Question, how do I see the archive from the new user account?

----------

Dude that worked like a charm thank you so much!

Weaselboy
Dec 17, 2011, 02:01 PM
Dude that worked like a charm thank you so much!

Glad it worked. I agree Apple should address it as it was not like this with MobileMe.