PDA

View Full Version : Lion not detecting ethernet cable




deadcantdance
Dec 17, 2011, 08:17 AM
Hi,

I have an early 2011 MBP 15" with Lion 10.7.2. Today I tried connecting to my network using an ethernet cable. Lion didn't recognize that the cable was plugged in, also the routers led for the port was showing that a device was connected.

First I thought there's something wrong with the cable, since I never used it before. But when I booted into Windows 7, the connection was recognized immediately. Booted back into Lion, but there the ethernet cable is still not recognized.

What can I do to fix this?

Regards,
deadcantdance



Weaselboy
Dec 17, 2011, 09:27 AM
What does your Network System Pref panel look like? You may be connected to wi-fi so the wired connection is not doing anything.

Can you see the ethernet connection like in my screen shot?

Maybe try moving the ethernet connection to the top of the list. Click where I marked with the green arrow and select "Set service order" to move ethernet to the top and see what that does.

Also try just turning off wi-fi to see if the wired connection starts working.


https://img.skitch.com/20111217-e4wxi4qmedu6f2ghjnqh6fbpsc.jpg

deadcantdance
Dec 17, 2011, 09:46 AM
I can see Ethernet there and WI-FI was disabled at the time.

Weaselboy
Dec 17, 2011, 09:57 AM
I can see Ethernet there and WI-FI was disabled at the time.

What color bubble do you see by the Ethernet option?

Maybe try hitting the minus at the bottom left to remove the Ethernet service then click plus to readd it.