PDA

View Full Version : There is always a static noise that goes on for ten seconds after any noise. Help?




tbb07
Dec 17, 2011, 12:48 PM
So whenever I receive a notification from one of my many program (for instance, Mail app), there is always a static noise that continues for about ten seconds after the notification sound. Now, I'm sure this is not a defect of any sort, and is probably a way for the mac to detect incoming audio, or something like that. But this is becoming increasingly bothersome, and I was wondering if there is any way to cut the static noise off completely, or at least shorten it. Is there?

Thanks!



Big-TDI-Guy
Dec 17, 2011, 01:07 PM
What Mac do you own? Does it happen using internal speakers? External? With headphones? Optical? Does the static get louder if your volume is set higher, or is it always at the same level? Does it happen if music is playing in the background, or a video?

It could be a hardware issue, but if you really want some answers, you need to supply more info.

tbb07
Dec 17, 2011, 01:47 PM
What Mac do you own? Does it happen using internal speakers? External? With headphones? Optical? Does the static get louder if your volume is set higher, or is it always at the same level? Does it happen if music is playing in the background, or a video?

It could be a hardware issue, but if you really want some answers, you need to supply more info.

The same noise occurs when I am using earbuds as when I am just using the internal speakers, so I thought it isn't an issue.

I bought the Mac on Mac 7 this year, so I doubt this is a hardware issue, as I remember the static noise for the longest time.

Does this happen to anyone else? Note that this static noise isn't exclusive to notifications. The noise occurs after the loud boop too (after you do something you cannot on the mac).

tbb07
Dec 17, 2011, 10:31 PM
I feel as though my posts were rather confusing.

Well, to test for yourself. Press F12 (turn the volume up one notch). After you do that, do you hear the static noise for about ten seconds? If so, you are not alone.

iThinkergoiMac
Dec 17, 2011, 11:22 PM
You never answered the question: what Mac do you own?

Almost certainly, you're hearing the noise generated by the soundcard. After 10 seconds, the soundcard shuts off, so the noise stops. Most people don't notice it, but if you notice it, it's annoying as heck.

tbb07
Dec 18, 2011, 11:00 AM
You never answered the question: what Mac do you own?

Almost certainly, you're hearing the noise generated by the soundcard. After 10 seconds, the soundcard shuts off, so the noise stops. Most people don't notice it, but if you notice it, it's annoying as heck.

Yes, that is precisely it. And sorry I completely did not notice the question.

My iMac is the $1699 new model.
Specs: 27-inch: 2.7GHz
2.7GHz Quad-Core Intel Core i5
2560 x 1440 resolution
4GB (two 2GB) memory
1TB hard drive1
AMD Radeon HD 6770M with 512MB

Big-TDI-Guy
Dec 18, 2011, 11:22 AM
Does it happen when using headphones, or only through the external speakers?

iThinkergoiMac
Dec 18, 2011, 12:35 PM
Does it happen when using headphones, or only through the external speakers?

The same noise occurs when I am using earbuds as when I am just using the internal speakers, so I thought it isn't an issue.

If the "problem" is the soundcard, as I am 99.99% sure it is, then it will happen regardless of what is connected. It's probably the most noticeable on headphones, as the sound is getting piped directly into one's ears.

Unfortunately, the soundcards in most Macs produce background noise when active. There's absolutely nothing that can be done short of getting a different soundcard.

miniConvert
Dec 18, 2011, 12:40 PM
Is there an Apple store nearby where you can test for the same thing on the display models? Take your headphones.

If it seems worse on yours then talk to Apple about repair/replacement.

baryon
Dec 18, 2011, 01:25 PM
Are you using external speakers? If your system volume is very low, and your speakers are set very high, then while you will hear normal volume sound, hissing and static from the system might be amplified above usual levels. There is static during and after every sound played by the system, which is either due to compression or the audio card switching off to save power after a while, I'm not sure, but it's normal, it's just not supposed to be loud enough to bother you at all!

So if it's loud even without external speakers, something could be wrong with sound settings or the hardware, get it checked!

Big-TDI-Guy
Dec 18, 2011, 01:35 PM
It could be the soundcard / amplifier. I have a late 2006 (24) and it does this extremely bad - it was a defective amplifier, and I missed the warranty period. Using the optical output - with external speakers - and it's not there at all.

I've seen other iMacs that do not have this problem at all. So it's possible what he's experiencing is louder than normal, as mine you can hear from rooms away. Whereas on others, you have to be in an extremely quiet environment to notice it.

If you've got the warranty, make use of it. Considering in my case, the sound card is part of the mainboard, which costs more than the purchase price of the computer, to replace...

I have to say this issue is far more common in Class-D amplifiers, than on the old-school ones.... Sometimes, analog is better. ;)