PDA

View Full Version : [iPhone] iPhone 3g, 4.2.1, 05.15.04 jailbreak/unlock




zedder17
Dec 24, 2011, 11:04 AM
Hi,

I've recently acquired a 3g, 4.2.1, 05.15.04 that I'd like to jailbreak and unlock. From my previous readings a while back, the only way to unlock was to upgrade the baseband to 06.15, with never being able to ever downgrade. Is this still the case or was a way developed to keep your current baseband but still unlock??

If there was a way developed, can you please guide me?

Or if the only way to unlock is to upgrade to the iPad baseband (06.15), can some one please guide me with the easiest/safest directions!!??

thanks!



Crystal-RX
Dec 24, 2011, 11:07 AM
Hi,

I've recently acquired a 3g, 4.2.1, 05.15.04 that I'd like to jailbreak and unlock. From my previous readings a while back, the only way to unlock was to upgrade the baseband to 06.15, with never being able to ever downgrade. Is this still the case or was a way developed to keep your current baseband but still unlock??

If there was a way developed, can you please guide me?

Or if the only way to unlock is to upgrade to the iPad baseband (06.15), can some one please guide me with the easiest/safest directions!!??

thanks!

Before you go with the Ipad baseband which no way to go back down. Download tiny umbrella on your computer, run it with your phone hook up and see what bootloader is on your phone. If it has 05.08, then you can downgrade its baseband and do not need to install Ipad baseband.

do this and report back.

zedder17
Dec 24, 2011, 11:17 AM
thanks for the quick response!

I have the phone hooked up with tiny umbrella, where does it show the bootloader? is that the number beside the baseband?

Crystal-RX
Dec 24, 2011, 11:23 AM
That is correct. What do you get?

zedder17
Dec 24, 2011, 11:25 AM
5.9....

this is what's there: 05.15.04-5.9_M3S2

so since I'm not at 05.08, I have no choice but to upgrade the baseband?

Crystal-RX
Dec 24, 2011, 11:28 AM
IPad baseband is your only option now.

1. Download 3g 4.2.1 on your PC
2. Download 0.9.6rc16 on your apac
3. Jailbreak it and install iPad baseband with redasnow.

zedder17
Dec 24, 2011, 11:38 AM
ok, I downloaded 3g 4.2.1 and redsn0w 0.9.6rc16!


I'm going to do it but I just have a couple questions if you don't mind:

1) I understand that once you upgrade to 6.15, there is no downgrading, but what are the cons of going to 6.15? I've read possible battery draining issues, what else?

2)Once it's jailbroken and unlocked, can it still be hooked up to iTunes for sync'ing and backing up?

3) Is it true that the 3g's iOS can only be upgraded as far as 4.2.1?

thanks for your help!!

bobodidley
Dec 24, 2011, 11:46 AM
Hi, I have been reading your post and was trying the same options. I start tiny umbrella and it shows no phone information. on 3gs 4.2.1 05.15.04 jailbroken with cydia. Any idea what im doing wrong wit tiny umbrella?

Crystal-RX
Dec 24, 2011, 11:50 AM
ok, I downloaded 3g 4.2.1 and redsn0w 0.9.6rc16!


I'm going to do it but I just have a couple questions if you don't mind:

1) I understand that once you upgrade to 6.15, there is no downgrading, but what are the cons of going to 6.15? I've read possible battery draining issues, what else?

2)Once it's jailbroken and unlocked, can it still be hooked up to iTunes for sync'ing and backing up?

3) Is it true that the 3g's iOS can only be upgraded as far as 4.2.1?

thanks for your help!!

1. The cons is your phone GPS is no longer working.
2. Yes, you can hook up to Itunes and do as you wish with normal Iphone. Just don't restore it.
3. That is true, the latest firmware for 3G is 4.2.1

----------

Hi, I have been reading your post and was trying the same options. I start tiny umbrella and it shows no phone information. on 3gs 4.2.1 05.15.04 jailbroken with cydia. Any idea what im doing wrong wit tiny umbrella?

Downloading baseband is only apply to 3G with bootloader 05.08. Since you have 3GS, there is no option for you. The only option for you if you want to unlock is to install an Ipad baseband. However, it will kill your phone GPS.

bobodidley
Dec 24, 2011, 11:54 AM
I figured the Ipad base band is the only option. I actually tried it but was failing each time at ipad fetch but read elsewhere that if you are using redsnow and trying to install cydia and fetch ipad base band at the same time it will crash.

Question? What exactly will that limit me to if there is no GPS?
I am assuming when apps want to use your location.



(Sorry for the insane run on sentence above :) )

zedder17
Dec 24, 2011, 11:55 AM
so if the phone goes haywire and I need to do a restore, is it possible? how?

Sorry for all the questions...

Crystal-RX
Dec 24, 2011, 12:01 PM
so if the phone goes haywire and I need to do a restore, is it possible? how?

Sorry for all the questions...

You still can restore but you will need a customs firmware to restore it to. You can use sn0wbreeze (if you have PC) or Pwnage tool (if you have Mac) to cook a customs 4.2.1 firmware to restore it to.

You can always restore to 3.1.3 using official firmware, and use tiny umbrella to exit recovery at the end of the process when you see 1015 error.

zedder17
Dec 24, 2011, 12:09 PM
sounds a bit involved...may need your help when/if the time comes!

ok, I'm going to reboot the pc and give the jailbreak/unlock a go...will report back!

zedder17
Dec 24, 2011, 01:11 PM
success!!!

at first I tried to install Cydia and upgrade the baseband at the same time, but redsn0w quit while "fetching baseband files...", so i had to take the phone out of recovery mode and tried it again....but this time I only installed Cydia, then after it was done, I upgraded the baseband.

I then opened Cydia and searched for ultrasn0w and installed it. I won't know if the unlock actually worked until my wife gets home with her phone so I can put the SIM into this phone.


All worked well...thank you very much Crystal-RX for all your help and quick responses! Have a Merry Christmas!!

Crystal-RX
Dec 24, 2011, 01:19 PM
Congrats and Merry Christmas to you.

By the way, if you are in the US and will be using T-Mobile, make sure you disable 3G in setting, general, network. :)

bobodidley
Dec 24, 2011, 01:42 PM
I also decided to unlock and all went well but when I opened Cydia and downloaded the dev source nothing showed up to install. I finally searched manually and installed. All went well tested the phone with a call. The only thing odd is it still shows as AT&T. I assume they will not show all carriers? I am not sure what country or carrier this sim is from. I was doing this for a friends co-worker. :)


Thank You so very much for all of your help and prompt responses.

Timbalan
Dec 24, 2011, 02:06 PM
I'm trying to do something very similar with a iphone 3g on an older bootrom.

Tiny umbrella reports: 04.26.08-5.9_M3S2

Just wanted to confirm that the iPad baseband would also be my only option. (Looking at that I think I'd rather stay at 3.1.2 an keep GPS functionality)

Thanks in advance I was pleasantly stunned to see a current thread so related to what I am looking to do.

Crystal-RX
Dec 24, 2011, 02:32 PM
I'm trying to do something very similar with a iphone 3g on an older bootrom.

Tiny umbrella reports: 04.26.08-5.9_M3S2

Just wanted to confirm that the iPad baseband would also be my only option. (Looking at that I think I'd rather stay at 3.1.2 an keep GPS functionality)

Thanks in advance I was pleasantly stunned to see a current thread so related to what I am looking to do.

Actually, you are lucky. You still have the old baseband 04.26.08 which can be unlock by ultrasn0w. So, all you have to do is to cook a customs 4.2.1 firmware with and restore to it. Once you done, jailbreak it with redsn0w and then unlock with ultrasn0w.

You do not need ipad baseband on your phone and your GPS will be working perfectly :D

Timbalan
Dec 24, 2011, 03:38 PM
Actually, you are lucky. You still have the old baseband 04.26.08 which can be unlock by ultrasn0w. So, all you have to do is to cook a customs 4.2.1 firmware with

With? Would snowbreeze work? Or is there a better choice?

Also would I wanna use the latest redsnow or an older one? So much seems to have changed since iphone 3g and 4.2.1 days.

Crystal-RX
Dec 24, 2011, 03:45 PM
With? Would snowbreeze work? Or is there a better choice?

Also would I wanna use the latest redsnow or an older one? So much seems to have changed since iphone 3g and 4.2.1 days.

Yes, use sn0wbreeze (if you have windows) and pwnage tool (if you have Mac) to cook this 4.2.1 customs firmware.

Also, just use 0.9.6rc16 and you are good to go. Later redsn0ws were update/change so they work on 3GS/Iphone 4 with newer firmwares.

zedder17
Dec 24, 2011, 11:26 PM
well, when my wife came home I tried her sim in the 3g but was unable to make a call...it read her phone number off the sim, but that's it...

She is using virgin mobile...can virgin not be used with an unlocked iphone?

also, when I unlocked it, the sim was not in the iphone...does it need to be in the iphone before I run ultrasn0w?

Crystal-RX
Dec 24, 2011, 11:37 PM
Once it is unlocked, it will work with all GSM network's SIM. Also, you do not need sim to be in the phone during unlock.

So, check the following:
1. What baseband on the phone now. Make sure it has the one that supports by ultrasn0w.
2. Make sure ultrasn0w is installed. Go to cydia, manage, packages, and look at ultrasn0a to make sure there is a green check next to it.
3. All the above check, reboot the phone, if still no signal, try to toggle air plane switch of and on.

zedder17
Dec 25, 2011, 12:11 AM
thanks, I'll double check tomorrow but I know the baseband did upgrade to 6.15...and Ultrasn0w has the green check mark...one thing I'm not sure of is if virgin mobile Canada is running on gsm??? Does anyone know off-hand? I'll need to research tomorrow!

Crystal-RX
Dec 25, 2011, 12:35 AM
thanks, I'll double check tomorrow but I know the baseband did upgrade to 6.15...and Ultrasn0w has the green check mark...one thing I'm not sure of is if virgin mobile Canada is running on gsm??? Does anyone know off-hand? I'll need to research tomorrow!

Here is a quote I found;

"Virgin Mobile worldwide
GSM is used in the UK, South Africa, Australia, France and Canada. CDMA, for phones with R-UIM cards, and GSM, for phones with SIM cards, are used in the US, and India (Virgin has access to Bell Canada's CDMA and HSPA+ networks.) GSM was launched in India recently. Virgin Mobile South Africa and India use two different mobile telephony standards, GSM and CDMA."

zedder17
Dec 25, 2011, 07:54 AM
kind of a confusing statement!

First it says: "Virgin Mobile worldwide GSM is used in the UK, South Africa, Australia, France and Canada."

then it says: "...GSM, for phones with SIM cards, are used in the US, and India (Virgin has access to Bell Canada's CDMA and HSPA+ networks."

I checked the baseband, it is at 6.15, ultrasn0w has a green checkmark and I also tried toggling the Airplane Mode....I also re-installed ultrasn0w...no luck!

am I SOL with Virgin Canada on this iPhone 3g??

It has a SIM card, but I'm not sure if it's on GSM or CDMA...

zedder17
Dec 25, 2011, 09:04 AM
got it to work! She's happy!!!

the "enable 3G" was disabled in the settings...

thanks again Crystal-RX for all your help and quick responses!

Great site for help and support!!!

Crystal-RX
Dec 25, 2011, 09:08 AM
kind of a confusing statement!

First it says: "Virgin Mobile worldwide GSM is used in the UK, South Africa, Australia, France and Canada."

then it says: "...GSM, for phones with SIM cards, are used in the US, and India (Virgin has access to Bell Canada's CDMA and HSPA+ networks."

I checked the baseband, it is at 6.15, ultrasn0w has a green checkmark and I also tried toggling the Airplane Mode....I also re-installed ultrasn0w...no luck!

am I SOL with Virgin Canada on this iPhone 3g??

It has a SIM card, but I'm not sure if it's on GSM or CDMA...

CDMA does not use a sim card. So, it must be a GSM. Can you call your provider and find out.

Also, check to make sure your sim works.

I am not sure if it makes any different, in US if we use it with T-Mobile, we have to disable 3G in the setting. I am not sure if it applies to Virgin.

Do you have a friend who is with Rogers you can borrow a sim for 2 minutes to test the phone?

zedder17
Dec 25, 2011, 09:57 AM
Hey Crystal-RX...we might have been typing at the same time...I posted just before you! I got it to work!! I had to enable the 3G...

thanks again...have a good one!!

Crystal-RX
Dec 25, 2011, 10:45 AM
got it to work! She's happy!!!

the "enable 3G" was disabled in the settings...

thanks again Crystal-RX for all your help and quick responses!

Great site for help and support!!!
Good job. Great Christmas gift for your wife.

Merry Christmas!

Timbalan
Dec 25, 2011, 11:41 AM
Thank you very very much,

Crystal-RX
Dec 25, 2011, 01:09 PM
Thank you very very much,

good job. If you find 4.2.1 is too slow on your 3g phone, you can always go back down to 3.1.3. :)

italia311
Dec 25, 2011, 03:56 PM
Hi Crystal-RX

Just out of curiosity. I have the BB 05.15.04 with 4.2.1 on boot loader 05.08. I noticed you asks the first poster this question but they did not have this boot loader. Am I able to downgrade...if so how?

So far I have jailbroken the phone using redsn0w and installed cydia. I tried using Fuzzyband to downgrade but it isn't working. I am lost.

Can I restore the phone without losing 05.08 as my boot loader?

thank you in advance.

Crystal-RX
Dec 25, 2011, 04:04 PM
Hi Crystal-RX

Just out of curiosity. I have the BB 05.15.04 with 4.2.1 on boot loader 05.08. I noticed you asks the first poster this question but they did not have this boot loader. Am I able to downgrade...if so how?

So far I have jailbroken the phone using redsn0w and installed cydia. I tried using Fuzzyband to downgrade but it isn't working. I am lost.

Can I restore the phone without losing 05.08 as my boot loader?

thank you in advance.

Here is what you need to do;

1. Jailbreak your phone with redsn0w 0.9.6rc16
2. install fuzzyband from Cydia.
3. Run Fuzzyband, and it will downgrade your phone baseband to lower version.
4. install ultrasn0w 1.2.5 to unlock it.
5. Your phone is unlocked.... enjoy your unlock phone.

italia311
Dec 25, 2011, 04:13 PM
Here is what you need to do;

1. Jailbreak your phone with redsn0w 0.9.6rc16
2. install fuzzyband from Cydia.
3. Run Fuzzyband, and it will downgrade your phone baseband to lower version.
4. install ultrasn0w 1.2.5 to unlock it.
5. Your phone is unlocked.... enjoy your unlock phone.

I have version rc8 is this probably why fuzzyband won't work?

Thanks for the info

Crystal-RX
Dec 25, 2011, 04:20 PM
I have version rc8 is this probably why fuzzyband won't work?

Thanks for the info

redsn0w version has nothing to do with fuzzy band. You download/install fuzzyband from Cydia. So, if your phone bootloader is 05.08, then fuzzyband will downgrade your phone baseband to lower version.

So, did you jailbreak your phone and it has Cydia icon on your phone?

italia311
Dec 25, 2011, 04:30 PM
redsn0w version has nothing to do with fuzzy band. You download/install fuzzyband from Cydia. So, if your phone bootloader is 05.08, then fuzzyband will downgrade your phone baseband to lower version.

So, did you jailbreak your phone and it has Cydia icon on your phone?

I have Cydia installed and I just ran Fuzzyband and it says:

Bootloader Version: 05.08 [G2M3S2]
Baseband Version: ICE2-05-15.04
Phone OS Version: 4.2.1

then it says "Not Supported"

:confused:

Crystal-RX
Dec 25, 2011, 04:39 PM
I have Cydia installed and I just ran Fuzzyband and it says:

Bootloader Version: 05.08 [G2M3S2]
Baseband Version: ICE2-05-15.04
Phone OS Version: 4.2.1

then it says "Not Supported"

:confused:

Weird...It works when I had 4.1 firmware on my phone. Only explanation I can see is that fuzzyband downgrader has not been upgrade to work on 4.2.1 (in my opinion).

Can you run your phone to tiny umbrella and see if you have blob for 4.1? if yes, then downgrade it to 4.1, then use fuzzyband to downgrade the baseband. If you don't have blob, then downgrade it to 3.1.3, then use fuzzy band to downgrade its baseband.

once you've done so, use custom firmware to upgrade it back to 4.2.1.

italia311
Dec 25, 2011, 04:53 PM
Weird...It works when I had 4.1 firmware on my phone. Only explanation I can see is that fuzzyband downgrader has not been upgrade to work on 4.2.1 (in my opinion).

Can you run your phone to tiny umbrella and see if you have blob for 4.1? if yes, then downgrade it to 4.1, then use fuzzyband to downgrade the baseband. If you don't have blob, then downgrade it to 3.1.3, then use fuzzy band to downgrade its baseband.

once you've done so, use custom firmware to upgrade it back to 4.2.1.

Shoot I was thinking the same that is not available for 4.2.1. I don't have a blob for 4.1. To be honest this phone was just given to me and the person "accidentally" upgraded. how do I downgrade it to 3.1.3?

Crystal-RX
Dec 25, 2011, 05:10 PM
Shoot I was thinking the same that is not available for 4.2.1. I don't have a blob for 4.1. To be honest this phone was just given to me and the person "accidentally" upgraded. how do I downgrade it to 3.1.3?

1. Download 3g 3.1.3 to your computer.
2. Put your phone into DFU mode, hit shift + restore (if you have PC) or Option + restore (if you have mac), and then point it to 3.1.3 firmware.
3. Itunes will restore the firmware for you. At the end, it will give you a 1015 error.
4. Open tiny umbrella, click on your device, then hit exit recovery.
5. your phone will boot up normally to activation screen (USB , Itunes and emergency bar at the bottom)

italia311
Dec 25, 2011, 06:18 PM
Hey Sorry,

Just trying to reinstall Cydia...its saying I am using wrong ISPW :P

Troubleshooting...hah

italia311
Dec 25, 2011, 06:46 PM
K...got Cydia back on. I will try the steps outlined by you and I will give you an update tomorrow. I'm tired now! :)

Thank you so much for your help. Really appreciate it.

Crystal-RX
Dec 25, 2011, 06:53 PM
K...got Cydia back on. I will try the steps outlined by you and I will give you an update tomorrow. I'm tired now! :)

Thank you so much for your help. Really appreciate it.

No problem. I just look at Fuzzyband from Cydia. It only supports to 4.1.

davidcom
Dec 26, 2011, 02:53 AM
got it to work! She's happy!!!

the "enable 3G" was disabled in the settings...

thanks again Crystal-RX for all your help and quick responses!

Great site for help and support!!!

Hi Zedder17. Can you let me know if you lost your GPS functionality? If so, I guess that means that apps like Maps won't work?

italia311
Dec 26, 2011, 05:42 AM
No problem. I just look at Fuzzyband from Cydia. It only supports to 4.1.

Just did a re-install of 4.1 on my iPhone and it says the same. Not supported for ICE2-05.15.04

:eek:

Mbhusal
Dec 26, 2011, 06:41 AM
I am having the same problem..I got that 1015 error and everything seemed fine. Now my phone says only emergency calls..do I again need to jailbreak, install cydia and then Fuzzyband to make it work?

italia311
Dec 26, 2011, 06:54 AM
I am having the same problem..I got that 1015 error and everything seemed fine. Now my phone says only emergency calls..do I again need to jailbreak, install cydia and then Fuzzyband to make it work?

I had to do that again but fuzzy still not successful.

Crystal-RX
Dec 26, 2011, 09:14 AM
I had to do that again but fuzzy still not successful.

Were you able to open fuzzyband in Cydia? it clearly states it support 4.1. I did it previously and I know it works. :confused:

zedder17
Dec 26, 2011, 10:47 AM
Hi, davidcom,

I just checked...I opened Maps and it found our location quickly and accurately! So, it looks like the GPS functions were not affected on this phone...hope this helps!

Once thing I did notice is that the battery life is still showing a full green bar at 100%....my wife charged it yesterday afternoon and was using it for a bit yesterday as well as today...I thought it was kinda weird that it was at 100% still, so this morning I downloaded a battery app, and it showed the same 100% charge! I'm gonna have to keep an eye on this....hopefully it is reading correctly and I won't find it powered off at some point cause the battery drained completely!

Has anyone ever run into this before??

italia311
Dec 26, 2011, 01:24 PM
Were you able to open fuzzyband in Cydia? it clearly states it support 4.1. I did it previously and I know it works. :confused:

I finally got it to work! Took me a bunch of tries to get the right order I suppose but its now downgraded and unlocked.

Thanks for you help/guidance!

Crystal-RX
Dec 26, 2011, 01:32 PM
I finally got it to work! Took me a bunch of tries to get the right order I suppose but its now downgraded and unlocked.

Thanks for you help/guidance!

Great to hear! happy holidays!

italia311
Dec 26, 2011, 04:53 PM
Great to hear! happy holidays!

Thanks! You 2!

Trauma1
Dec 26, 2011, 07:44 PM
You still can restore but you will need a customs firmware to restore it to. You can use sn0wbreeze (if you have PC) or Pwnage tool (if you have Mac) to cook a customs 4.2.1 firmware to restore it to.

Does restoring a jailbroken 4.2.1 iPhone 3G with the 6.15 baseband follow the "normal" jailbreak procedures with sn0wbreeze/Pwnage Tool?

In other words, if I want to restore then re-jailbreak and unlock such a device would I need to save the SHSH blobs through TinyUmbrella, preserve the baseband, or do anything like that?

CHINABEE
Dec 29, 2011, 10:53 AM
I have a iphone3g , 4.2.1 , 05.15.04 . I had a friend try and unlock it so I could use a t-mobile sim but he clearly didnt know how to do just that. I (think) I did jailbreak the phone .. but as far as unlocking .. I failed. Things are a mess and I do not know what I am doing. Could anyone give me step-by-step easy instructions on how to unlock my phone so I could use a t-mobile sim card. Also the links to where I can download for windows. I do not mind if I have to use the Ipad baseband . Can someone please help me?

Crystal-RX
Dec 29, 2011, 10:58 AM
I have a iphone3g , 4.2.1 , 05.15.04 . I had a friend try and unlock it so I could use a t-mobile sim but he clearly didnt know how to do just that. I (think) I did jailbreak the phone .. but as far as unlocking .. I failed. Things are a mess and I do not know what I am doing. Could anyone give me step-by-step easy instructions on how to unlock my phone so I could use a t-mobile sim card. Also the links to where I can download for windows. I do not mind if I have to use the Ipad baseband . Can someone please help me?

1. install fuzzyband from Cydia to check to see if your phone has 05.08 bootloader. If it does, then you can downgrade its baseband to lower version and and it can be unlocked with ultrasn0w. If your phone bootloader is higher than 05.08, then go to step 2.

2. The only option for you to unlock your phone is to install an Ipad baseband. Once you put this on, it will kill your phone GPS. If you decide to do it, then follow the following;

a. Download redsn0w 0.9.6rc16
b. run redsn0w, click on "install ipad baseband" and follow it instruction.
c. install ultrasn0w 1.2.5 from Cydia to unlock your phone.

Good luck.

CHINABEE
Dec 29, 2011, 11:16 AM
Where can I download the redsnow ? Every website I try to download it from for windows it either said page not found or this download has been removed.

Crystal-RX
Dec 29, 2011, 11:19 AM
You can get it directly from dev team. I think rc18 works as well.

http://blog.iphone-dev.org/post/5239805497/tic-tac-toe

hartscape
Dec 29, 2011, 03:44 PM
hi crystal i have jailbroke my iphone installed cydia ...i,m having problems unlocking but now know after reading here why...it was on orange network i used ultrasnow now its t mobile...my question is my baseband version is 05.15.04.....bootloder version is 06.04{g2m3s2}...0s version 4.2.1.......
got all this from tiny umberella like you suggested but the fuzzyband app did just as well though it can,t downgrade it still gives all this imformation...so i take it that the only way to unlock this phone is upgrade to i pad software?..i,m doing great at moment and even though its only 15 pound to unlock i feel like i,m acheiving something and learning fast so i look forward to some advice thanks and happy xmas :eek:

Crystal-RX
Dec 29, 2011, 07:31 PM
hi crystal i have jailbroke my iphone installed cydia ...i,m having problems unlocking but now know after reading here why...it was on orange network i used ultrasnow now its t mobile...my question is my baseband version is 05.15.04.....bootloder version is 06.04{g2m3s2}...0s version 4.2.1.......
got all this from tiny umberella like you suggested but the fuzzyband app did just as well though it can,t downgrade it still gives all this imformation...so i take it that the only way to unlock this phone is upgrade to i pad software?..i,m doing great at moment and even though its only 15 pound to unlock i feel like i,m acheiving something and learning fast so i look forward to some advice thanks and happy xmas :eek:

If you can ask your carrier to unlock it, then it would be great. Otherwise, the only way to unlock your phone is to put Ipad baseband on it.

hartscape
Dec 31, 2011, 02:14 AM
hi upgraded to 6.15 ..re installed cydia ...then used ultrasn0w to unlock it ..put a contract virgin sim card in it but didn,t work ..checked the carriers and they were all there and i ticked the vodafone one...it still kept saying no service...i thought it was my area so went for a drive to see if i could pick up a signal but no luck...anyway checked the general settings and then about...at the bottom it said T mobile which i thought was a bit strange..so i went back to carriers and chose T mobile instead of vodafone and then voila virgin mobile came on and signal strenght perfect.made a few phone calls works perfectly...somehow the carrier list was switched about to the actual sim cards you can put in...lateral thinking and deduction helped me as well as advice on here ..the other thing i instantly noticed is the wi fi signal meter is grey now and only turns blue when using an app same with power battery bar its grey then only turns green when using an app...thats it ..now some advice how to get my paid apps off itunes which i stored on there without affecting my phone would be great...thanks every one

Jayson Wonder
Jan 6, 2012, 03:31 PM
Is there a way to check the bootloader version on a 3g without being jail broken?

Want to find out what my options for unlocking but have yet to jailbreak.

Any advice is helpful.

Thanks,

Crystal-RX
Jan 6, 2012, 04:00 PM
Is there a way to check the bootloader version on a 3g without being jail broken?

Want to find out what my options for unlocking but have yet to jailbreak.

Any advice is helpful.

Thanks,

download tiny umbrella, run it and it will tell you what bootloader your phone has. Look at the bottom section of tiny umbrella where it displace the info.

Jayson Wonder
Jan 6, 2012, 04:20 PM
download tiny umbrella, run it and it will tell you what bootloader your phone has. Look at the bottom section of tiny umbrella where it displace the info.

Thanks for quick reply.

I did Tiny Unbrella, this is what I get:

Device Model: MB629C/B - iPhone3G
Installed Firmware Version: 4.2.1
Installed Baseband version: 05.15.04-6.4_M3S2

I assume this means I an have to do the iPad BB method loosing GPS? :(

What else will I loose? There was a posted here that said he never lost his GPS, is there any way to save the GPS?

I also heard there was suppose to be away to downgrade back to iphone BB later, have you heard if there is any truth to this?

Thanks very much great forum!!!

Crystal-RX
Jan 6, 2012, 04:36 PM
Thanks for quick reply.

I did Tiny Unbrella, this is what I get:

Device Model: MB629C/B - iPhone3G
Installed Firmware Version: 4.2.1
Installed Baseband version: 05.15.04-6.4_M3S2

I assume this means I an have to do the iPad BB method loosing GPS? :(

What else will I loose? There was a posted here that said he never lost his GPS, is there any way to save the GPS?

I also heard there was suppose to be away to downgrade back to iphone BB later, have you heard if there is any truth to this?

Thanks very much great forum!!!

Yeah. Your phone bootloader is 06.04 and therefore, the only option if you want to unlock your phone is to have ipad baseband on it.

Here is the full post from Dev Team relate to ipad baseband on 3G/3GS for your reference;

http://blog.iphone-dev.org/post/1718400992/ultra-recycle

I am sure there is exception to the GPS's issue. However, I think it is safe to assume that once you put an Ipad baseband on your phone, you will kill it GPS, if it doesn't great, if it does, then you have anticipated it already. :)

Jayson Wonder
Jan 6, 2012, 04:51 PM
Yeah. Your phone bootloader is 06.04 and therefore, the only option if you want to unlock your phone is to have ipad baseband on it.

Here is the full post from Dev Team relate to ipad baseband on 3G/3GS for your reference;

http://blog.iphone-dev.org/post/1718400992/ultra-recycle

I am sure there is exception to the GPS's issue. However, I think it is safe to assume that once you put an Ipad baseband on your phone, you will kill it GPS, if it doesn't great, if it does, then you have anticipated it already. :)

Ok thanks, I read that, pretty helpful. I just do not understand if this is a tethered method. I need to do a untethered method.

My only goal is to unlock a 3g so she can use Telus instead of Rogers. What do you recommend? I will go with the option you mention as you seem really know what you are talking about.

Thanks,

Ksizzle9
Jan 6, 2012, 05:03 PM
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

Guy posting about 3G, I would go ahead and downgrade the 3G to 3.1.3 or 3.1.2 if u know how, the phone will run much, much better. Won't look quite as good but will def be smoother

Jayson Wonder
Jan 6, 2012, 05:11 PM
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

Guy posting about 3G, I would go ahead and downgrade the 3G to 3.1.3 or 3.1.2 if u know how, the phone will run much, much better. Won't look quite as good but will def be smoother

Don't know how can you tell? Also will this allow me to unlock without iPad BB?

Thanks, I am new to all of this. :(

Crystal-RX
Jan 6, 2012, 08:16 PM
Ok thanks, I read that, pretty helpful. I just do not understand if this is a tethered method. I need to do a untethered method.

My only goal is to unlock a 3g so she can use Telus instead of Rogers. What do you recommend? I will go with the option you mention as you seem really know what you are talking about.

Thanks,

Jailbreak with redsn0w for your phone now is untethered. That post was old.

dj29152
Jan 8, 2012, 08:47 PM
Crystal-RX- seems like you know this in and out.

I have been reading this and have been on researching for the past 2 hours.

need your advice i have a 3GS 8GB on 4.2.1 with BB 5.15.04, is it possible to upgrade to 5.0.1 and unlock? If not, what is my option to jailbreak and unlock the phone?

Crystal-RX
Jan 8, 2012, 09:03 PM
Crystal-RX- seems like you know this in and out.

I have been reading this and have been on researching for the past 2 hours.

need your advice i have a 3GS 8GB on 4.2.1 with BB 5.15.04, is it possible to upgrade to 5.0.1 and unlock? If not, what is my option to jailbreak and unlock the phone?

look at the 3rd digit (year), 4th and 5th (week) of serial # of that phone and let me know what is it? 3gs made in 2011, week 35 and above will have problem with iPad baseband.

If your phone makes before that time and you understand the consequences, then you can upgrade to 5.0.1 and unlock it if you put iPad baseband on your phone.

dj29152
Jan 8, 2012, 09:15 PM
So i have two 3GS 8Gb

iPhone 1.) 3rd Digit: 1 4th: 0 5th: 8
iPhone 2.) 3rd Digit: 9 4th: 1 5th: 8

seems like it is before, is there an alternative to the iPad baseband upgrade? Even if that means not going to IOS 5.

Crystal-RX
Jan 8, 2012, 09:40 PM
So i have two 3GS 8Gb

iPhone 1.) 3rd Digit: 1 4th: 0 5th: 8
iPhone 2.) 3rd Digit: 9 4th: 1 5th: 8

seems like it is before, is there an alternative to the iPad baseband upgrade? Even if that means not going to IOS 5.

If baseband on these phones is higher than 05.13, the only option you have is an iPad baseband if you want to unlock then. Unless your phones not in the US and carrier can unlock that for you.

For 3GS that does not have blobs save, it can either go to 4.1 or 5.0.1 now.

dj29152
Jan 8, 2012, 10:20 PM
If baseband on these phones is higher than 05.13, the only option you have is an iPad baseband if you want to unlock then. Unless your phones not in the US and carrier can unlock that for you.

For 3GS that does not have blobs save, it can either go to 4.1 or 5.0.1 now.

The baseband is higher then 5.13, its 5.15 right now.

Well these two phones would be used over seas eventually, not sure if they would unlock it there either.

I don't think the blobs were saved online.


Seems like iPad BB is the only way to go?

Crystal-RX
Jan 8, 2012, 10:49 PM
Yep! You have only 1 option which is the iPad baseband route if you want to unlock these.

dj29152
Jan 9, 2012, 09:39 AM
Yep! You have only 1 option which is the iPad baseband route if you want to unlock these.

And the biggest con would be possibly disable GPS and not be able to come back down from BB

dj29152
Jan 10, 2012, 03:36 PM
So I tried to restore using iTunes but kept getting error 3194. I thought this was the host file issue and even resolved it, but it still wouldn't work.

Then I gave up that and started right at redsnow, I jailbroke the phone which upgraded the BB to 6.15 and installed cydia. However cydia was a white icon and wouldn't start up. so i went through the jailbreak installing only cydia, this completed but cydia was acting the same way.

So now I have a 3GS with 6.15 BB jailbroken kinda and to unlock

Also the other 3GS is really a 3G (not S) ... That one is not activated and stuck on it. I tried restoring via iTunes in recovery mode but faced the 3194 error.


Btw I was using Windows 7.

italia311
Jan 10, 2012, 04:38 PM
Just an update:

I was successful in downgrading my 3g and unlocking. Now roughly 2 weeks later I have no service. Tried SIM in a different phone and it works.

Weird.


Suggestions??

Crystal-RX
Jan 10, 2012, 05:11 PM
Just an update:

I was successful in downgrading my 3g and unlocking. Now roughly 2 weeks later I have no service. Tried SIM in a different phone and it works.

Weird.


Suggestions??

1. What firmware is on your phone now?
2. What modem firmware is on your phone now?

italia311
Jan 11, 2012, 03:12 AM
1. What firmware is on your phone now?
2. What modem firmware is on your phone now?

I'm on:
Modem Firmware: 05.13.04
Version: 4.1

user12102
Jan 12, 2012, 12:49 AM
Hello Crystal,
I had a problem with the home button on my unlocked (Done by a friend) Iphone 3G and thought that restoring and updating the OS will fix it but that din't happen and I had to replace the home button assembly.
Now I would like to unlock the phone again please suggest if any other options are available apart from updating the baseband to 06.15.00.The following are the specs of the phone (tinyumbrella)

Model : 3G
Firmware : 4.2.1
Baseband : 05.15.04-5.9_M3S2
Saved SHSH Blobs :
iPhone3G 4.0 (8A293)
iPhone3G 4.0.1 (8A306)
iPhone3G 4.0.2 (8A400)
iPhone3G 4.1 (8B117)
iPhone3G 4.2.1 (8C148)

Thanks

Crystal-RX
Jan 12, 2012, 01:04 AM
Ultraslow can't unlock the baseband you currently have on your phone. However, if your phone has 05.08 bootlader, then you can downgrade it's baseband. So, run your phone through tiny umbrella and see what you get. Boot loader shows right after baseband in the lower section in tiny umbrella.

user12102
Jan 12, 2012, 01:20 AM
Ultraslow can't unlock the baseband you currently have on your phone. However, if your phone has 05.08 bootlader, then you can downgrade it's baseband. So, run your phone through tiny umbrella and see what you get. Boot loader shows right after baseband in the lower section in tiny umbrella.

The bootloader shows as 5.9_M3S2

Crystal-RX
Jan 12, 2012, 08:27 AM
The bootloader shows as 5.9_M3S2

You have the 05.09 boootloader phone. So, only 1 option for you if you want to unlock it is to put an ipad baseband on it. However, read and research the cons before proceeding.

user12102
Jan 12, 2012, 04:14 PM
You have the 05.09 boootloader phone. So, only 1 option for you if you want to unlock it is to put an ipad baseband on it. However, read and research the cons before proceeding.

THANKS Crystal for giving all the valuable info on this thread ,I was able to successfully Unlock 3G phone using your suggestions and the gr8 news is the GPS WORKS after updating the baseband to 6.15.00

Cheers

Base Icks
Jan 13, 2012, 12:26 PM
Hey guys wondering if you could point me in the right direction. I didn't want to make a new topic since this is close to mine.

Anyways I have the same phone situation but I'm going for something a bit different. I have a jail broken 3G 4.2.1 with 5.15.04. I want to unlock my AT&T phone from the USA to be able to use it with a uk. Carrier. Does anyone know if this is possible or would work? Or where or how I should go about this info?

Thanks

Crystal-RX
Jan 13, 2012, 12:50 PM
Hey guys wondering if you could point me in the right direction. I didn't want to make a new topic since this is close to mine.

Anyways I have the same phone situation but I'm going for something a bit different. I have a jail broken 3G 4.2.1 with 5.15.04. I want to unlock my AT&T phone from the USA to be able to use it with a uk. Carrier. Does anyone know if this is possible or would work? Or where or how I should go about this info?

Thanks

1. First, since your phone is jailbroken, install fuzzyband from cydia and see what bootloader you have on your phone. If it is 05.08, you are in luck that you can downgrade your phone baseband to a lower version so you can unlock it with Ultrasn0w.

2. If your phone bootloader is 05.09 or higher, you have only 1 option to unlock your phone which is to install an Ipad baseband. However, read the following link first before you proceed.
If you still want to do it, just use redsn0w 0.9.6rc18, run it and click "install Ipad baseband", once you are done, install ultrasn0w 1.2.5 from cydia to unlock it.
http://blog.iphone-dev.org/post/1718400992/ultra-recycle

sleeps41
Jan 16, 2012, 10:32 PM
Hello everyone, ok so here is where i'm at. I have an iphone 3g 4.2.1 05.15.04 with 05.09 bootloader. I understand that for now the only way for me to go to unlock is to use the 06.15.00 ipad firmware. I have already jailbroken using redsn0w 0.9.6rc16 but only loaded Cydia for now. What I am trying to figure out is how do i create a restore file (custom firmware) in case I have to restore my iphone for some reason. Next, when do i create a custom restore, from where I am at now or after i install 06.15.00? I have searched but have not had much luck with this. Any help will be great. Thanks again.

Crystal-RX
Jan 16, 2012, 10:48 PM
Hello everyone, ok so here is where i'm at. I have an iphone 3g 4.2.1 05.15.04 with 05.09 bootloader. I understand that for now the only way for me to go to unlock is to use the 06.15.00 ipad firmware. I have already jailbroken using redsn0w 0.9.6rc16 but only loaded Cydia for now. What I am trying to figure out is how do i create a restore file (custom firmware) in case I have to restore my iphone for some reason. Next, when do i create a custom restore, from where I am at now or after i install 06.15.00? I have searched but have not had much luck with this. Any help will be great. Thanks again.


1. Your phone currently has the latest firmware which is 4.2.1 now. So, if you want to unlock it. All you have to do is to run redns0w 0.9.6rc16 and just click on "install Ipad baseband". Once you are done with that, install ultrasn0w to unlock it. Before, putting ipad baseband on your phone, please make sure to read dev team blog relate to this ipad baseband.

2. You can build customs firmware now or later, it is up to you. This is just for you to restore your phone in case you have problem with your phone.

miknos
Jan 17, 2012, 06:53 AM
Hope I'm not going out of topic but I'm desperate trying to fix my relative's iPhone.

He has a iPhone 3G. It was on 3.1.2 and I updated to 4.2.1. Managed to jailbreak to figure I couldn't unlock at 05.15.04 baseband. Updating to 06.15 (iPad baseband) I might lose GPS, have battery problems (draining faster) not counting that 4.2.1 runs slower!

Now I'm trying to figure it out how to downgrade to 3.1.3 and unlock it.
In TinyUmbrella it shows:05.15.04-6.4_M3S2

Is it true that I need to update to 4.2.1 (again), change to iPad baseband then downgrade to 3.1.2?
Any help please?

Crystal-RX
Jan 17, 2012, 07:53 AM
Hope I'm not going out of topic but I'm desperate trying to fix my relative's iPhone.

He has a iPhone 3G. It was on 3.1.2 and I updated to 4.2.1. Managed to jailbreak to figure I couldn't unlock at 05.15.04 baseband. Updating to 06.15 (iPad baseband) I might lose GPS, have battery problems (draining faster) not counting that 4.2.1 runs slower!

Now I'm trying to figure it out how to downgrade to 3.1.3 and unlock it.
In TinyUmbrella it shows:05.15.04-6.4_M3S2

Is it true that I need to update to 4.2.1 (again), change to iPad baseband then downgrade to 3.1.2?
Any help please?

You will have to install iPad baseband first while you are at 4.2.1 before downgrading to 3.1.3. Since you do not need shsh for any fw under 4.x on 3G. So, here is what you need to do;

1. Download 3.1.3 onto you pc.
2. Put the phone into DFU and restore to it to 3.1.3.
3. Use tiny umbrella to exit recovery when you get 1015 error.
4. Jailbreak it with Redsn0w (if you don't have original sim) or use spirit, jailbreakme.com.
5. Install Ultrasn0w from Cydia to unlock it.

miknos
Jan 17, 2012, 09:53 AM
Thanks for the reply.

I used redsn0w 0.9.6rc16 to install iPad baseband (6.15) with iPhone1,2_4.2.1_8C148_Restore. Everything was working fine (both JB and Unlock). When I checked info in About, it showed 4.1. I opened iTunes and it showed 4.2.1 update available. I updated and I think I screwed now.

Just tried to use Redsn0w again with iPhone1,2_4.2.1_8C148_Restore and now the "plug in to iTunes" icon appears in the iPhone (no JB).

What can I do to JB and unlock it now?

Crystal-RX
Jan 17, 2012, 09:58 AM
Thanks for the reply.

I used redsn0w 0.9.6rc16 to install iPad baseband (6.15) with iPhone1,2_4.2.1_8C148_Restore. Everything was working fine (both JB and Unlock). When I checked info in About, it showed 4.1. I opened iTunes and it showed 4.2.1 update available. I updated and I think I screwed now.

Just tried to use Redsn0w again with iPhone1,2_4.2.1_8C148_Restore and now the "plug in to iTunes" icon appears in the iPhone (no JB).

What can I do to JB and unlock it now?

your phone has 4.1 fw on it. So, when you run redsn0w you need to select 4.1 (if you don't have it, then download it onto your PC).

miknos
Jan 17, 2012, 10:10 AM
I know, but when I try to jailbreak (again) (iPhone1,2_4.2.1_8C148_Restore, redsn0w 0.9.6rc16) the iTunes icon appears in the iPhone.

I'm trying with 0.9.10b4 and redsn0w crashes (closes). Just finished with 0.9.9b9d and it's working fine.

I think I'll keep the 4.1.

It's complicated to know which version of redsn0w works properly with X FW version.

Thank you for the reply.

solafson
Jan 18, 2012, 10:58 AM
I have a 3g, 4.2.1, 05.15.04 currently locked with FIDO (Rogers) in Canada.

I want to unlock to use with Bell but I don't necessarily need to jailbreak it. Is this an option?

Tiny Umbrella reports my phone as:

MB635C/A - iPhone3G
4.2.1
05.15.04-5.9_M3S2

Is the iPad baseband the only option? I would like to keep the GPS still functional.

Cheers

Crystal-RX
Jan 18, 2012, 11:05 AM
I have a 3g, 4.2.1, 05.15.04 currently locked with FIDO (Rogers) in Canada.

I want to unlock to use with Bell but I don't necessarily need to jailbreak it. Is this an option?

Tiny Umbrella reports my phone as:

MB635C/A - iPhone3G
4.2.1
05.15.04-5.9_M3S2

Is the iPad baseband the only option? I would like to keep the GPS still functional.

Cheers

Best option is to call Roggers to unlock your phone. Otherwise, iPad ipbaseband is your option then. You will have to assume GPS will not working at all if you go that route.

snowedin1
Jan 18, 2012, 10:30 PM
I have been reading up here and think I have a good plan thanks to Crystal-RX. Problem is when I try to find the bootloader info with Tinyumbrella everything is blank. Not really clear on the process but learning.
I've got a ..
Iphone 3g (made August of 2008)
IOS 4.2.1 (8c148)
Baseband 05.15.04

I'm planning on following downgrade plan but need my bootloader info to move forward.


1. Download 3.1.3 onto you pc.
2. Put the phone into DFU and restore to it to 3.1.3.
3. Use tiny umbrella to exit recovery when you get 1015 error.
4. Jailbreak it with Redsn0w (if you don't have original sim) or use spirit, jailbreakme.com.
5. Install Ultrasn0w from Cydia to unlock it.

Crystal-RX
Jan 19, 2012, 12:55 AM
When you run tiny umbrella, your iPhone boot loader is shown right after your phone baseband.

snowedin1
Jan 19, 2012, 03:56 PM
Thanks. My bootloader is 5.9. It was my firewall in the way

A friend gave me this phone and it seems really slow at ios 4.2.1

I'm going to install the iPad baseband 6.15.00 first while I'm at 4.2.1 before downgrading to 3.1.2. Hopefully that will speed things up.

I was going to go to 3.1.3 but I found this statement in the notes of the iclarified.com Unlock Wizard. Link below

"Please note that you must restore to 3.1.2 using iTunes .......... Please make sure you DO NOT restore to 3.1.3 as you will lose the ability to unlock.

http://www.iclarified.com/unlock/iphone3g/windows.php?firmware=3.1.3&baseband=05.13.04

So should I go with 3.1.2 or 3.1.3?
Either way I know that baseband 6.15.00 can disable my GPS

Will all of this allow me to use this ATT&T 3G on my Verizon account? Am I on the right track?

b0bab0i
Jan 19, 2012, 04:07 PM
Thanks. My bootloader is 5.9. It was my firewall in the way

A friend gave me this phone and it seems really slow at ios 4.2.1

I'm going to install the iPad baseband 6.15.00 first while I'm at 4.2.1 before downgrading to 3.1.2. Hopefully that will speed things up.

I was going to go to 3.1.3 but I found this statement in the notes of the iclarified.com Unlock Wizard. Link below

"Please note that you must restore to 3.1.2 using iTunes .......... Please make sure you DO NOT restore to 3.1.3 as you will lose the ability to unlock.

http://www.iclarified.com/unlock/iphone3g/windows.php?firmware=3.1.3&baseband=05.13.04

So should I go with 3.1.2 or 3.1.3?
Either way I know that baseband 6.15.00 can disable my GPS

Will all of this allow me to use this ATT&T 3G on my Verizon account? Am I on the right track?
You can never use an At&T Phone on a Verizon. AT&T is on GSM while Verizon phones are CDMA.

You should read up on GSM & CDMA differences.

snowedin1
Jan 19, 2012, 08:18 PM
Thanks again. I'm not tied to verizon, so now I get to decide whether to stay with AT&T and whether or not I want to unlock it.

atlashead
Jan 19, 2012, 09:23 PM
I've got a iphone 3gs on firmware 4.2.1 with baseband 05.15.04 with bootloader 6.4. I want to go ahead with the baseband upgrade but I have a week 48 production model which means I have the newer bootrom. Should i still proceed with running redsn0w? what are the risks?

b0bab0i
Jan 20, 2012, 01:15 AM
I've got a iphone 3gs on firmware 4.2.1 with baseband 05.15.04 with bootloader 6.4. I want to go ahead with the baseband upgrade but I have a week 48 production model which means I have the newer bootrom. Should i still proceed with running redsn0w? what are the risks?

Once you upagrde to iPad BB, you will lose GPS functionality, but it will allow you to unlock the phone. You have to use Custom IPSW if you ever want to restore your phone.

atlashead
Jan 26, 2012, 09:02 PM
Thanks b0bab0i! I went ahead with the baseband upgrade using redsn0w and unlocked it using ultrasn0w. The gps seems to work still. Which is great, even though i dont use it lol. I also applied the greenpois0n jailbreak on top of the redsn0w one so its now an untethered jailbreak.

lynettepr
Feb 5, 2012, 07:59 AM
Hello, just tried to jailbreak/unlock an Iphone 3G, version 4.2.1, modem firmware 5.15.04. First I did the jailbreak and installed ultrasn0w with Cydia. Turned off the 3G and put the tmobile sim card. The T-mobile network didn't show up,it says "Searching..." but I've wait for hours and nothing happened. Does anyone know how much does it take for the t-mobile to register on the IPhone? Am I doing anything wrong? Anyhelp will be appreciated.

Crystal-RX
Feb 5, 2012, 09:55 AM
Hello, just tried to jailbreak/unlock an Iphone 3G, version 4.2.1, modem firmware 5.15.04. First I did the jailbreak and installed ultrasn0w with Cydia. Turned off the 3G and put the tmobile sim card. The T-mobile network didn't show up,it says "Searching..." but I've wait for hours and nothing happened. Does anyone know how much does it take for the t-mobile to register on the IPhone? Am I doing anything wrong? Anyhelp will be appreciated.

Your phone is not unlocked because Ultrasn0w can't unlock 05.15.04 baseband. Read posts in this thread and follow if you want to unlock your phone.

lynettepr
Feb 5, 2012, 10:50 AM
It worked following your steps :D Thank you very much! you made my day... Have a nice day.

munafshakir
Feb 27, 2012, 08:23 AM
Hi there,

please, is there anyone out there can tell me how to jailbreak and unlock iphone 3G, 3.1.2, baseband 05.15.04.

I updated the baseband by mistake via itune and dont know what to do now.

any help will be appreciated.

thanks
:)

newp28
Mar 10, 2012, 04:21 AM
the IPSW 4.2.1 that im going to download is it the originalone or the custom firmware?

erthwjim
Mar 12, 2012, 07:52 AM
Crystal,

It seems you're quite the popular person and I hate to bombard you with more questions, but I'm having an issue. I have an Iphone 3g with 4.2.1 and baseband 05.15.04. I used sn0wbreeze v2.9.2 to create a custom firmware. I made sure to check install 06.15.00 iPad baseband and even saw it downloading/installing it when it was building the IPSW. Once I put it in DFU mode and restored with the custom firmware, everything restored successfully. I then checked the firmware on the Iphone and it still shows 05.15.04. Should it show the iPad baseband 06.15.00 or is this normal?


Any advice would be much appreciated.

erthwjim
Mar 12, 2012, 08:07 AM
Nevermind, ended up going through redsn0w and figured out how to get the iPad baseband through there. Not sure why sn0wbreeze didn't work though.

Lilahh
Oct 10, 2012, 10:51 PM
I have an iPhone 3g with iOS 4.2.1 and baseband 05.15.04-6.4_M3S2 (according to TinyUmbrella). I called AT&T and have unlocked the phone legitimately via iTunes.

I would like to jailbreak it without updating to the iPad baseband. I'm not willing to lose GPS. Is it possible to jailbreak and keep my current unlocked baseband? If so, what steps would I take?

TriJetHero
Oct 11, 2012, 02:36 AM
As you now have a official unlock you won't lose your unlock anymore.
No need to update to the iPad BB.


Jailbreaking and unlocking are to seperate things entirely.

To jailbreak go to:
http://greenpois0n.com/downloads/

use greenpois0n RC 6.1

Lilahh
Oct 11, 2012, 11:47 AM
To jailbreak go to:
http://greenpois0n.com/downloads/

use greenpois0n RC 6.1

Thank you TriJetHero!! According to the greenpois0n RC 6.1 Read Me the iPhone 3G isn't on the supported devices list. Are you certain that it will work?

TriJetHero
Oct 11, 2012, 11:55 AM
use this for redsn0w 09.6b5
http://www.iclarified.com/entry/index.php?enid=12947

etsu88
Nov 28, 2012, 09:44 AM
Hey,
I used redsn0w to jailbreak my iphone 3g and i used ios 4.2.1. I have tried to put upgrade iPad baseband but after downloading still in my phone baseband is 05.15.04. I have tried everything..Can someone help me cause I need to unlock my phone so I can use my sim card.

dhlizard
Nov 28, 2012, 12:49 PM
Hey,
I used redsn0w to jailbreak my iphone 3g and i used ios 4.2.1. I have tried to put upgrade iPad baseband but after downloading still in my phone baseband is 05.15.04. I have tried everything..Can someone help me cause I need to unlock my phone so I can use my sim card.

Read this --> http://blog.iphone-dev.org/post/26534086824/baseband-freedom
Then use the tutorial on iClarified.com as a guide.

drsoubhi
Mar 14, 2013, 07:17 AM
Hi,
A few years ago, I obtained a used iPhone 3G, it's not factory unlocked.And I really don't know the source of this phone, a man unlocked the SIM for me, then upgraded to IOS 4.0.1. and he jailbreacked the phone. it was working fine for 2 years. until the memory began to suffer (8GB).

I decided to save my data using itunes, then to factory reset and upgrade.

I upgraded to Custom IOS4.2.1 using snOwBreeze 2.9.7. I found that the new Modem BaseBand is 05.15.04.
I think that my fault is I didn't keep the old Modem BaseBand.

I used Tinyumbrella and it returned than the Boot Loader is 6.4_M3S2.

Now my iphone GSM network shows no service.
but I can use all other Wifi, tools....

I searched into Itune backup folder but I couldn't find the ipsw file I just saved!, I searched the entire HDD but no way!
Is it possible for Itune to delete old files?

1-How can I reactivate the GSM service?
2- Where is my backup file?
3- How to upgrade an IOS for a Factory locked Iphone without the need for supersim to re-unlock?

Regards,