PDA

View Full Version : My battery seems dead on iPod 5G mini w/video




Ahulani
Dec 24, 2011, 02:55 PM
I have no response at all from my iPod when plugged into my laptop. (I haven't used it for about 6 months, so battery may indeed be shot?)

A friend said: "Have you tried charging it without plugging it into the laptop? My nano goes dead on a regular basis and I now have a USB cube that plugs into a wall socket, and I use it to charge the nano. Once charged it shows up where ever the nano is plugged in."

Is this the way to go? If so...
My iPod is connected by a firewire cable (not USB) that came with it. Do cube chargers come with that kind of connection?
Should I buy a cube charger?
Should I take it to the Apple Store?
Clearly I am unclear!



FinalCut747
Dec 28, 2011, 03:06 AM
IIRC, the newer iPods don't work with FW for charging

Ahulani
Dec 28, 2011, 12:59 PM
The firewire cable is the cord that came with my iPod Nano 5G. It worked for a year just fine. However, I took the thing it into the Apple Store in Corte Madera.

It was a defective cord…

AND it was replaced FREE.

The store was swamped on the day after Christmas, but it was fully staffed with about 20 red shirted elves sporting iPad2s and the service was just over-the-top amazing. In spite of all the stress brought into the store by confused/disgruntled customers, we were all given the time and attention we needed. Frowns were melting to smiles all over as we were seriously listened to and given the time needed. There was no feeling of being pushed aside for the next customer.

This attitude alone reflects a universal customer interface philosophy that gave me heart again. There must be powerful training and leadership intention to create this result. Each person was totally present with whomever they were speaking.
Thank to all of you who would like a little Apple uplift.