PDA

View Full Version : Trouble Installing Hard Drive in Optical Drive Bay




Snares
Dec 30, 2011, 09:54 AM
Long time reader, first time poster here. These forums have helped me countless times over the past two and a half years since I bought my first mac and I hope you'll pull through for me again.

Over the Christmas period I set myself a little project of making my Macbook white (early 2009, 10.7.2) a little faster and to expand the storage. What I have done is install a solid state drive (Kingston SV200) in the position of my old hard drive and added a new hard drive (Samsung HM641JI) in the optical bay. Despite some problems, I have managed the physical side of things but thing are not functioning as I would expect.

1) Although the Samsung drive is formatted correctly it is very, very temperamental. Sometimes the drive is not acknowledged, sometimes it will unmount itself for no reason, I have managed to save and access data on it but in the current state it is totally unusable.

2) I have tried my old hard drive in the optical bay caddy and it works fine, so I'm assuming the connection is good and that it is to do with the Samsung drive.

3) To make matters more confusing it works fine in the 'normal' hard drive location.

Does anyone have any ideas what may be causing the problems and how they can be fixed?

Also, although the Kingston drive has speeded things up a little, I haven't been blown away by the performance. Is there anything I should do to get the best out of the drive?

Cheers,

Paul