PDA

View Full Version : Help! Mac Mini Optical Audio keeps fizzling out!




DaveLandry
Jan 5, 2012, 06:31 PM
Setup: Mac Mini -> 1/8" to Optical Adapter -> Toslink Cable -> Receiver -> 5.1 Speakers

Starting last night, whenever I try to play any sound from my Mac Mini (iTunes, YouTube in Safari, media in Plex) the audio plays for a couple of seconds and then all of the 5 speakers "fizzle" out to nothing, with just the subwoofer playing it's audio and some ugly "clicks" that make my heart jump.

I've ruled out the receiver and cable, as my Xbox plays fine with the same setup (using the same inputs), so it's either the Mac Mini itself or the 1/8" to Optical adapter I have.

Has anyone ever experienced this issue? My Mac Mini has been rendered useless as my HTPC!



Hammie
Jan 5, 2012, 09:41 PM
Setup: Mac Mini -> 1/8" to Optical Adapter -> Toslink Cable -> Receiver -> 5.1 Speakers

Starting last night, whenever I try to play any sound from my Mac Mini (iTunes, YouTube in Safari, media in Plex) the audio plays for a couple of seconds and then all of the 5 speakers "fizzle" out to nothing, with just the subwoofer playing it's audio and some ugly "clicks" that make my heart jump.

I've ruled out the receiver and cable, as my Xbox plays fine with the same setup (using the same inputs), so it's either the Mac Mini itself or the 1/8" to Optical adapter I have.

Has anyone ever experienced this issue? My Mac Mini has been rendered useless as my HTPC!

Have you opened it up ever? Mine lost all audio in the past because the audio cable was not fastened properly after upgrading my memory.

Unless dirty, the optical adapter should not fail because it is doing nothing but directly the light to the optical cable. BTW, you said you used the same inputs. Did you also try the same cable? Try a different cable and see what happens. Also, check your AudioMidi settings and make sure that you have everything setup correctly (stereo, surround, what ever).