PDA

View Full Version : 100% CPU use all the time




jufjo
Jan 18, 2012, 02:48 PM
My macbook is using 100% of its CPU, all the time.
The computer is not overheating, the fan speed isn't insane either (around 3400rpm when not doing much), but nevertheless the macbook needs to use all its CPU.
I'm a total noob but sort of figured that this is not supposed to be like this.

CPU
user:70%
system;29%
nice:0%
idle;1%

Is this ok or bad?
If bad, what can I do about it?

I did look for this problem on the forum but that was always fan or heat related and I don't think that is the problem with my macbook.
If it has been discussed before, sorry for asking again.



simsaladimbamba
Jan 18, 2012, 02:49 PM
What process or processes take up the CPU?
______________________________________________________
Have a look at Activity Monitor (Applications / Utilities /) and select All Processes and sort by CPU to see what the culprit may be.
Also check the "System Memory" tab to see what your "Page ins:", "Page outs:" and "Swap used:" are.

image below uses sorting by CPU as an example
http://dl.dropbox.com/u/10644330/MR_Image_Hotlinks/MR_screenshots/MR_screenshots_03_2011/Acitivty_Monitor.png
Further reading:
Mac OS X: Reading system memory usage in Activity Monitor (http://support.apple.com/kb/ht1342)
Making The Most of Activity Monitor (http://mac.appstorm.net/how-to/os-x/making-the-most-of-activity-monitor/)
What Is Activity Monitor (or How to Take Your Mac's Pulse) (http://oreilly.com/pub/a/mac/2005/10/04/activity-monitor.html)
______________________________________________________

jufjo
Jan 18, 2012, 02:54 PM
Thank you!

Immediately I spot something odd, it is called tvmobilisvcs and I have no idea what it is but it uses over 110-150 cpu.
Everything else seems pretty ok, rarely more then 20cpu.

Page ins; 1,28gb
page outs; 1,90gb
swap used; 1.75gb

thekev
Jan 18, 2012, 03:01 PM
The application name traces back to this (http://www.tvmobili.com/). I don't know if this is something you put there intentionally.

Here (http://forum.tvmobili.com/viewtopic.php?f=7&t=27) is a thread on the issue on their forum.

As described on their page "A FREE DLNA MEDIA SERVER FOR WINDOWS, MAC, AND LINUX"

I am wondering if it has issues with the version of OSX you have installed or something. Personally I'd just remove it entirely if possible.

GGJstudios
Jan 18, 2012, 03:04 PM
Thank you!

Immediately I spot something odd, it is called tvmobilisvcs and I have no idea what it is but it uses over 110-150 cpu.
Everything else seems pretty ok, rarely more then 20cpu.

Page ins; 1,28gb
page outs; 1,90gb
swap used; 1.75gb
If you didn't intend to install TVMOBiLi (http://www.tvmobili.com/), then uninstall it.

The most effective method for complete app removal is manual deletion:
Best way to FULLY DELETE a program (http://forums.macrumors.com/showpost.php?p=11171082&postcount=16)

jufjo
Jan 18, 2012, 03:07 PM
Ah!
Yes I know that software, tried some things with the new 'smart' tv we have but had no idea it was still on my computer :o
So I drop-kicked it off my macbook and now everything is working lovely!
Back to 83% idle... makes me sound lazy ;)

Thank you very much for helping me out!