PDA

View Full Version : Keyboard stuck in French layout




jtbarrett
Jun 9, 2005, 12:41 PM
Hello, I'm a brand new Mac user having a bit of trouble with the international settings. I would appreciate any insight the forum has on this issue.

While experimenting with my new Mac I played with the international settings to see how OS X handles various keyboard formats. I tried several of them (French being the last) before reverting to the default setting of just the standard US input. However, it was still in French mode. Displaying the onscreen keyboard shows French in the title, and the machine behaves as if I were in French mode. Re-adding French or any number of other options does not help the situation, the U.S. profile has just been replaced with French. I am able to use the machine by using the U.S. Extended (Unicode) profile, but would prefer to switch back to the default setting and get rid of the menu bar icon.

Thanks very much for any help.
I am running a fully updated version of OS 10.4.1 on a dual 1.25ghz G4.
Restarting the computer does not help this situation.



jsw
Jun 9, 2005, 12:46 PM
If you open System Preferences...->International and go to the Input Menu tab, then de-select "Show input menu in menu bar", the icon should go away. If you go to the "Language" tab and drag English to the top (or use "Edit" to add it if it's been deleted), you should be OK.

Let us know if this worked for you.

jtbarrett
Jun 9, 2005, 12:56 PM
jsw,

Thanks for your reply. Yes, I can get rid of the icon as you described but the issue of a corrupted standard U.S. profile remains. I suppose I'm content to leave it broken if troubleshooting it would be a real hassle and there aren't any drawbacks to using the Unicode profile instead.

Thanks,
James Barrett

UTB_Avid
Jun 9, 2005, 01:04 PM
In system prefs->international->format tab what region do you have it set to? I am looking under panther right now, I can't remember exactly how it is on tiger, but check your regional settings.

jtbarrett
Jun 9, 2005, 01:32 PM
My region is set to United States.

mkrishnan
Jun 9, 2005, 01:49 PM
At the bottom of the System Preferences -> International -> Input Menu dialog, do you have the input source options set as Use one... or as Allow a different....?

Also, when you get the French keyboard through the keyboard viewer, does the icon also go back to the France flag instead of the USA flag?

jtbarrett
Jun 9, 2005, 01:54 PM
It is set to "Use one input source for all documents". The menu bar always displays the American flag whenever the US profile is selected, even if the actually applied profile is French (and showing as french on the Keyboard Viewer)

I have noticed that it's not in all applications that this problem occurs. It seems as though the keyboard behaves properly in core operating system text fields such as spotlight and finder, but is stuck in french for most applications such as Word, TextEdit, Safari and Mail.

EDIT: Nevermind on that last thing. Perhaps I was in the unicode profile without realizing it. Now everything is misbehaving as I originally described. (All applications treat the U.S. profile as French)

mkrishnan
Jun 9, 2005, 02:01 PM
There's always the good old repair permissions and reboot. ;)

jtbarrett
Jun 9, 2005, 02:04 PM
mkrishnan, I've tried that without success...

mileslong
Jun 9, 2005, 05:57 PM
simply make a loud bang like a gun going off and the french script should run away...

mkrishnan
Jun 9, 2005, 09:13 PM
simply make a loud bang like a gun going off and the french script should run away...

Although as a side effect, for many years afterwards, the US keyboard layout will make veiled references to "having bailed your sorry butts out" to the French keyboard layout at any opportunity. ;)