PDA

View Full Version : Building up-to-date Colloquy from trunk




eprillios
Jan 29, 2012, 05:47 AM
Hey there, :-)

I've got a Mac for the first time and because I use IRC frequently I downloaded Colloquy. But because there are some bugs in the usual download I wanted to build Colloquy from the trunk. I'm no developer and I'm new to the Mac, so I didn't get it build successfully. I've already downloaded the source from the trunk using this guide (http://colloquy.info/project/wiki/Source%20Code) on their site and downloaded Xcode and F-Script, but I couldn't find how to get a working application from the sources. I'll be happy to know how I must build Colloquy from the trunk.

Thanks in advance.



wrldwzrd89
Jan 29, 2012, 11:04 AM
Hello! I just tried to build Colloquy from the trunk. I am getting a build error also. I am using Xcode 4.2 with Lion - which Xcode are you using?

The error I get is: 'sandbox/private.h' file not found in /usr/include/sandbox.h

Commenting out the offending line in the file that includes sandbox.h causes 2 compiler warnings to appear about declarations being invalid.

subsonix
Jan 29, 2012, 01:12 PM
Found this workaround:

http://colloquy.info/project/attachment/ticket/2831/fix_build_10.7.patch

Does that work?

wrldwzrd89
Jan 29, 2012, 01:32 PM
Found this workaround:

http://colloquy.info/project/attachment/ticket/2831/fix_build_10.7.patch

Does that work?
Yes, it does! It builds properly now.

eprillios
Jan 30, 2012, 10:35 AM
Thanks all, I will check if it works. I'm using Textual now, but it's still good to know how to get it work. :-) I was using the latest Xcode from the Mac App Store, by the way. ;-)