PDA

View Full Version : iPod Classic won't play some songs that work fine in iTunes




tyrell456
Jan 29, 2012, 04:44 PM
Recently my iPod classic has been having this weird problem where it won't play some songs that work perfectly fine in iTunes on my MBP that it's synced with. It's only been happening for the last 2 or 3 months, and only with songs I've added in this time.

When I attempt to play these songs, the iPod will show the songs information like any other song, and then just skip to the next song in the list without playing it.

It's always the same songs too, so it's not like a random problem that affects different songs each time. I've tried completely removing the songs from my iTunes library, syncing the iPod without the offending songs, and then re-adding the song and syncing the iPod again attempting to force the iPod to re-sync the song in case there was a problem when it originally synced, but that doesn't work either.

Any ideas?



0dev
Jan 29, 2012, 04:51 PM
Sounds like a possible hard drive issue with the iPod. Have you tried restoring?

tyrell456
Jan 29, 2012, 04:56 PM
Sounds like a possible hard drive issue with the iPod. Have you tried restoring?

Yep, multiple times. I thought I could be a hard drive failure as well (though I've had it for less than a year), but when I restore it and completely resync it like new, it's still the same handful of 10-15 songs (out of a 20GB library) that won't work. Wouldn't it change up if it was a drive failure rather than having the same songs? And I know for sure that the files aren't corrupt or anything like that, as they work just fine in iTunes as well as any other media player I try them with on my computer, just not with my iPod.

0dev
Jan 29, 2012, 05:00 PM
If the files aren't corrupt, it points to a problem with the iPod. It does seem strange it's the exact same songs, but if it's songs you've added after a certain date maybe those files are just getting pushed to the bad part of the HD?

Either way, if it's under a year old and a restore isn't sorting it, and you know for certain the files aren't corrupted, then just bring it back to Apple.

Tombleboo
Apr 24, 2014, 04:04 PM
For a few days recently my old ipod classic 5th gen has failed to play new mp3s synced from that particular starting point, all the existing tracks in itunes and on the ipod played fine but new tracks from online or ripped from CD just wouldn't play, they showed up on the ipod after sync but wouldn't play.
I've scoured forums for a solution but nothing worked, from restoring ipod to moving files to desktop then back into itunes and also using an mp3 repairer. Anyway, I finally found a solution, and it was very simple.
I just actually played the tracks in itunes first and then they synced in a normal working way into the ipod!
You don't have to play all of the track, just click on each one in itunes for a second then on to the next one, a few seconds work per new downloaded album.
My guess is this is a glitch to do with the way itunes and the ipod are communicating with each other re some sort of tags (or whatever).