PDA

View Full Version : Dreamweaver: Times, Times New Roman, not loading in application




dbit
Feb 10, 2012, 02:54 PM
I'm on a computer using 10.6.8, Snow Leopard and Dreamweaver CS5. When we apply a style of Times New Roman to the text, it remains in it's default state (sans serif). When we apply a font family style, including times and a default serif font, the font still appears sans serif. This makes it seem like dreamweaver thinks the font it has is times, or it would default down the font family chain. When we preview in the browser the correct times new roman font is used.

I thought it might be all adobe apps but photoshop and illustrator display times just fine. We've validated the font in font book, cleared up duplicate problems with other fonts in font book. We've used onyx to clear the font cache several times, and also Font Finagler to clear the cache while keeping intact disabled fonts. After clearing the catch dreamweaver goes into some kind of font routine and takes about 15 minutes to get out of it. When I sample this process from activity monitor I see it running tons of font related routines. One time after this routine the correct times new roman font appeared! But after a program restart it disappeared again.

Also, in my preferences font dialog (for choosing the application fonts) my font list abruptly stops after fonts starting with the letters "th" and resumes with three z fonts. I have a lot of fonts between this range, but they don't show up, leading me to believe some kind of bug in Dreamweaver is causing the lower portion of my font list to not load/initialize.

Can anyone help? Has anyone else encountered this problem?

Screenshot:



Darth.Titan
Feb 10, 2012, 03:20 PM
It's probably due to the fact that your stylesheet declaration is malformed.
How it should look:
<style type="text/css" media="all">
...
You should be using '=' not ':'

dbit
Feb 10, 2012, 04:07 PM
Thanks for pointing that out. I fixed that now, but it's still the same behavior. It was a good catch, but I made sure that the stylesheet was responding by changing the color: to different colors. The stylesheet also worked with other font families, just not times new roman, times, or default serif.

So, still same problem. Other people who have looked into it with me on other forums are boggled so far.

UTclassof89
Feb 11, 2012, 10:17 AM
Have you tried clearing Dreamweaver's MacFileCache.dat ?

Users > [username] > Library > Application Support > Adobe > Dreamweaver CS5 > [language] > Configuration > MacFileCache.dat

dbit
Feb 11, 2012, 05:39 PM
UT: I just tried it and no dice. Tried again deleting it and rebooting, still no dice. Thanks much for the suggestion though!

I am still totally boggled by this. When I turn on "live view" it jumps in and renders Times, but that's because webkit is doing the rendering rather than dreamweaver. In regular view dreamweaver renders every other font family correctly, but not times/newroman/serif.

UTclassof89
Feb 12, 2012, 11:29 AM
My next troubleshooting steps would be (testing the issue after each):

1) throw away the Dreamweaver prefs file and restart DW

2) turn off a bunch of fonts higher in your list to see if it's just the quantity of fonts you have running that's causing DW to choke

3) uninstalling your copy of TNR and loading someone else's (to rule out a corrupted font file; pay special attention to the first font missing from your list, which may not be TNR)

dbit
Feb 12, 2012, 11:41 AM
Thanks UT.

Can you tell me where the preferences reside? Is it in a plist file like com.adobe.dreamweaver.preferences.plist or something?

UTclassof89
Feb 12, 2012, 02:18 PM
Yes:
MacHD > Library > Preferences > com.adobe.Dreamweaver.11.plist

nnane
Feb 26, 2012, 02:45 PM
Hey, thanks for posting this. I just re-built my system, and I have the same issue. Times New Roman is everywhere on my system (in every other app), but just not in Dreamweaver. I have to also believe it's the prefs file. I found and deleted com.adobe.dreamweaver-11.0.plist (you mentioned com.adobe.Dreamweaver.11.plist), but this didn't fix it. Any other ideas?

http://f.cl.ly/items/1B302L1G0K1Q1X1x0r1v/No%20Times-TimesNewRoman.png

dbit
Mar 6, 2012, 10:53 AM
I've still not found an answer to this problem. I have brought it up in multiple places and everyone seems to be stumped. I'm confounded as well as annoyed. Let me know if you make any progress.

Memaddog
Jul 24, 2012, 02:59 PM
I just wanted to chime in and say that I too had the same issue/behavior though curiously, "Trebuchet MS" a few other random fonts appear in the list before jumping down near the end of the fonts.

This was happening on my office computer but not on my laptop which has he same OS and Dreamweaver version so I knew it wasn't merely a program bug but was at least in part due to something else which was different on each computer. I was fairly confident that it had to be a font issue. (I have far too many fonts which are totally unnecessary on the office computer.) So I copied all the system and user fonts from my laptop over onto my office computer, moved the system fonts (HD/Library/Fonts) on the office computer to the desktop and copied over all the system fonts from my laptop. Essentially, I just mirrored the system fonts folder of my laptop on my office computer.

Problem solved. I can't tell you what font(s) was causing the problem but I'm pretty sure that's the root issue. Obviously Dreamweaver is having a problem with some font(s) while other programs aren't.

http://i47.tinypic.com/1eovuu.gif

fig
Jul 24, 2012, 04:37 PM
Well, we can look at this as a positive and people can find better font choices than Times ;)

I know that other versions of the Adobe Suite have had issues where installed fonts didn't show up but that seemed to be a 32/64 bit problem, I've had that issue on my work PC where some fonts didn't show up and had to be installed in C:\Program Files (x86)\Common Files\Adobe. Don't know that it's all related though.