PDA

View Full Version : iMessage Mac - Which ID?




AbSoluTc
Feb 17, 2012, 03:15 PM
So here's a question. I have an Apple ID and a Me ID for iCloud. I know Apple considers the Me ID as an Apple ID. Can I use my Me ID for iMessage or should I just stick with my Apple ID? I am just a little confused about this right now. I want everything to use my Me ID but I can't change my Apple ID to my Me ID because it won't allow it. Stupid.

What should I use to prevent any confusion and such?



nuckinfutz
Feb 17, 2012, 03:18 PM
Both will work but you can only attribute 1 Apple ID to the account. If you attempt to add another email that's used in an another Apple ID the system will balk.

I chose the email that people would most likely know and use to contact me. :apple:

newyorksole
Feb 17, 2012, 03:27 PM
On my iPhone, in the Messages settings it says "Receive at 2 addresses (phone number, which is greyed out, and Applie ID)

If my friends iMessage my phone number, will those iMessages EVER go to my Mac?

AbSoluTc
Feb 17, 2012, 03:30 PM
On my iPhone, in the Messages settings it says "Receive at 2 addresses (phone number, which is greyed out, and Applie ID)

If my friends iMessage my phone number, will those iMessages EVER go to my Mac?

They should. It's greyed out because its not editable. You can't delete your phone number from your phone. At least, that's what I am assuming.

I have set my contact email to my @me.com address and so far no issues. I really wish apple would fix it so apple ID's can be merged. Would solve a lot of problems.

newyorksole
Feb 17, 2012, 03:45 PM
They should. It's greyed out because its not editable. You can't delete your phone number from your phone. At least, that's what I am assuming.

I have set my contact email to my @me.com address and so far no issues. I really wish apple would fix it so apple ID's can be merged. Would solve a lot of problems.

My contact email everywhere is @me.com and when people iMessage me I don't get them to my Mac.

I started a convo with someone with iMessage on the Mac and when they responded it went to my iPhone AND Mac, but I would like it so that when people iMessage my iPhone # it goes to my Mac too.

Maybe it's a glitch?

AbSoluTc
Feb 17, 2012, 05:01 PM
My contact email everywhere is @me.com and when people iMessage me I don't get them to my Mac.

I started a convo with someone with iMessage on the Mac and when they responded it went to my iPhone AND Mac, but I would like it so that when people iMessage my iPhone # it goes to my Mac too.

Maybe it's a glitch?

Just did some testing with this. Have the same issue. If I initiate the conversation on my Mac, it goes to all devices. I can message from my Mac or my iPhone and it goes to all locations. However, if someone messages me out of the blue to my number, it goes only to my phone.

Not sure why. It should go to all locations I would think.

iPhone3gPSU
Feb 17, 2012, 06:00 PM
It's because here's how it is setup:

Your iPhone is capable of receiving iMessages sent to your phone number and @me.com e-mail.

Your computer, however, is only capable of receiving messages that are sent to your @me.com e-mail so therefore if anyone sends a message to your phone number, they will only go to your iPhone.

This is dumb, right?! I mean, the whole point is supposed to be so that you can "pick up on a conversation from your iPhone to your mac," but that really isn't the case. What you can do is start a new conversation with that person's phone number, but from your @me.com e-mail. The main issue is that now that creates two conversations in the friend's messages app (one of which they were having with your iPhone, and one that they are now having with your e-mail). As far as I can tell, there is no way in the messages app to "send from" your phone number.

My thought is that eventually Apple will change it so that all iMessage communication goes through your e-mail. I mean, that's how iPad works, and now the Mac, so iPhone is really only the inconsistent one. If, when someone sends you a message, it would go to your e-mail instead of your phone number - problem solved! Hmmm... :confused:

AbSoluTc
Feb 17, 2012, 11:32 PM
It's because here's how it is setup:

Your iPhone is capable of receiving iMessages sent to your phone number and @me.com e-mail.

Your computer, however, is only capable of receiving messages that are sent to your @me.com e-mail so therefore if anyone sends a message to your phone number, they will only go to your iPhone.

This is dumb, right?! I mean, the whole point is supposed to be so that you can "pick up on a conversation from your iPhone to your mac," but that really isn't the case. What you can do is start a new conversation with that person's phone number, but from your @me.com e-mail. The main issue is that now that creates two conversations in the friend's messages app (one of which they were having with your iPhone, and one that they are now having with your e-mail). As far as I can tell, there is no way in the messages app to "send from" your phone number.

My thought is that eventually Apple will change it so that all iMessage communication goes through your e-mail. I mean, that's how iPad works, and now the Mac, so iPhone is really only the inconsistent one. If, when someone sends you a message, it would go to your e-mail instead of your phone number - problem solved! Hmmm... :confused:

It's kind of stupid because I can iMessage to a phone number but not the other way around? Something is messed up. Lol.

Lucbert
Feb 18, 2012, 06:29 AM
It's the same problem with the ipad and it has been existing for a while but noone at apple did anything about it.

Make's it completely useless because people usually text my number

Joe HS
Feb 18, 2012, 07:40 AM
It's kind of stupid because I can iMessage to a phone number but not the other way around? Something is messed up. Lol.

You can't (yet) receive iMessages on your Mac that were sent to a Phone number because there is no way of confirming that your are the owner of the phone number, like there is with an email and a password.

This could be fixed relatively easily if you could link phone number(s) to an Apple ID from the iPhone itself.

Takuro
Feb 18, 2012, 07:57 AM
I think Apple has to create a centralized place in your iCloud settings where all email addresses and phone numbers associated with your account are consolidated and pushed to your other iOS / OS X devices. The new Messages app in 10.8 allows you to associate more than one email ID with an iMessage "entity" (I can't really call it an account-per-se.) However, you can't add your phone number. In addition, the iPhone doesn't have support for associating multiple email ID with your iMessage entity. Hopefully, the two will converge at point to give us a messaging system that is robust enough to have any iOS / OS X user contact any other user from any device using any valid email address or phone number, which I think is probably the end goal of iMessage as it's perfected over time.

youp.c
Feb 29, 2012, 05:10 PM
I got the same issue when I used the app for the 1st time, but within minutes I got it working though.

Here's a short how-to
1. Check if iMessage/Messages on mac is working with mail address
2. Go to settings >> accounts
3. Click on your account
4. Click on the "+" beneath your mailaddress and the text "You can be reached for messages at:"
5. It says something like "now enter your mail address to receive messages at", but nevertheless add your phone number in international format
6. You'll get a error message but don't click on the "remove address" button
7. Instead force quit Messages via Apple Menu () >> Force Quit
8. Restart Messages app and now you should be able to receive and send messages from your phone number

I wonder if it's possible why does Apple 'blocked' it?

newagemac
Feb 29, 2012, 05:34 PM
I got the same issue when I used the app for the 1st time, but within minutes I got it working though.

Here's a short how-to
1. Check if iMessage/Messages on mac is working with mail address
2. Go to settings >> accounts
3. Click on your account
4. Click on the "+" beneath your mailaddress and the text "You can be reached for messages at:"
5. It says something like "now enter your mail address to receive messages at", but nevertheless add your phone number in international format
6. You'll get a error message but don't click on the "remove address" button
7. Instead force quit Messages via Apple Menu () >> Force Quit
8. Restart Messages app and now you should be able to receive and send messages from your phone number

I wonder if it's possible why does Apple 'blocked' it?

Call me skeptical but I seriously doubt this works. Have you tried sending a text message to the phone number and did it show up on your Mac? Also, it doesn't sound like you did any type of verification so are you saying you can add anybody's phone number and you'll be able to receive their text messages?

youp.c
Feb 29, 2012, 05:49 PM
Have you tried sending a text message to the phone number and did it show up on your Mac? Yes and yes

Also, it doesn't sound like you did any type of verification so are you saying you can add anybody's phone number and you'll be able to receive their text messages?
I think your number must be linked to the same apple id as the one of your mail address, but I'm not sure about this.

Prey
Mar 6, 2012, 11:21 PM
I got the same issue when I used the app for the 1st time, but within minutes I got it working though.

Here's a short how-to
1. Check if iMessage/Messages on mac is working with mail address
2. Go to settings >> accounts
3. Click on your account
4. Click on the "+" beneath your mailaddress and the text "You can be reached for messages at:"
5. It says something like "now enter your mail address to receive messages at", but nevertheless add your phone number in international format
6. You'll get a error message but don't click on the "remove address" button
7. Instead force quit Messages via Apple Menu () >> Force Quit
8. Restart Messages app and now you should be able to receive and send messages from your phone number

I wonder if it's possible why does Apple 'blocked' it?

Silly question. Whats the international format for North America? 1 234 4567890?

AbSoluTc
Mar 8, 2012, 03:39 PM
This does not work.

newagemac
Mar 9, 2012, 10:01 AM
I tried it too and it doesn't work. The number shows up after you force quit as "Failed" and it won't work. Also, you can't set your caller ID to the phone number so that kills the usefulness right there.