PDA

View Full Version : Shouldn't Messages for Mac default to iPhone when signed off?




Gemütlichkeit
Feb 18, 2012, 03:25 PM
I close my lid on my Air and i have a few messages from friends who go to the mac and not the phone.

When I open my mac hours later they pop up there as if we were still in that conversation.

Once you close the lid shouldn't it sign you off, in which their messages should be sent to your phone instead?



xxBURT0Nxx
Feb 18, 2012, 03:27 PM
do you have imessage on your phone set to get messages from both you phone number and your email?

when someone messages you on messages for mac, it's going to your email, unless you also have the messages app on the phone set to receive messages sent to that email they won't show up because it's waiting on messages sent to your phone number.

Apple really needs to just tie a phone number to your iCloud account so that all messages can be viewable on all devices.

jmmo20
Feb 18, 2012, 04:19 PM
do you have imessage on your phone set to get messages from both you phone number and your email?

when someone messages you on messages for mac, it's going to your email, unless you also have the messages app on the phone set to receive messages sent to that email they won't show up because it's waiting on messages sent to your phone number.

Apple really needs to just tie a phone number to your iCloud account so that all messages can be viewable on all devices.


like the OP, I have the same problem but I also have my email+telephone number on my iphone, so it should work, but it doesn't always work.

also, when you're using your mac, your iphone keeps vibrating all the time.. there needs to be something on the iphone to disables notifications if apple's servers detect you're on your mac.. maybe a silent alert? without sound/vibration on your iphone?
it's a bit crazy actually because even if you only using your mac, the iphone keeps vibrating all the time.

profets
Feb 19, 2012, 06:44 AM
like the OP, I have the same problem but I also have my email+telephone number on my iphone, so it should work, but it doesn't always work.

also, when you're using your mac, your iphone keeps vibrating all the time.. there needs to be something on the iphone to disables notifications if apple's servers detect you're on your mac.. maybe a silent alert? without sound/vibration on your iphone?
it's a bit crazy actually because even if you only using your mac, the iphone keeps vibrating all the time.

Lol, yesterday I was in a group conversation on iMessage on my Mac, and there was a lot of messages coming in from multiple people. I could hear my iPhone in one room and iPad in another room playing alerts like crazy, gets pretty annoying, and then of course you don't know if some might be messages going only to the phone because of someone sending an iMessage to your number.

I'm not sure how, but some sort of sync and silencing like you mentioned would be a cool idea I think. Maybe as these devices all start getting bluetooth 4.0 they can automatically pair when in range based on the apple ID used on each device? I dunno, just a thought.

russellelly
Feb 19, 2012, 11:03 AM
Apple really needs to just tie a phone number to your iCloud account so that all messages can be viewable on all devices.

This. This. And this again.

I've never used iMessage on my iPad and doubt I'll use on ML for this reason.

jrock2004
Feb 19, 2012, 11:11 AM
I downloaded and installed the messages beta yesterday and now it appears that any messages from iPhones are coming to the app instead of my iPhone. I looked in settings and for receive at I have 2 addresses. one is my phone number which is greyed out and the other is my iCloud email

Gemütlichkeit
Feb 19, 2012, 03:03 PM
do you have imessage on your phone set to get messages from both you phone number and your email?

when someone messages you on messages for mac, it's going to your email, unless you also have the messages app on the phone set to receive messages sent to that email they won't show up because it's waiting on messages sent to your phone number.

Apple really needs to just tie a phone number to your iCloud account so that all messages can be viewable on all devices.
I just added my @me.com account on my phone. We'll see if this effects it.

kuwxman
Feb 19, 2012, 03:47 PM
So your phones ARE getting the alerts while using Messages on your Mac? Mine isn't at all. Was actually commenting to a friend that I would like those messages to show up on my phone. :confused:

DeckMan
Feb 19, 2012, 03:56 PM
Sounds like a bug to me. If you're talking about the Mountain Lion version, you should report it using the developer feedback tool. If it's the Messages Beta on Lion, I'm not sure how/if you could report that.

xxBURT0Nxx
Feb 19, 2012, 06:53 PM
It's not a bug... it is based on how you have your settings configured....

to get them to show on your phone, you need to go to settings, messages, make sure that both your mobile number and email are set to retrieve, and then set caller ID to EMAIL so that when you send messages they reply to your email. email imessages are the only ones that appear on all devices. anything sent to or from your mobile number will only appear on a mobile device.

JohnDoe98
Feb 19, 2012, 06:57 PM
Also, if your desktop has the imessage app in the foreground, the messages won't load in the notifications on your iPhone or iPad (the screen won't light up and show the alert). If you switch to another app though on your desktop (putting iMessage on OS X in the background, you'll get the notifications passing through again on all devices (on your mac the messages app will bounce and show the red bubble). Pretty clever implementation from Apple here. Just make sure not to walk away from the desktop after sending a message and expect to get alerted on your iOS devices. Yes, the messages will still display in the messages app on the iOS device, but the alerts don't seem to go through when the desktop client is in the foreground, at least on mine. So make sure to background it before you leave.

I guess they figure if you are reading them on your desktop, no need to alert you on your iOS device. Makes sense.

xxBURT0Nxx
Feb 19, 2012, 07:05 PM
the alerts don't play because if you are in the app on your mac it assumes that you see the message appear. If you are not in the app, it plays an alert on all devices. Again though, your phone must be set to get messages from both the phone number and email, or you will not get the alerts/messages on phone.

JohnDoe98
Feb 19, 2012, 07:35 PM
the alerts don't play because if you are in the app on your mac it assumes that you see the message appear. If you are not in the app, it plays an alert on all devices. Again though, your phone must be set to get messages from both the phone number and email, or you will not get the alerts/messages on phone.

Right

sik08amg
Feb 19, 2012, 08:09 PM
Instead of it deciding for us the entire time, maybe a toggle on the app that the user can control. I prefer the app full screen which puts it in the background so my phone is constantly buzzing when I'm doing what everyone does on the internet. I actually think my battery on my phone dies quicker now even though I haven't been texting from it. Maybe a notification on the devices that the switch has been enabled, and you have the option to deactivate it or activate it from any of the devices. Seems pretty simple.

Drew

pmz
Feb 19, 2012, 08:12 PM
Its called: BETA

Although, I feel that iMessage has never come out of out beta. There has been tremendous confusion and complication over the fact that an "iMessage" sent from a mobile number to a mobile number, does not sync with iMessage on, say, your iPad, even though you have iMessage enabled on both devices, and the same e-mail address registered.

People who message me shouldn't have to specifically choose my e-mail address instead of my phone number...the tendency is to do the opposite. So while iMessage syncing across devices is great in concept, its a failure in practice because Apple did not bother to workout the handling of iMessages sent to your phone number.

sik08amg
Feb 19, 2012, 08:47 PM
Yes I agree, and that only means that they will improve all angles. Regardless of the end result, I know I will be satisfied. I have yet to have an apple product let me down.

Gemütlichkeit
Feb 25, 2012, 08:12 AM
the alerts don't play because if you are in the app on your mac it assumes that you see the message appear. If you are not in the app, it plays an alert on all devices. Again though, your phone must be set to get messages from both the phone number and email, or you will not get the alerts/messages on phone.

Good tip. I set it up on my phone before reading your post and was confused as to why my phone was alerting me haha.

I hope there's more ways to tweak this in the future. I feel the IM's should go to all devices but only alert on the one that's currently active. Hope they can program that in somehow.

hafr
Feb 25, 2012, 09:37 AM
It's not a bug... it is based on how you have your settings configured....

to get them to show on your phone, you need to go to settings, messages, make sure that both your mobile number and email are set to retrieve, and then set caller ID to EMAIL so that when you send messages they reply to your email. email imessages are the only ones that appear on all devices. anything sent to or from your mobile number will only appear on a mobile device.

Since it happens anyway, I'd say it's a bug...

I've gotten messages sent to my Apple ID that showed up on the phone but not on the computer, and then ten minutes later the opposite happened. In the same conversation...

Also, messages sent to my phone number appears on the computer. I'm guessing this is because I've added my phone number in my Apple ID info online.

----------

Yes I agree, and that only means that they will improve all angles. Regardless of the end result, I know I will be satisfied. I have yet to have an apple product let me down.

Have you used iMessage on several devices? And you're satisfied? Okay... Or why not the fact that read-status isn't pushed on iCloud, meaning any e-mail I read on the computer is still marked as unread on the phone until I manually update by opening the app?

Fynd
Feb 25, 2012, 09:46 AM
BURT0N is correct. Set your Caller ID on your phone to your apple ID. This isn't an actual issue. You are just using it now in a way that when you text from your mac your friends get an imessage from whoever@me.com, and when you text from your phone they get your number so you're name is in their inbox twice, and messages go to whichever they reply to. Set caller ID to email, and all messages in/out will come from/go to your email.

If setup up properly, when you come back to your computer and first open it up, you'll hear Messages go berserk as it fills in all the texts you received while away on your phone.

hafr
Feb 25, 2012, 10:41 AM
BURT0N is correct.
Burton is as wrong as you are. Either you lot are luckier than my friends and I, or you haven't tried it out as thoroughly as we have, or you're just saying what you think is correct.

Set your Caller ID on your phone to your apple ID.
I have.

This isn't an actual issue.
Do you think I'm lying about the multiple threads, or having set the same Caller ID? Or do you just not think it's an issue that multiple threads are being created?

You are just using it now in a way that when you text from your mac your friends get an imessage from whoever@me.com, and when you text from your phone they get your number so you're name is in their inbox twice, and messages go to whichever they reply to.
Having the same Caller ID set on the phone and on the computer sometimes generates two threads on the receiving end (one for the phone, one for the computer), sometimes it doesn't. It seems to be random at best. Either it's a bug that multiple threads are being created, or it's a bug when messages (with the same Caller ID) from the computer and the phone end up in the same thread. Either way, since it's not consistent - there is something wrong.

Set caller ID to email, and all messages in/out will come from/go to your email.
Incoming messages have nothing to do with which Caller ID you've chosen. And despite having the same Caller ID on several devices, it sometimes creates several message threads on the receiving end, with the same e-mail address being highlighted in blue (indicating that the Caller ID setting on my phone and my computer is in fact identical).

Sending and receiving in the hundreds of messages on the phone, the iPad and the computer every day since the release of iOS 5 and the beta of Messages respectively, I promise you I haven't missed the Caller ID setting...

The only way it never starts multiple threads is by all participants in a "chat" always sending from the same device.

Gemütlichkeit
Feb 25, 2012, 12:00 PM
This is still confusing.

What I want to happen and what Apple has setup aren't the same thing.

What I want: OSX Messages to take priority when messaging people with iOS devices. When I'm no longer using OSX Messages it should default to my iOS device.

What's actually happening: Messages go to both my Air and iPhone. Even when I'm strictly messaging someone from the Air, it still alerts to my iOS device which is weird.

I have my iOS device setup with both my phone number and apple ID. It's caller ID is set to my phone number.

My Air is of course set to receive to my Apple ID.

When I set both to Apple ID then I don't get alerts on my phone that someone messaged me.

Weird.

LiesForTheLiars
Feb 25, 2012, 12:19 PM
That's how it works, at least for me. Your messages are sent to all devices using your Apple ID. It can be annoying, but I don't think they're going to change that. What bothers me is if someone with two devices on messages someone using Messages, it sends the sane message twice from both devices. At least on your end you're only getting one message on two devices.

Gemütlichkeit
Feb 25, 2012, 01:09 PM
I've just removed Apple ID from iMessage on my phone.

Conversations don't sync up now and I'm back to where I started haha. Best solution so far.

kuwxman
Feb 28, 2012, 01:14 AM
My Messages does sync with my phone now. I am happy, lol.