PDA

View Full Version : Please help with my Powerbook 12" problem




indialogue
Mar 17, 2012, 03:29 PM
I unfortunately made the mistake of installing Leopard on my early-2005 12" Powerbook 1.5 Ghz (stock except for a RAM bump to 1.25GB). It had been running fine till then. I've spent the past 1-2 months trying to resuscitate this laptop on the weekends and reading through different help articles, but to no avail.

The issues that I'm facing are:

It manages to go through the boot process only on rare occasions, works fine till it gets to the password screen, and then hangs as it enters the desktop
It mostly hangs on a blue screen after going through the grey screen with the apple logo
I cannot boot into the Safe mode at all - I've tried multiple times
I cannot boot into verbose mode as well
I can boot into Single-user mode. However, once I start the recommended fsck test, it hangs I think because there is no movement beyond the "Checking Catalog" text
I tried starting from the Mac OS X Install disc - I have the old Powerbook install disc (10.3) as well as the Leopard install disc (10.5), but neither of them are working. The 10.3 disc despite being the original disc that came with the Powerbook, keeps being ejected out
I can get into the Target Drive Mode but it is very very very slow and stutters and I cannot select the 10.5 startup disc even though it is visible there. The 10.3 disc never comes up in the Target Drive Mode


Some of the things that I've checked and would like your advice on are:

Reset of NVRAM has been done
PRAM as well
Startup chime comes on most of the time
Only one time did the faulty RAM signal come - 3 beeps and then the sleep light kept blinking in some pattern (at least I think it was). This has only happened once
The Powerbook has issues with the fan for a long time - its very noisy and once when I opened up the laptop to clean it with some compressed air, I might have scraped off some of the thermal paste. I dont know if overheating is also exacerbating this issue
Could it be a problem with the PMU - I can't verify this but in single User Mode it displays an error saying check PMU and states that year is 1904?
I don't know if its a problem with the HDD - its a HDD replaced by Apple in 2006 so it is old but before installing Leopard its SMART status was always good. Don't know why it would give out suddenly
I have taken it to the local Apple repair centre but they passed it off as being a "logic board issue". I don't really buy that because if it was so - the laptop wouldn't be able to startup, would it?
If it is a problem with the HDD how do I confirm that? I have a 2010 Macbook but as I'm facing issues with the Target Disk Mode, don't know if I can connect the two (plus no Firewire on the Macbook)
I unfortunately do not have a mirror backup of my Powerbook to try and boot off that as well


I would really like to get this Powerbook working again - I love the 12" form factor, the matte screen, the keyboard - I could go on and on. Please do try and help me solve this through - worse comes to worse I dont mind spending a 100 quid in getting a new logic board as well but would prefer to just make do with what I have right now. Thanks for all the help that you can provide!



skinniezinho
Mar 17, 2012, 04:19 PM
What about taking off the hard drive, put it on a enclosure,install 10.3/10.4/10.5 on other mac (it seems to me that you may have some problem with the optical drive too) and trying to run again?
You should be able to do it with target mode too :S
If you have a backup dmg/iso of the MacOS you can make a bootable hdd/pen and install with it instead of the cds...
About the logic board,go to the FAQ on my sig, search for apple hardware test, download the one for your powerbook and burn it to a cd, if you have a logic board issue it will tell you, and other issues too..

QuarterSwede
Mar 17, 2012, 04:37 PM
Sounds like a possible HDD failure. My 12" 1.5GHz 1.25GB PowerBook is running Leopard just fine (it's my file server).

My father had issues with his HDD on an iMac (didn't know it) when he went to upgrade from SL to Lion. It completely failed during the install.

eyoungren
Mar 17, 2012, 04:55 PM
I have taken it to the local Apple repair centre but they passed it off as being a "logic board issue". I don't really buy that because if it was so - the laptop wouldn't be able to startup, would it?

It's quite possible. I had a PowerBook G4/400 (Titanium) that had the logicboard go bad. Still chimed and booted but froze every time I got close to the login window. I bought a replacement board and everything was fine - until my daughter sent it flying off the couch. It then began exhibiting the same symptoms again, only this time it would actually boot but freeze after a while. I could keep it on with little tricks (sleeping it mainly) but eventually it would freeze again.

To me it sounds like you have multiple issues. Probably your PRAM battery and a bad hardrive. The fact that the HD is working slowly over Target Disk Mode indicates (to me) either a bad hard drive, a bad port (indicative of logicboard failure) or both. I had the same issue with the second logicboard. Even though I could keep the Mac on, the firewire port would not work correctly.

Just my assessment. I'm no expert.

indialogue
Mar 18, 2012, 07:45 AM
New development - I had put the laptop on for the whole night, seeing if fsck would finally finish running. Got up in the morning and it was dead. On restarting, there is no more startup chime, the fan immediately starts off into overdrive, the num lock has stopped lighting up (caps lock still does) and the screen remains blank. PMU reset is also not helping.

I'm going to try skinniezinho's suggestion and remove the hdd into a portable enclosure and see if I can access/repair it from my other mac. I just wish that removing the hdd wasn't such a pain in the Powerbook :mad: I'm just hoping that it is not a logic board failure - I don't mind spending for small parts such as the PRAM battery and fan but plonking 100 bucks plus for a logic board with questionable life again doesnt seem like a wise option. Any suggestions otherwise?

Anyways, keeping the hdd removal for the next weekend - will keep you all updated if it works. Thanks a lot for the suggestions so far

skinniezinho
Mar 18, 2012, 09:33 AM
New development - I had put the laptop on for the whole night, seeing if fsck would finally finish running. Got up in the morning and it was dead. On restarting, there is no more startup chime, the fan immediately starts off into overdrive, the num lock has stopped lighting up (caps lock still does) and the screen remains blank. PMU reset is also not helping.

I'm going to try skinniezinho's suggestion and remove the hdd into a portable enclosure and see if I can access/repair it from my other mac. I just wish that removing the hdd wasn't such a pain in the Powerbook :mad: I'm just hoping that it is not a logic board failure - I don't mind spending for small parts such as the PRAM battery and fan but plonking 100 bucks plus for a logic board with questionable life again doesnt seem like a wise option. Any suggestions otherwise?

Anyways, keeping the hdd removal for the next weekend - will keep you all updated if it works. Thanks a lot for the suggestions so far

First try to run Apple Hardware Test from a cd/hdd, that will save you future time waste..

indialogue
Mar 18, 2012, 02:04 PM
First try to run Apple Hardware Test from a cd/hdd, that will save you future time waste..
Can't do that because it does not boot from the CD despite pressing "c" and anyways the screen has also decided to go blank. Funnily, the apple startup chime is working now but screen/num lock is still dead

skinniezinho
Mar 18, 2012, 03:51 PM
Can't do that because it does not boot from the CD despite pressing "c" and anyways the screen has also decided to go blank. Funnily, the apple startup chime is working now but screen/num lock is still dead

try with alt...
And you can "burn" it to a pen/hdd using disk utility