PDA

View Full Version : Digital Audio G4 won't boot with Radeon 9600 XT installed




Jethryn Freyman
Mar 23, 2012, 10:58 PM
So, I've got a 466MHz Power Mac G4 (Digital Audio model.) It's in fine working condition and works perfectly with the stock ATI Rage 128 Pro installed. Anyway, I recently upgraded my G5 tower from a Radeon 9600 XT to an X800 XT, and decided I'd try sticking the 9600 into the G4, as it'd be a nice improvement over the oldschool Rage card. The 9600 is in perfect working order.

Anyway, I put the 9600 in, closed up the case, hit the power button... and nothing. Opened it back up, reseated the 9600, made sure there wasn't any dust in the way, tried again. No signs of life whatsoever. Put the Rage 128 back in, boots fine.

What's going on here? I'm sure that the Radeon 9600 XT is a 4x AGP card, and that the Digital Audio G4 is 4x AGP (whereas the G5 tower is 8x AGP.) Maybe the card draws too much power? Wouldn't have thought so. Driver problem? (I'm running fully updated 10.5.8.) The gold AGP connections on the Rage Pro and the 9600 XT are different, but fit fine into the slot. And the small nub of a pin on those two cards closest to the actual display ports is absent from the X800 XT.

Pictures of all three cards below :)

Red = X800 XT aka FireGL X3 (works fine in G5, not tried in G4)
Blue = Radeon 9600 XT (works in G5, not in G4)
Green = Rage 128 Pro (works fine in G4, not tried in G5)

http://i.imgur.com/zjqMv.jpg

http://i.imgur.com/Mx3fc.jpg



Jethryn Freyman
Mar 24, 2012, 01:18 AM
Oh wait, wikipedia says that the standard Radeon 9600 XT is 8x AGP. Though sites say it should would with a DA Power Mac. Do I need to tape pins over or something? Weird though that pressing the power button doesn't do a thing..

Dave H
Mar 24, 2012, 01:34 AM
The 4 and 11 pins (http://themacelite.wikidot.com/pins-3-and-11) need to be taped on 8x AGP cards when used in a Gigabit Ethernet or later G4.
The G4 will act completely dead otherwise until the card is removed or taped.

The 9600 card may or may not work in a Digital Audio. A black screen is a common problem. I had a Radeon 9600 card that worked in my G4 DA, then I "upgraded" to a 9600XT that gave a black screen on 9 out of 10 startups.
Compatibility chart (http://themacelite.wikidot.com/compatibility)

Jethryn Freyman
Mar 24, 2012, 05:07 PM
The 4 and 11 pins (http://themacelite.wikidot.com/pins-3-and-11) need to be taped on 8x AGP cards when used in a Gigabit Ethernet or later G4.
The G4 will act completely dead otherwise until the card is removed or taped.

The 9600 card may or may not work in a Digital Audio. A black screen is a common problem. I had a Radeon 9600 card that worked in my G4 DA, then I "upgraded" to a 9600XT that gave a black screen on 9 out of 10 startups.
Compatibility chart (http://themacelite.wikidot.com/compatibility)
Brilliant instructions and link, thanks! Will try this today.

Dave H
Mar 25, 2012, 01:03 PM
I meant the 3 and 11 pins. Sorry about that...

Jethryn Freyman
Mar 25, 2012, 05:55 PM
I meant the 3 and 11 pins. Sorry about that...
ha, yes I figured it was a little typo :)

reddrag0n
Mar 28, 2012, 04:36 PM
Sounds like pins 3 & 11 are causing it not to boot right.

this site will help you out on how to fix the problem

The Mac Elite Pins 3 and 11 (http://themacelite.wikidot.com/pins-3-and-11)

MacVidCards
Mar 30, 2012, 04:30 PM
Glad to see my "3 & 11 pin taping" article is still getting use. Shot the pix on my back patio.

The x800 will work in DA and is even easier than G5 in that the power plugs are handy.

Jethryn Freyman
Jul 3, 2012, 09:19 PM
I think I might give this a go today. The old 9600 has just been sitting around for 4 months, might as well have some fun. Will post benchmarks later :)