PDA

View Full Version : ATV takes forever to stream/download content from iTunes store




badlydrawnboy
Mar 26, 2012, 10:39 PM
I have a new ATV (1080p) hooked up to my wireless network. It was working perfectly until today. All of a sudden it's taking a long time to download/stream content. For example, I just purchased a new episode of a TV series, and it says "Ready to play in 23 hours".

There doesn't appear to be anything wrong with my network. I have two computers connected via Ethernet, and an iPad and iPhone connected wirelessly, and they're all fine. Did a speed test and am getting 30 MB/s down and 5 MB/s up.

Any ideas? How do I troubleshoot this? I've power-cycled the modem and router three times, to no avail.



elmo151
Mar 27, 2012, 05:14 AM
not quite forever. it runs faster than the "warning"

SandboxGeneral
Mar 27, 2012, 05:51 AM
I think it may be a software issue. I have the ATV2 and ATV3, and since the latest software update, many times it takes a minute or so for the show to start, whether it be on iTunes, Netflix, or a podcast.

I have a really nice connection and have checked my network for problems, and found none.

Plus my podcasts are not showing watched anymore, the blue unmatched badge icon remains on all of them on both ATV's.

badlydrawnboy
Mar 27, 2012, 09:10 AM
Don't think it's a software issue in my case. Was working perfectly until yesterday. I had to reset my router just before that, come to think of it, so it may be something with the wireless connection. But my other computers seem to be accessing the wireless fine, so I'm not sure why the ATV isn't.

blevins321
Mar 27, 2012, 09:41 AM
I've noticed mine is very sluggish, even though I have a 30MB connection. The ATV3 is wired through a switch to the router, too, so I know its not a wireless problem. Maybe they'll improve the network behavior on the first software update.

Shoesy
Mar 27, 2012, 12:02 PM
I get this sometimes, but I assume these days it's my cable provider capping my downloads.