PDA

View Full Version : [Resolved] New ATV - Photos repeating in slideshows




smithrh
Mar 27, 2012, 09:37 PM
Well, for sure in the Origami one.

I have a library of about 10k images and for some reason my new 1080p ATV really fixates on about 100-200 of them and keeps showing them repeatedly, sometimes even showing the same image within a few cycles.

Note that the ATV2 had a very similar issue that was fixed fairly quickly, but it's a bit disappointing to be running into what seems to be the very same issue again.

I do have "repeat slides" off and it's in random play.

For some reason, I really like starting up music and watching the images go by, I can do it for hours sometimes - so I hope this gets fixed quickly, the images look SUPER in 1080p!



hafr
Mar 28, 2012, 01:29 AM
Well, for sure in the Origami one.

I have a library of about 10k images and for some reason my new 1080p ATV really fixates on about 100-200 of them and keeps showing them repeatedly, sometimes even showing the same image within a few cycles.

Note that the ATV2 had a very similar issue that was fixed fairly quickly, but it's a bit disappointing to be running into what seems to be the very same issue again.

I do have "repeat slides" off and it's in random play.

For some reason, I really like starting up music and watching the images go by, I can do it for hours sometimes - so I hope this gets fixed quickly, the images look SUPER in 1080p!

How did you fix it for the ATV2? I've got an ATV2 on 4.4.4 and I've got the same issue...

smithrh
Mar 28, 2012, 08:01 AM
How did you fix it for the ATV2? I've got an ATV2 on 4.4.4 and I've got the same issue...

If I recall right, one of the software releases that came out after the ATV2 had been out for a few months fixed the issue. Nothing I did personally.

heisenberg123
Mar 28, 2012, 08:10 AM
If I recall right, one of the software releases that came out after the ATV2 had been out for a few months fixed the issue. Nothing I did personally.

well Random is Random

Reapeat on or off would most likely be more for if you had them show in order once it got to the end of the folder it either repeated the process or stopped

since it required a software update to fix on ATV2 maybe that same will happen for AT3?

hafr
Mar 28, 2012, 08:27 AM
If I recall right, one of the software releases that came out after the ATV2 had been out for a few months fixed the issue. Nothing I did personally.

Seems weird that the same problem would arise in a later version of the ATV2 OS... Oh well.

smithrh
Mar 28, 2012, 09:38 AM
well Random is Random


One would expect that if "repeat pictures" is set to "no" then pictures wouldn't... repeat - even if on Random.

Otherwise one would expect that the repeat function setting would be unselectable.

heisenberg123
Mar 28, 2012, 09:47 AM
One would expect that if "repeat pictures" is set to "no" then pictures wouldn't... repeat - even if on Random.

Otherwise one would expect that the repeat function setting would be unselectable.

couldnt repeat on off be use for people who play the photos in order, once it gets to the end of the list it repeats or stops based on the selection?

smithrh
Mar 28, 2012, 10:06 AM
couldnt repeat on off be use for people who play the photos in order, once it gets to the end of the list it repeats or stops based on the selection?

Oh - good point, hadn't thought of that. At 10k photos I wasn't going to get there!

But random should still mean random and photos shouldn't be repeated (very) frequently the way they are currently.

heisenberg123
Mar 28, 2012, 10:13 AM
Oh - good point, hadn't thought of that. At 10k photos I wasn't going to get there!

But random should still mean random and photos shouldn't be repeated (very) frequently the way they are currently.

i agree, even on my MBP I have about 200 photos in a folder set to change every minute for my wallpaper and i see repeats way more often than every 200 pictures, not sure why that is but ive seen it on other random playlists too like my ipod

smithrh
Mar 28, 2012, 11:42 AM
I let Apple know.

If you set it to not shuffle, it works. I can see it hitting my server getting new images every now and again, say, every 20-30 seconds or so.

Why it gets lazy on shuffle, no idea, but I can see it load up a bunch of images initially then much much less frequently it goes to get a few more.

I suspect this is an easy bug to fix, but somewhat disappointed it wound up in there again after it happened on ATV2.

The images look AWESOME in 1080p, that's for sure - unlike the new iPad where most of them are blurry for some reason. I let Apple know about that too... gotta have Origami working!

takeshi74
Mar 28, 2012, 12:33 PM
But random should still mean random and photos shouldn't be repeated (very) frequently the way they are currently.
As stated above, random is random. Repeats can and do happen on random.

smithrh
Mar 28, 2012, 02:39 PM
As stated above, random is random. Repeats can and do happen on random.

Not the way it's working now, of course - or I wouldn't have brought it up.

:D

Update:

I find that if I press the > button a few times in a row I can get the ATV to start showing new slides.

smithrh
Sep 24, 2012, 04:38 PM
Fixed on 5.1.

bobhawes
Dec 30, 2012, 01:11 PM
x