PDA

View Full Version : MacBook Air trackpad issues?




Nilscollection
Mar 29, 2012, 12:55 AM
Hi everyone,

A friend of mine has some issues with the trackpad of his 2010 MacBook Air.
About two weeks ago, he stated that his trackpad was a bit messed up because when he just wanted to move his cursor, the trackpad reacted as if he clicked and dragged.

I first tried to repair disk permissions, reset the PRAM / VRAM but that didn't work out.
I then proceeded doing a hardware test that came with the Snow Leopard-stick, but it said everything was just fine so I reinstalled OS X Lion from the recovery-partition - but that didn't solve the problem either.

I then used my own copy of OS X Lion (USB-stick) to reinstall OS X, and for now it works properly but I'm still not sure if it's completely gone.

I've Googled the issue, but it doesn't seem like a widespread one. I was wondering if anybody else has had this problem and if so, how they've solved it?

Regards,
Nilscollection

EDIT // I've also tried both our Magic Mice, but they react the same way as the trackpad - assuming that the trackpad is a USB-device and the Magic Mouse a bluetooth-device, does this mean that it's not hardware bound?



nblewis
Apr 15, 2012, 09:46 AM
my macbook air 2010 is having similar issues. I brought it in to the apple store but it wasn't having the issues when they looked at it, so they claimed it was user error, but now it is much worse. Just wondering if you ever solved the issue.

bingeciren
Apr 15, 2012, 11:49 AM
I had the same problem when I received my Air the first day. At first I thought it was a software issue. It would stick, move erratically, act as if it was being right clicked when it wasn't. Anyway, I took it to the store and left it to be serviced. At first they didn't notice the problem and returned the machine with the problem unsolved. Next day I took it back to the store and demonstrated the problem there. This time they correctly diagnosed the problem as being a faulty trackpad and replaced it. That solved the problem and it was the end of the story. Have them replace the trackpad.

oginome
Apr 15, 2012, 02:40 PM
I'm sure it's the hardware problem. Trust me.

tecknik1
Apr 15, 2012, 08:16 PM
Same has above, Its a faulty trackpad. I had the same problem on my Air 4.2.
After reseting PRAM reinstall Lion same same and finally Apple service said its the trackpad, Had it replaced for free and works now no problem.