PDA

View Full Version : iMac G4 oddities




mentaluproar
Apr 11, 2012, 10:59 PM
Back when this 700 MHz iMac was new, the CDROM died on it. Out of curiosity, I tore it apart to see what there was to see. The IDE cable was unique in that one of the wires didn't feed straight through, but was switched to a different pin. Thinking this was a weird thing, I tried changing it out to see if that fixed the issue. Obviously it didn't, but it was such a pain to work with that I didn't put the old cable back in. (one of the holes for the screws was cross threaded and to this day, is a nightmare to pull out.)

Years later, I find it in storage, and order a new DVD burner from OWC, some ram, and replace the PRAM battery. Tada, it works again, but with a few issues.

First, the system takes forever to boot if I manually set master to the hard drive and slave to the CDROM. Cable select lets it boot very quickly, much after than my i5 Mac mini. However, if I use open firmware, the computer confuses the CD rom for the hard drive, and vice versa. The only way to boot off CD is by telling it to eject the hard drive, then boot from the cd in the alleged hard drive. The OS (either OS 9 or tiger) has no such problem identifying the drives properly. I'm guessing it uses a different method to identify drives.

Target disc mode does not work. The system simply turns off when I try.

I don't have a wired Mac keyboard anymore. The wired PC keyboard won't let me into open firmware with super-alt-O-F. Odd.

Any ideas on how to rectify the drive identification issue? I think I read somewhere a long time ago about a reverse cable select cable, but I can't find that article anymore. Any ideas what I am doing wrong with getting into OF?