PDA

View Full Version : Problem installing Linux on iBook G3




BrianMayFan123
Apr 16, 2012, 04:22 PM
----------

I have an iBook G3 (500Mhz, 384mb RAM with an upgraded DVD RW) which I have recently decided would be much better put to use as a Linux Lappy.

I have used Linux before on Intel based machines with little or no difficulty
However I have tried multiple times to install PPC linux distros on my iBook and all have failed for one reason or another.

I have attempted Ubuntu 6.04/7.04, Mint PPC, Debian and Yellow Dog
Once or twice I have failed to even boot from CD/DVD, but the majority of the time I go through the installation routine which completes seemingly fine, but when the iBook reboots I'm given a corrupted, black screen which is unusable.

My iBook meets the minimum spec for the above distros so I'm a bit lost on where I've gone wrong

My question is, has anyone here tried something similar on an iBook G3 and had the same issue?

I'm sorry if I sound like a complete spiv but I'm much more confident with hardware rather than software



charlieegan3
Apr 16, 2012, 04:26 PM
I have a iBook G4 that had PPC Fedora at one point, it was so slow, unusable in fact.

Not to put you off but i don't think its worth it on a machine that old.

crewkid89
Apr 16, 2012, 04:37 PM
It's so tough to nail down specifics unless you know what distro you will be using. I would heavily recommend against using older versions because they are no longer supported. GNU/Linux distros don't necessarily get slower as they get newer. There are plenty of low resources distros out there to try out. I would recommend looking into whichever one you are already most comfortable with and seeking out documentation and advice through that distro's channels. Ubuntu has a pretty active sub forum for apple products and specific documentation for ppc macs. If you are comfortable with ubuntu I would start there.

www.ubuntuforums.org

Edit: PS as for anything else max out the ram and you will see significant performance improvement. Avoid 3D graphics and use lightweight versions of everything.

MacinDan
Apr 16, 2012, 06:44 PM
It sounds like you might have to manually edit your xorg.conf file to give you a working screen. Default horizontal sync and vertical refresh rates can sometimes be off. There's a little more here for MintPPC users:

http://www.mintppc.org/forums/viewtopic.php?f=10&t=504