PDA

View Full Version : ATV2 Remote Frustrations




JO3H
Apr 17, 2012, 09:05 AM
Any help on this will be appreciated. I tried the Apple Support Forum and no one responded. I've searched for a solution, but can't seem to resolve this issue:

When using my Apple TV with a remote (Apple TV Remote or Logitech Harmony One), the remote will take control of iTunes on my MacBook Pro.

I went into iTunes-Preferences-Devices and clicked "Forget All Remotes".

I also went to System Preferences-Security&Privacy-General and checked "Disable remote control infrared receiver".

I also tried turning off home sharing.

But the BLASTED thing still controls the MacBook Pro!!!

Am I missing something?

I am running current software on ATV2 and MacBook Pro.

Thanks!!!



maturola
Apr 17, 2012, 09:11 AM
You need to unpair the remote before disabling the infrared.

1)Choose System Preferences from the Apple () menu in the upper-left menu bar.
2) Choose Security from the View menu.
3) Click the lock and enter your Administrator password if necessary.
4) Click Unpair in the Security pane.
5) Use the Security pane in System Preferences to turn the infrared ("IR")
reception on your Mac off (or back on). To do this:
6)Choose System Preferences from the Apple () menu in the upper-left menu bar.
7)Choose Security from the View menu.
8)Click the lock and enter your Administrator password if necessary.
9)Select the "Disable remote control infrared receiver" checkbox.

mawool01
Apr 17, 2012, 09:13 AM
Go to System Preferences

Security & Privacy, General, click the lock at the bottom to make changes, then select disable infrared receiver. This will fix your problem.

bucksaddle
Apr 17, 2012, 09:42 AM
Go to System Preferences

Security & Privacy, General, click the lock at the bottom to make changes, then select disable infrared receiver. This will fix your problem.

You obviously didn't read the original post where he specifically mentions he has done this.

To the OP - have you tried pairing the remote directly with the Apple TV?

Lunchbox700
Apr 17, 2012, 10:30 AM
Weird. I use a Logitech Harmony so don't have this problem.

waw74
Apr 17, 2012, 10:33 AM
Pairing does nothing to the remote, it's all about the receiver. so pairing with the aTV will do nothing to the response of the macbook.

each apple remote has an ID code (a number between 0 and 255), when you hit play it sends that number and then the command for example 76-play. what pairing does is tell a receiver to only listen to a certain number, and ignore the rest.

I've heard (but can't confirm) that when you press the menu and next button on the remote to pair it, it will randomly pick a new code. This would help if you get 2 remotes with the same code.

so if both devices happen to be paired to 81, then they'll both respond
Is it possible your macbook also "saw" the pair commend you sent to the aTV? try turning off the macbook, and re-pairing the aTV. see if that clears it up.

if all else fails there's always duct tape on the IR receiver of your macboook.

JO3H
Apr 17, 2012, 12:15 PM
i am going to try to unpair the remote from system preferences tonight and let you guys know what happens; that is the only thing i haven't tried yet. I thought disabling the infrared receiver would be a catch-all, but not in this case.

i also read something about the atv2 receiving the infrared signal and then sending some sort of a message to the macbook pro via my wireless network. the suggestion for that was disabling home sharing, but that was apparently BS. i can't find the link to that piece right now. the problem with that is i really like homesharing for looking at pics and pulling up old/random music & video i don't have sync'd to my iphone.

thanks again, everyone!

waw74
Apr 17, 2012, 02:50 PM
the aTV will only send control signals back if you're using air tunes to play audio from iTunes on your computer (or iOS device). You would have to start the playback on the other device, and then pick the aTV as the output.

if you go into the computers section on the aTV, it will let you access the library on your computer, but will play the media on the aTV and not in iTunes.

JO3H
Apr 17, 2012, 06:50 PM
I finally figured it out.

Despite having disabled the IR receiver, etc, etc, etc, it was still enabled by a driver/plug-in called candelair. I had an app on my iPhone many moons ago called Remote Buddy. I used it to control my old macbook pro when I had it connected to my TV directly (pre ATV2). I deleted the app a long time ago, but still had this candelair driver/plug-in installed on the macbook pro; it carried over when I migrated all my data from time capsule backup.

It was in system preferences under "other". I guess this candelair overrides disabling the IR receiver under the Security & Privacy preferences.

Candelair is produced by iospirit and is known as "the bright IR driver".

Thanks all for your suggestions!!!
:)

Mdmaloneymd
May 15, 2012, 07:49 PM
I had waisted several hours on the same problem before I found this post. Thanks for figuring it out.