PDA

View Full Version : No connection from ATV2 to iTunes until Library is restarted




AtomicEdge
Apr 18, 2012, 04:37 AM
I currently have a 2011 Mac Mini boosted to 8gb of RAM that I use as a server which my two ATV2's hook up to.

Most of the time it's fine, but I get the following every 2 or 3 days:


Highlighting the Computers icon on the ATV2 menu doesn't bring up recently added things at the top like normal but it just shows the :apple:
I can select the logo, and it shows me the options of Music, TV Shows, Movies etc and I can select the one that I want.
After selecting a choice I get a "Connecting to [My Library Name]" with a spinning disk icon and it never goes away and never loads.
Restarting the ATV2 does nothing to fix the issue.
HOWEVER, it will work on one ATV fine, but not the other.
It's not consistant which of my ATV's get's this issue. One is on Wifi, the other ethernet.
Restarting iTunes on my Mac Mini fixes the problem, but as it doesn't have a screen attached, I have to remote in, which is a pain.


Also it's worth noting that I have had the same from a different iTunes library, running from a friends laptop using iTunes on Windows, and that I have recently replaced my router and I'm still getting the issue.

Does anyone else get this problem? It's one of the few things that makes it hard for me to suggest an ATV/iTunes solution for less tech savvie people like my Mum!



Frosticus
Apr 18, 2012, 04:43 AM
I sometimes get a similar problem. Usually restarting iTunes does the trick - an easy workaround, but I agree this problem should be fixed...

chenks
Apr 18, 2012, 04:44 AM
is the mac mini going to sleep?

AtomicEdge
Apr 18, 2012, 04:49 AM
is the mac mini going to sleep?

Nope, I have it set to never sleep, and as I say, it can work fine on one library but not the other.

waw74
Apr 18, 2012, 11:08 AM
i've had similar problems in the past with airtunes, showed up but wouldn't connect. (had an express joining my existing network)

a reboot of the main router fixed it right up.

might not fix it, but won't hurt anything to try.

urkel
Apr 18, 2012, 01:35 PM
Same with ATV3. My daughter uses it throughout the day and it works fine, but every morning we get a phantom connection to the Mac Mini (2011) so I have to go to the other room and restart iTunes. That does the trick but im glad to see im not the only one because that indicates it may be a bug.

WhatAmI
Apr 18, 2012, 03:57 PM
Same setup and problems here... 2011 Mac Mini that never sleeps and ATV2&3 which are always on and after an extended time left unused I often need to restart iTunes to access my library

Scarpad
Apr 19, 2012, 09:09 AM
I have the same problem, also if I restart, watch say an hour tv program, after the show is over I've lost connection again. It's extremely frustrating, and I wish Apple would acknowledge this issue.

AtomicEdge
Apr 19, 2012, 09:52 AM
Looks like this is a pretty common issue then. Good to know I don't have some rare bug that Apple will never look at. Instead I have a common bug they will never look at! ;)

I do wish that Apple were a little bit more open and on the ball with ATV bugs. Random and seemingly pointless redesigns are waaaaaay down my list...

chenks
Apr 19, 2012, 10:48 AM
Looks like this is a pretty common issue then. Good to know I don't have some rare bug that Apple will never look at. Instead I have a common bug they will never look at! ;)

I do wish that Apple were a little bit more open and on the ball with ATV bugs. Random and seemingly pointless redesigns are waaaaaay down my list...

Don't base a few replies on a forum as whether something is common or not.

With regards to being open about bugs etc... how many other major tech companies are open about bugs and/or issues? They are the same as any other company.

urkel
Apr 19, 2012, 11:19 AM
Looks like this is a pretty common issue then. Good to know I don't have some rare bug that Apple will never look at. Instead I have a common bug they will never look at! ;)
:D
It's always interesting what bugs Apple chooses to address and which ones they just rely on their super fans to deflect by aggressively label legitimate complaints as "whining" and complainers as "trolls". ITunes itself is overflowing with bugs that end users have just accepted as "normal behavior" because after so many years then complaining just feels pointless and we get sick of being told "it's not the product, it's the user". :p

Sedulous
Apr 19, 2012, 12:54 PM
This used to happen to me all the time but not anymore.

WhatAmI
Apr 19, 2012, 04:50 PM
This used to happen to me all the time but not anymore.

:confused: Not since you streamed Pocahontas in HD or was there any other magic doing that rectified the issue many seem to be experiencing :confused:

Sedulous
Apr 19, 2012, 07:01 PM
:confused: Not since you streamed Pocahontas in HD or was there any other magic doing that rectified the issue many seem to be experiencing :confused:

Honestly, I wish I knew. Homesharing is stable and I never have to restart iTunes. Netflix remains a bit buggy. So I figure maybe it has something to do with iTunes (v 10.6.1).

NightStorm
Apr 19, 2012, 08:08 PM
Really wish Apple would just make home sharing a service that could run without iTunes being open all of the time. I experience similar issues to everyone else every 2 or 3 days.

richpjr
Apr 29, 2012, 05:13 PM
This is really annoying. It happens to both an ATV2 and ATV3 that I have in our house. I seem to have to restart iTunes at least every other day.

tootall
Apr 30, 2012, 07:43 AM
Homesharing is not stable for me. I have to restart iTunes once or twice for the apple TV to recognize it. Oddly, my iPod does not have any issues (recognizes home sharing all the time) while my iPad falls in between (better than ATV2 but worse than iPod).