PDA

View Full Version : my application not run on lower mac os x version.




mkristain
Apr 25, 2012, 06:06 AM
hi all,

my xcode version is 3.2.6 and mac os version is 10.6.8,

my application not working on lower version of mac os x like 10.5.6 or 10.5.8

and gives the message

"you cannot use this version of the application with this version of Mac OS X."

or

"you cannot open the application because it is not supported on this architecture."


please help how can i run my application on lower version of mac os.

thanks.



cMacSW
Apr 25, 2012, 08:53 AM
In your project settings you need to make sure you target 10.5, after setting this you may recieve warnings that some methods are not supported by this target and you will need to fix those.

gnasher729
Apr 25, 2012, 10:40 AM
please help how can i run my application on lower version of mac os.

thanks.

Since you ask: Change the SDK to 10.5, then change the deployment target in your build settings to 10.5 as well.

If your code compiles with the 10.5 SDK, you are fine. If not, and if you can't make it compile with the 10.5 SDK, then you are getting into advanced territory where your company should hire someone who knows what they are doing or give up on 10.5.


In your project settings you need to make sure you target 10.5, after setting this you may recieve warnings that some methods are not supported by this target and you will need to fix those.

Ignoring these warnings (better to change the build settings to turn all warnings into errors) means that your application will crash in these places when running on 10.5.

mkristain
Apr 25, 2012, 11:30 PM
Since you ask: Change the SDK to 10.5, then change the deployment target in your build settings to 10.5 as well.



I have changed Base SDK to 10.5 and Mac OS X Deployment Target to Mac OS X 10.5 ,but still the application is not run on 10.5.6

even i also test with Base SDK to 10.4 and Mac OS X Deployment Target to Mac OS X 10.4 and result is same.


my 10.5.6 machine does't have a Xcode , is this the reason that's why my application not run on this.

now what can i do for this..

gnasher729
Apr 26, 2012, 02:51 AM
I have changed Base SDK to 10.5 and Mac OS X Deployment Target to Mac OS X 10.5 ,but still the application is not run on 10.5.6

Tell us exactly what you are doing and what is happening. That's not only useful because it gives people a chance to help you, it is also very very useful because by articulating your thoughts and actions in a clear way you often figure out yourself what you are doing wrong.

mkristain
Apr 26, 2012, 03:42 AM
Tell us exactly what you are doing and what is happening. That's not only useful because it gives people a chance to help you, it is also very very useful because by articulating your thoughts and actions in a clear way you often figure out yourself what you are doing wrong.

in Project Settings 'Build Tab' in Architectures field for Base SDK i select the Max OS X 10.5

and in Deployment field for Max OS X Deployment Target i Select Max OS X 10.5,

thank build my application and trying to run this application on Mac OS X 10.5.6 here it gives error like 'you cannot open the application because it is not supported on this architecture'.

gnasher729
Apr 26, 2012, 05:34 AM
in Project Settings 'Build Tab' in Architectures field for Base SDK i select the Max OS X 10.5

and in Deployment field for Max OS X Deployment Target i Select Max OS X 10.5,

thank build my application and trying to run this application on Mac OS X 10.5.6 here it gives error like 'you cannot open the application because it is not supported on this architecture'.

If you look back to my post, I asked you to tell us exactly what you are doing. "Trying to run this application on Mac OS X 10.5.6" is not telling us exactly what you are doing. I have about five Macs around me. I can reproduce exactly what you are doing if you tell me what you are doing. If you don't tell me, I can't help. (To everyone else reading this thread, I can obviously _guess_ what he's doing but that is missing the point). You are probably a few thousand miles and 5 1/2 hours away from me. I can't read your mind.

Think about it: "It gives error like...". Who is "it"? How exactly does it give the error? What _exactly_ is the error? You really, really need to learn to write down things exactly. I only know that what you say is happening is impossible unless you made some additional changes in your project settings or failed to mention some essential steps when you were trying to run this application.

mkristain
Apr 26, 2012, 06:16 AM
I made a test application to get the version of MAC OS X on button clicking.

application created on Mac OS X 10.6.8 using xcode version - 3.2.6 ,

its working fine in 10.6.8 Mac OS X.

but when i double clicked to run this application on MAC OS X 10.5.6 than

than MAC OS X 10.5.6 gives error

"you can't open the application "Version_Test" because it is not supported on this architecture."

here Version_Test is my application name.


now please help me or guide me to out of this.

thanks.

Chundles
Apr 26, 2012, 06:30 AM
What sort of computer is your 10.5.6 machine and why isn't it running 10.5.8?

gnasher729
Apr 26, 2012, 07:51 AM
I made a test application to get the version of MAC OS X on button clicking.

application created on Mac OS X 10.6.8 using xcode version - 3.2.6 ,

its working fine in 10.6.8 Mac OS X.

but when i double clicked to run this application on MAC OS X 10.5.6 than

than MAC OS X 10.5.6 gives error

"you can't open the application "Version_Test" because it is not supported on this architecture."

here Version_Test is my application name.


now please help me or guide me to out of this.

thanks.

So to run on 10.5.6, did you reboot your computer from a partition or an external drive with 10.5, or what did you do? Remember that I asked _exactly_ what you are doing?

cMacSW
Apr 26, 2012, 08:00 AM
Also, I might add make sure you are setting the OS target and SDK values on the build target your actually building.

mkristain
Apr 27, 2012, 12:17 AM
mac os x 10.6.8 is Intel and 10.5.6 is Power PC is this the reason for this?

gnasher729
Apr 27, 2012, 03:15 AM
mac os x 10.6.8 is Intel and 10.5.6 is Power PC is this the reason for this?

You still have not answered the question - what exactly did you do? Look, in my company you would be considered unemployable because you have no communications skill at all. You seem to be unable to answer a straightforward question.

I can now guess whether you removed the motherboard from your computer and plugged in a different one with a PowerPC processor, or whether you made a copy of the application and installed it on a different computer. I guess you did the latter. I shouldn't have to guess, you should have told us so ages ago.

Intel code will not run on a computer with a PowerPC. The architectures that you can build for are: x86_64 (Intel 64 bit), i386 (Intel 32 bit), and ppc (PowerPC 32 bit), so you have to add ppc to the architectures in your build settings. i386 will run on all Macs with an Intel processor. x86_64 will run on all Macs with an Intel processor except the earliest ones, built around 2006, but will generally be faster. ppc will run on all Macs with a PowerPC processor. The latest XCode versions don't support building for PowerPC at all, so you need to decide if making your app work on PowerPC is worth the work or not. There are also substantial differences in the processors, so having an app work on PowerPC means complete testing of the whole application is needed.

mkristain
Apr 27, 2012, 05:43 AM
You still have not answered the question - what exactly did you do? Look, in my company you would be considered unemployable because you have no communications skill at all. You seem to be unable to answer a straightforward question.



i have already answer your question so many times,

i am just trying to run my application on 10.5.6 Mac OS X.

gnasher729
Apr 27, 2012, 10:31 AM
i have already answer your question so many times,

i am just trying to run my application on 10.5.6 Mac OS X.

You never, ever said that you copied the application onto a different computer. You didn't say it, and it was the one crucial bit of evidence that made it obvious what was happening. If you want to contradict me, please point out in which post you wrote that you were running the application on a different computer.

So no, you never answered the question that I asked.

mkristain
Apr 30, 2012, 12:36 AM
ok sir actually i have mentioned the two different version of MAC OS X,
so i think its sufficient to describe that i use two different machine,
its my mistake that i m not describe clearly.

now please help me to get out from this.

itickings
Apr 30, 2012, 03:04 AM
ok sir actually i have mentioned the two different version of MAC OS X,
so i think its sufficient to describe that i use two different machine,
its my mistake that i m not describe clearly.

No, you could very well have used exactly the same machine for both versions. And even if you think it is crystal clear that there are two machines involved, why not tell us what models they were? gnasher729 is being very helpful and patient with you, yet you ignore everything.

now please help me to get out from this.

That's impossible since you are not capable of reading posts or providing answers.
You have already been told what the problem most likely is, and the associated ramifications. Unless you provide more relevant information and explain why the answers already provided are no good, there is nothing more for you here.

gnasher729
Apr 30, 2012, 03:16 AM
ok sir actually i have mentioned the two different version of MAC OS X,
so i think its sufficient to describe that i use two different machine,
its my mistake that i m not describe clearly.

now please help me to get out from this.

You never said you used two machines. Tell me in which post you said you used two machines. You really have to read what people are posting. When I write "tell me exactly what you are doing", I except something like

1. I built a release version of the program using XCode 4.2.1 on an Intel Macintosh running MacOS X 10.6.6.
2. I took the compiled program from the "Release" folder in the "build" directory and burnt it on a CD.
3. I copied the application onto the desktop of a Macintosh with a PowerPC processor running MacOS X 10.5.8.
4. I tried to start the application by double-clicking it in the Finder. I received an alert from the Finder with the text "....."

To solve your problem:

1. Decide whether you really want to run this application on a Mac with a PowerPC processor. Any such machine is at least 5 3/4 years old. Do you really want this?

2. Add "ppc" to "Architectures" in the build settings. This will not work on newer versions of XCode. If it doesn't work on yours, go to developer.apple.com and find an older version that does. It is probably easier to install that XCode version on the PowerPC computer.

3. Go to developer.apple.com and find the documentation for developing code that runs on different processors. Spend a few weeks learning all this.

mkristain
Apr 30, 2012, 04:19 AM
thanks to guide me and give me right direction