PDA

View Full Version : Apple TV defaulting to 2.0 audio, even though it's directly connected to AV receiver




Bengt77
May 3, 2012, 02:08 AM
Since reading this Ars Technica article (http://arstechnica.com/apple/guides/2012/05/creating-videos-with-51-audio-for-the-apple-tv-mac-and-ios.ars?comments=1), I've learned that the movies you can buy and rent in the iTunes Store (and directly from the Apple TV) include two audio streams: an 5.1 AC3 stream and a 2.0 AAC stream to fall back on in case a device is detected that can't decode AC3 audio.

I have my Apple TV connected to my TV via HDMI. Of course, a 'dumb' TV can't decode AC3 audio. But I also run an optical cable from my Apple TV, directly into my AV receiver. This device obviously can decode an AC3 audio stream. Now, why does my Apple TV still default to 2.0 audio? Must the HDMI cable be connected be to an AC3-capable device? My receiver doesn't have any HDMI inputs or outputs, though. (As it slightly predates the standard.)

So how do I go about getting the 5.1 AC3 audio stream to my receiver? When feeding my receiver movies only containing an AC3 audio stream from the FireCore Media Player, it works beautifully. So why don't Apple's own movies play nice for me as well?

Any suggestions?



slothrob
May 3, 2012, 06:01 AM
I also have the aTV connected to my TV by HDMI and my receiver by optical. The only way I have been able to get it to send the AC3 signal to the receiver is to go to Settings>Audio & Video>Dolby Digital on the aTV and change the setting to On.

Choosing Off sends only the AAC track and doesn't allow the AC3 track to be chosen while in the movie, as does Auto. Choosing On, allows you the option of choosing the AAC track by holding down the center button while the movie is playing, in case you want to watch something through the TV speakers.

Bengt77
May 4, 2012, 01:42 PM
I also have the aTV connected to my TV by HDMI and my receiver by optical. The only way I have been able to get it to send the AC3 signal to the receiver is to go to Settings>Audio & Video>Dolby Digital on the aTV and change the setting to On.

Choosing Off sends only the AAC track and doesn't allow the AC3 track to be chosen while in the movie, as does Auto. Choosing On, allows you the option of choosing the AAC track by holding down the center button while the movie is playing, in case you want to watch something through the TV speakers.
Thank you for your reply. You are sure that your receiver is receiving a 5.1 audio signal, right? I thought I had the Dolby Digital setting turned on, but I'm not 100% certain now. The fact is, with iTunes Store movie material, only the L and R speakers on my receiver's display indicate a dedicated signal. I'll check later if the Dolby Digital setting is indeed turned on. I'm certainly having my doubts now. (Can't check it now, as the Apple TV is occupied by my girlfriend, alas.)

I have my TV's speakers turned off, by the way. I never listen to sound from the TV, as it sounds... well... like crap. So selecting the AAC audio track won't be necessary for me. But thanks for the tip!

slothrob
May 4, 2012, 06:10 PM
Thank you for your reply. You are sure that your receiver is receiving a 5.1 audio signal, right? I thought I had the Dolby Digital setting turned on, but I'm not 100% certain now
Yes. If the file has 5.1 audio and I select Dolby Digital>On, my Onkyo receiver identifies the audio as Dolby Digital.

Bengt77
May 5, 2012, 03:47 AM
Yes. If the file has 5.1 audio and I select Dolby Digital>On, my Onkyo receiver identifies the audio as Dolby Digital.
Awesome. Thanks again for your input; I really appreciate it!