PDA

View Full Version : Links for discussions occasionally display the wrong page in the thread


FloatingBones
May 5, 2012, 12:39 AM
Today, I used the advanced search feature to find a message by a particular user from a discussion with several hundred messages. One of the results returned showed the wrong page from the thread. I was quite confused until I manually went to the previous page of the thread and found the message there.

This link (http://forums.macrumors.com/showthread.php?p=14797384&highlight=fairtax#post14797384) displayed page 30 of the thread. However the actual message is on page 29 of the thread (http://forums.macrumors.com/showthread.php?t=1364739&highlight=fairtax&page=29) (the last entry on page 29).

My guess on what's happening:

The message originally was in the first slot on p. 30.
A message earlier in the discussion got deleted by the mods.
All the messages got bumped down one slot, but the page indexes for messages the got bumped down a page don't get updated.


Do I get a prize for figuring out that scenario? :)

SandboxGeneral
May 5, 2012, 06:04 PM
Today, I used the advanced search feature to find a message by a particular user from a discussion with several hundred messages. One of the results returned showed the wrong page from the thread. I was quite confused until I manually went to the previous page of the thread and found the message there.

This link (http://forums.macrumors.com/showthread.php?p=14797384&highlight=fairtax#post14797384) displayed page 30 of the thread. However the actual message is on page 29 of the thread (http://forums.macrumors.com/showthread.php?t=1364739&highlight=fairtax&page=29) (the last entry on page 29).

My guess on what's happening:

The message originally was in the first slot on p. 30.
A message earlier in the discussion got deleted by the mods.
All the messages got bumped down one slot, but the page indexes for messages the got bumped down a page don't get updated.


Do I get a prize for figuring out that scenario? :)

I'm not sure, but this could be due to the same thing described in this thread:

Weird glitch, is anyone else experiencing this or just me? (http://forums.macrumors.com/showthread.php?t=1358422)

FloatingBones
May 5, 2012, 06:58 PM
I'm not sure, but this could be due to the same thing described in this thread:

Weird glitch, is anyone else experiencing this or just me? (http://forums.macrumors.com/showthread.php?t=1358422)

It sounds similar. However, posts have been added to the thread I noted and the index of the message I cited hasn't changed. After searching, the link is still pointing to page 30.

I see the same mis-indexing in the "2012 Macbook Pro Redesign" referenced in that Weird glitch discussion. This search (http://forums.macrumors.com/search.php?searchid=27692235) shows one message from that thread (http://forums.macrumors.com/showthread.php?p=14820789&highlight=minor+spec+bump#post14820789), but you will find not that message on page 100 of the thread. The message is the last one on page 99 of the thread.

FloatingBones
May 7, 2012, 03:08 PM
Were the admins able to reproduce/re-create the bug? Does the scenario described seem to be the likely cause? Is there a straightforward way to update the search indexes for a thread when a message gets deleted from it?

TIA.