PDA

View Full Version : Computer won't sleep




avatarbe
May 10, 2012, 09:36 AM
Hi,

Since a few days now, my computer won't sleep anymore. When I hit the power button or choose sleep from the menu, my screens go dark, but my tower won't sleep. The white light on the front won't go to its 'breathing' state.

I looked at the console logs, and there I find nfsd logs every 10 seconds (always the exact same log):

10/05/12 16:34:19,757 nfsd: Can't export /private/var/folders/g7/j8_btw2n237d4kkr976f8_qm0000gn/T/.qmsubexp: No such file or directory (2)

I suppose its because of this my mac won't sleep, but i have no idea how to resolve it.

Does anyone can help with this?

Thanks a lot!
Ben



Mal
May 10, 2012, 11:41 AM
Enter this in Terminal and post the output back here:

pmset -g assertions

jW

avatarbe
May 10, 2012, 12:11 PM
Thanks for replying

This is the output of that command (only the top part, i guess the rest is irrelevant)


Assertion status system-wide:
ChargeInhibit 0
PreventUserIdleDisplaySleep 0
PreventUserIdleSystemSleep 0
NoRealPowerSources_debug 0
CPUBoundAssertion 0
EnableIdleSleep 1
PreventSystemSleep 1
DisableInflow 0
DisableLowPowerBatteryWarnings 0
ExternalMedia 0

Listed by owning process:
pid 3780: [0x0000012c00000ec4] PreventSystemSleep named: "org.cups.cupsd"

I don't have a printer connected (i have one installed), but i already killed that process with kill -9 3780, but after that, the computer still won't sleep...

Mal
May 10, 2012, 01:30 PM
After you killed it, did you run that command again and see if you got the same result? I've seen that problem mentioned several other places, but I don't recall the final solution. I'll post back if I can find it for you.

jW

avatarbe
May 11, 2012, 09:24 AM
Apparently the process automatically restarts itself. The strange thing is that I didn't change anything printer-wise... :/

----------

Ok, I think I found it... I logged in to the web interface of cups, and there where print-jobs pending (although I din't print anything in a very long time...)
I canceled the jobs, and now PreventSystemSleep is showing 0...



----------



Just tried it, and YES, it works!!
Thanks a lot!

Mal
May 11, 2012, 09:27 AM
Great, glad to hear it!

jW