PDA

View Full Version : Any way to stop iTunes from auto downloading everything I have ever purchased???????




gentlefury
May 12, 2012, 12:45 PM
OK, So I bought an Apple TV...and the cool thing about it is you can buy TV shows and never download a single bit! You buy a season and just watch it on the Apple TV.....the bad part is....now EVERYTIME I log into iTunes on any of my macs, it wants to download 85+ videos!!! I have to pause all and delete the queue....every single time I start iTunes....it is horribly irritating!! I have auto-download turned off for everything, and pre-order auto download turned off....why won't this stop??? Is there any tricks to getting it to stop??? It's especially annoying on my MBA that has 128GB of SSD space and it tries to download over 100GB every time I start my computer!!!

Also.....I can now stream music with iTunes in the cloud (on my MBA not my iPhone...which again....fng stupid!!!!!) and I can stream movies and shows on my Apple TV......but I have to download tv shows and movies to watch them on my MBA....come on Apple....lets get a little consistent please!!!



WSR
May 13, 2012, 12:55 PM
Have you tried turning off "Aways Check for Available Downloads" on each machine?

It's in iTunes' preferences under store.

gentlefury
May 13, 2012, 01:06 PM
Have you tried turning off "Aways Check for Available Downloads" on each machine?

It's in iTunes' preferences under store.

Yes, that and all the auto download options are off on all machines.

sebseb81
Jun 16, 2012, 10:51 AM
Does no one have an answer to the OP's issue? This problem seems rather ridiculous and glaring; watching a show on the ATV does not imply that you would ever want to download it to your Mac!

williamsonrg
Sep 23, 2012, 03:21 PM
Same problem here. Tried to purchase a season on my iPad (planning to just download an episode or two at a time), buy my Macbook Air will not stop downloading the entire season, no matter how I change the settings.

dbro
Oct 5, 2012, 12:51 PM
I have the same issue. It is maddening. Attached are my settings.