PDA

View Full Version : Why doesn't AppleTV3 or the new iPad playback uncompressed Blu Ray rips in m4v?




Firesign3394
May 20, 2012, 10:16 PM
I have ripped a few episodes of LOST using MakeMKV to my Mac from an original Blu Ray disk that I own.
The videos are encoded in H264, with a bit rate of about 20 Mb/s.
I then take the MKV file that MakeMKV creates and open it up in MP4Tools. Since the video is already encoded in H264 and is of allowable bit rate, since the AppleTV and the new iPad should support them based on their tech specs, I select pass through. Because the audio is DTS, I convert that to AC3 5.1 with a 2 channel track. For the device, I select AppleTV (so the new file it creates has a m4v extension).

Obviously these are large files, and I am okay with that. I will be streaming these to the AppleTV and iPad using Home Sharing. I don't want to convert the videos because I want the original uncompressed blu ray files, and I tried one episode and it took 9 hours. I have lots of free space on a few external hard disks so I would rather just leave them as they are.

The videos playback at a smooth framerate but there are color flashes at random points every second or two. Here is a screen shot I took with the iPad that shows the problem:http://i49.tinypic.com/o8s6mq.png

It does the same thing for the AppleTV. I have tested out the video in VLC and it plays perfectly, so the video file is not the problem.

The video plays smoothly and sounds great, but it's just those color flashes that are the problem.

Any help would be greatly appreciated!



SDAVE
May 21, 2012, 03:40 AM
Either the datarate is too high or the RIP wasn't done well.

Try playing back another rip from another source which has a similar datarate.

andymodem
May 21, 2012, 07:07 AM
Could this be related to why in Handbrake you check the Web Optimized option for streaming? I know in iFlicks when I have it update the metadata only, it optimizes for streaming, wonder if that would help. I have some pretty big rips (15GB+) that stream flawlessly to my ATV3.

I'm just rattling off random thoughts. :D

HobeSoundDarryl
May 21, 2012, 07:47 AM
Bad conversion. Data Rate has been shown to be OK up to 25Mbps on :apple:TV3. Something is wrong with your conversion.

Try Subler on the same file (doing the same thing). That would rule out that MP4Tools is giving you a problem with this file.

Open this file in Quicktime, then "show movie inspector" and paste the "big 4" into a reply in this thread:

Format
FPS
Data Size
Data Rate

Your problem is probably one of these exceeding the limits.

Are you sure the BD file is h.264 (not all of them are)? Do you know the profile number (:apple:TV3 specs max at 4.0)?

Lastly, having done a lot of experiments with this, I suggest just running it all through Handbrake with the high profile setting. This will re-compress the file so it's not what you are doing here but you end up with a much smaller file that will play fine. It does take a long time to do these conversions (many hours on a fast machine) but you only have to do it once. If you are chasing quality maximization, slip the HB quality slider down from 20 to 19 or so (though I find it's hard to see the difference between BD vs. 20 vs. 19, even on a big, quality HDTV screen).

Firesign3394
May 21, 2012, 04:30 PM
Using Subler fixed the problem! The videos stream flawlessly now to both the AppleTV and iPad! They look incredible. Thanks a lot.


Do you think I should write up a guide on how to do this now?

devilbond
May 21, 2012, 04:54 PM
Using Subler fixed the problem! The videos stream flawlessly now to both the AppleTV and iPad! They look incredible. Thanks a lot.

Do you think I should write up a guide on how to do this now?

If you like. I would also file a bug report with the developer of MP4 Tools