PDA

View Full Version : warning: invalid DWARF generated by the compiler: DIE 0x000629bb has multiple AT_dec




d000hg
May 21, 2012, 09:34 AM
warning: invalid DWARF generated by the compiler: DIE 0x000629bb has multiple AT_decl_line attributes in '/Code/test/Mac1.7to1.8Test/build/Mac1.7to1.8Test.build/Release/Mac1.7to1.8Test.build/Objects-normal/x86_64/OgreFramework.o'.Could someone tell me what this means and if it's anything serious or not?



gnasher729
May 21, 2012, 10:27 AM
Could someone tell me what this means and if it's anything serious or not?

It means you should learn how to send bug reports to Apple. It also means you should find out whatever code causes this problem and change it, because it isn't going to work (reliably).

As a pre-requisite for sending bug reports to Apple, you might learn how to give useful information when you post things on MacRumors, like the exact version of Xcode and the compiler that you are using. Which I thought would have been common sense.

d000hg
May 21, 2012, 10:36 AM
It's pretty clear I'm asking what the error is telling me, not which line of my code has an error. Why on earth would I submit a bug report to Apple when my code is not compiling? It seemed like just another compiler/linker error/warning but searching online didn't turn up an obvious explanation what I should do about it.

It's pretty evident I'm a noob so acting like a sanctimonious jerk is hardly helpful. What's the matter, did you buy FaceBook?

ArtOfWarfare
May 21, 2012, 11:52 AM
If I'm not mistaken, you're using Ogre 3D... is that because you saw a post where I suggest someone else use it?

Anyways, my advice is to follow these instructions, exactly, initially:
http://www.ogre3d.org/tikiwiki/Manually+configure+an+Xcode+4+project

If those instructions don't work, you might try adding links to the dylibs stored in OgreSDK/lib

That's how I start each Xcode project that I use Ogre 3D in.

If I'm mistaken and the Ogre in your file path is unrelated to Ogre 3D, then pay no heed to my advice.

d000hg
May 21, 2012, 12:02 PM
I am using Ogre3D - have been for ages but only on Windows, I'm new to Mac development.

I never saw that wiki page before and it's one of the things that I've been looking for, great! I'm on Xcode 3.2.6 (Snow Leopard) but it looks very transferable.

Thanks.