PDA

View Full Version : Cannot sleep




hehe299792458
May 21, 2012, 08:49 PM
I've been having trouble with my early 2011 macbook pro going to sleep ever since I installed Lion.

I googled it and it seems there are a number of possible causes:

Internet Sharing --> but I don't have this enabled

Little Snitch --> I don't have this installed

Printer queues --> no printer either



I have an external monitor that's connected. If I just close the lid of my MBP, the desktop goes to the external monitor and it doesn't go to sleep.

When I have the external monitor unplugged and close the lid of my MBP, the computer just stays awake (I can heat the fans running after 10 minutes).


However, if I click sleep from the apple menu, the computer goes to sleep fine (with or without the external monitor). But sometimes I forgot. I'm just used to closing the lid and having my notebook sleep. So sometimes, the computer stays awake for the entire night.

Any ideas on how to make the computer sleep normally again? That is, I want it to sleep when I close the lid.



goRoostr
May 22, 2012, 09:27 AM
Try resetting SMC, and if that doesnt work:
1) Trash this folder
Macintosh HD > Library > Preferences > SystemConfiguration
2) Re-boot
3) Test
4) Empty trash

ScoobyMcDoo
May 22, 2012, 09:50 AM
Here (http://macenstein.com/default/2011/08/how-to-get-your-macbook-pro-to-sleep-in-os-x-lion/) is another thing you can try. The proposed solution seem kind of wonky to me, but a lot of folks replied that it worked for them.

hehe299792458
May 24, 2012, 11:12 PM
Try resetting SMC, and if that doesnt work:
1) Trash this folder
Macintosh HD > Library > Preferences > SystemConfiguration
2) Re-boot
3) Test
4) Empty trash

Tried both... but to no avail unfortunately

Here (http://macenstein.com/default/2011/08/how-to-get-your-macbook-pro-to-sleep-in-os-x-lion/) is another thing you can try. The proposed solution seem kind of wonky to me, but a lot of folks replied that it worked for them.

tried as well... I agree it does seem strange, but some people I know, it actually worked. but it didn't work for me

FredT2
Jun 6, 2012, 12:10 AM
Same here. My situation is similar but with a Mac Pro. It will sleep via power button, menu, or keyboard shortcut, but absolutely refuses to sleep via energy saver settings. I have:

1. Reset PRAM.
2. Rest SMU.
3. Fixed prefs.
4. Cleared all print queues.
5. Turned off all sharing.
6. Trashed SystemConfiguration folder.
7. Checked Console logs from any strange activities (nothing)
8. Ran pmset -g (nothing shows preventing sleep)

I've been running from my Snow Leopard partition for a few months because I couldn't solve this problem. But I decided I'd give it another try, and so far I'm totally stumped. I don't like PleaseSleep as a solution because there are too many programs that I would need to exclude (EyeTV, Audio Hijack, HandBrake, etc.), so the machine would remain awake a lot of the time anyway. I guess it's back to Snow Leopard and wait for Mountain Lion, and hoping that the problem won't continue with it. Unless someone here has another great idea for me to try. :confused:

Set845
Jun 6, 2012, 03:26 PM
I had the same problem and tried everything. The solution for me was a message in Console kernel log. Wake reason: EHC2. I Googled it and found this:

EHC: standing for Enhanced Host Controller, is another USB interface, but can also be wireless devices and bluetooth since they are also on the USB bus of a Mac.

I went into the Bluetooth preference pane and in Advanced I found Serial Port Name Bluetooth-PDA-Sync enabled. I disabled it and now my iMac sleeps.