PDA

View Full Version : Setting Caller ID on iPad iMessages




bgro
Jun 11, 2012, 10:36 PM
Are you able to set your caller id on the iPad iMessage application to your phone number? Wanted to see if you could start an iMessage from your iPad using your phone number (i have mine set to phone number on my iPhone and would like to match this setting).

I know part of the iOS6 update was the merging of your phone number with Apple ID so wanted to see if this could be done.

Thanks.



leukotriene
Jun 11, 2012, 10:42 PM
Are you able to set your caller id on the iPad iMessage application to your phone number? Wanted to see if you could start an iMessage from your iPad using your phone number (i have mine set to phone number on my iPhone and would like to match this setting).

I know part of the iOS6 update was the merging of your phone number with Apple ID so wanted to see if this could be done.

Thanks.

Sorry dude, the iMessage settings pane doesn't even have any options for setting any kind of caller ID. it's completely absent. It is there for the FaceTime settings pane though. This is on the iPad btw.

bgro
Jun 11, 2012, 10:47 PM
Sorry dude, the iMessage settings pane doesn't even have any options for setting any kind of caller ID. it's completely absent. It is there for the FaceTime settings pane though. This is on the iPad btw.

Ok thank you. Guess the work around will be to set the caller id on my iphone to my Apple ID so everything is the same. Unless this functionality isn't yet enabled in the beta. Thanks again.

GeorgieAcevedo
Jun 11, 2012, 11:08 PM
Are you able to set your caller id on the iPad iMessage application to your phone number? Wanted to see if you could start an iMessage from your iPad using your phone number (i have mine set to phone number on my iPhone and would like to match this setting).

I know part of the iOS6 update was the merging of your phone number with Apple ID so wanted to see if this could be done.

Thanks.

It's supposed to be an option on setting of iMessage or FaceTime but this is the first beta. I see no workaround it yet. Maybe next beta ?

SanjeevRana
Jun 12, 2012, 12:32 AM
I dont know what you guys checked but the option is there...

Under Settings->Messages->Send & Receive
Set "Start new coversations from:" to your number and you are done !

Works perfectly.. :)

GeorgieAcevedo
Jun 12, 2012, 01:03 AM
I dont know what you guys checked but the option is there...

Under Settings->Messages->Send & Receive
Set "Start new coversations from:" to your number and you are done !

Works perfectly.. :)

My number is not showing up as a option, bug? I wish I knew how to fix it!

http://i45.tinypic.com/34g6hzb.jpg

http://i46.tinypic.com/2cxg6fb.jpg

SanjeevRana
Jun 12, 2012, 01:08 AM
Did you setup your iPhone iMessages before iPad one ? And does it show phone and email on your iPhone ... Of course need ios6 on iPhone as well

GeorgieAcevedo
Jun 12, 2012, 01:10 AM
Did you setup your iPhone iMessages before iPad one ? And does it show phone and email on your iPhone ... Of course need ios6 on iPhone as well

No wonder! I will update my iPhone to iOS 6 tomorrow. Thanks!

falcora
Jun 12, 2012, 01:22 AM
I dont know what you guys checked but the option is there...

Under Settings->Messages->Send & Receive
Set "Start new coversations from:" to your number and you are done !

Works perfectly.. :)

I don't see this option on the ipad, only on my iphone. (both are running ios 6 beta)

SanjeevRana
Jun 12, 2012, 01:26 AM
I don't see this option on the ipad, only on my iphone. (both are running ios 6 beta)

Did you setup your apple Id during initial setup or skipped it and later setup iMessage specifically under settings ?

That's the only thing I can think of ... I setup the id initially and enabled everything ... Skipped it for my wife and setup manually which caused same issue as yours ...

falcora
Jun 12, 2012, 01:35 AM
Did you setup your apple Id during initial setup or skipped it and later setup iMessage specifically under settings ?

That's the only thing I can think of ... I setup the id initially and enabled everything ... Skipped it for my wife and setup manually which caused same issue as yours ...

I didn't set it up. I did an update from 5.1.1 (not a restore) and it didn't prompt me for any additional options (except to enable siri on my ipad)

SanjeevRana
Jun 12, 2012, 01:41 AM
You updated from 5.1.1 to 6 beta OTA ?? I thought that wasn't possible :confused:

falcora
Jun 12, 2012, 01:45 AM
You updated from 5.1.1 to 6 beta OTA ?? I thought that wasn't possible :confused:

No not OTA, I just option clicked the Check For Update button in iTunes, selected the ipsw I downloaded from my developer account, and it updated my ipad and iphone. It didn't make me redownload my apps or restore an icloud backup or anything. Everything was just there as if I had done a tradional update through iTunes.

SanjeevRana
Jun 12, 2012, 01:49 AM
No not OTA, I just option clicked the Check For Update button in iTunes, selected the ipsw I downloaded from my developer account, and it updated my ipad and iphone. It didn't make me redownload my apps or restore an icloud backup or anything. Everything was just there as if I had done a tradional update through iTunes.

Hmm .. Then it could be how a fresh setup and a upgrade are handled ... Tried switching off iMessage and enabling again ?

Shorties
Jun 12, 2012, 10:22 AM
Did you setup your iPhone iMessages before iPad one ? And does it show phone and email on your iPhone ... Of course need ios6 on iPhone as well

Do you need the iOS 6 beta on both the iPhone and the iPad for the iPad to receive text imessages? Or will just having it on the iPhone do it? is the iPhone itself the one doing the forwarding?

Cambria
Jun 12, 2012, 02:31 PM
Anybody figured it out? Cant convince my Ipad to use my phone number. I have an Iphone 4 and Ipad 2, both with the Ios 6 Beta...

PhilPower
Jun 12, 2012, 02:42 PM
I got it to work!

Just activate iMessage on iPad and AFTERWARDS activate iMessage on iPhone.
A pop-up will come up on iPad saying the number was added and if you like to use it on your iPad as well. :)

jazoi
Jun 12, 2012, 03:02 PM
I had trouble as well. I followed your suggestion, but I have not received the popup on my iPad yet. Does your iMessage/FaceTime Apple ID have to be a developer account? My Apple ID for iTunes is my developer account, but I use a separate one for iCloud/iMessage/FaceTime.

PhilPower
Jun 12, 2012, 03:07 PM
I donīt really know as I have one account for all...so could be the issue...

Jonathansm
Jun 12, 2012, 03:17 PM
Now on my iPhone with iOS 6 is has my number greyed out so I can't even selected it as an option. Doesn't show up on my iPad on iOS 6 either. I deactivated both of them and reactivated them but still doesn't work

PhilPower
Jun 12, 2012, 03:20 PM
It is normal that the number is grey as you canīt change it.
Did you do the activation in the order I suggested?

jazoi
Jun 12, 2012, 03:21 PM
Yeah, that's what I'm wondering. When I first set it up, it set my iMessage up using my iTunes account. I think for about a minute, it did work and associated my number with that account. However, I signed out of it and signed in with my iCloud account ID. Haven't been able to get it to work since then. There are no options to unassociate or reassociate anything. I hope that once it is associated it is not set for life. Even better news, I tried signing in again with my main iTunes account to see if my phone number was still on there. Nope, I can't associate my phone number at all with my iPad anymore with either ID.

kirky29
Jun 12, 2012, 03:27 PM
iMessage on the iPhone & iPad activated, but no phone number appeared on the iPad.

But with FaceTime, it's activated on the iPad (no number showing though) but it just won't activate on the iPhone?

Anybody else having this issue? - It just says "Waiting for activation..."

EDIT - since saying that, it's randomly done it. -- my phone number still isn't showing on the iPad though!

Cambria
Jun 12, 2012, 03:36 PM
Got it to work. It seems my iphones udid wasn't registered since i got it replaced a while back. Strange enough i was able to install ios 6 in the first place :confused: Noticed that when i tried to restore ios and got the message that i'm not registered

schizbomb
Jun 12, 2012, 03:46 PM
I got it to work on iPad, but not OSX yet.

outphase
Jun 12, 2012, 03:56 PM
I got it to work on iPad, but not OSX yet.

Probably when Mountain Lion comes out

PhilPower
Jun 12, 2012, 03:59 PM
Probably when Mountain Lion comes out

I think so too.

bgro
Jun 12, 2012, 07:19 PM
On the iPad try going into Settings --> Messages and sign out of your Apple ID...then sign back in. After I did that my phone number appeared and I was apple to choose to be reached at my phone number AND start new conversations from my phone number. WIll be tyring out in a few minutes and will report back.

Edit
Well that didn't last long...the same thing happened to me as someone else in the thread. Number showed up for a few minutes then disappeared and can't get it back.

Zorn
Jun 13, 2012, 01:12 AM
I'm in the same boat, this feature isn't working for me at all no matter what I try.

maesterxen
Jun 14, 2012, 01:12 AM
Does anyone know if the iPad has to be on iOS6 to use this feature? I have an iPad 1 so its going to suck massively if both the iphone and ipad have to be on ios6 for this to work.

ktd
Jun 14, 2012, 01:50 PM
I got it to work!

Just activate iMessage on iPad and AFTERWARDS activate iMessage on iPhone.
A pop-up will come up on iPad saying the number was added and if you like to use it on your iPad as well. :)

Thanks! Just deactivated iMessage on both units and then activated on my iPhone and then iPad and now it works great with my phone number on both units.

mrblack927
Jun 14, 2012, 03:58 PM
Still nothing for me. iPhone 4S and iPad 3 both running iOS 6. I'm guessing Apple is still fidgeting with the servers and that's why it's intermittent for some people. Hopefully in a few days (weeks?) it will smooth out and start working correctly.

EDIT: Got it working (we'll see if it lasts). Not sure if the method matters since I've heard of people getting it to work all different ways, but for what it's worth, I was signed in on my iPad and deactivated/reactivated iMessage on my iPhone. The "waiting for activation" message remained for a good 2-3 minutes, then suddenly it became a "receive from" option on my iPad. After selecting my phone number on my iPad I was able to remove all email addresses and use solely phone number.

shandyman
Jun 14, 2012, 06:19 PM
Thanks! Just deactivated iMessage on both units and then activated on my iPhone and then iPad and now it works great with my phone number on both units.

this ain't working for me, tried it many times, eve the other way round. :(

shandyman
Jun 15, 2012, 06:39 PM
Does anyone know if the iPad has to be on iOS6 to use this feature? I have an iPad 1 so its going to suck massively if both the iphone and ipad have to be on ios6 for this to work.

Yup. It's iOS 6 on each device only. My iPad 2 was on iOS 5 whilst iPhone was on 6 and no joy. My friend had his iPad on iOS 6 and iPhone on iOS 5 and also no joy.

I got both working on iOS 6 now. You have to sign out your apple ID on both devices, turn them off then on, then sign in on iPad first then iPhone and you get the popups mentioned. :)

212rikanmofo
Jun 15, 2012, 06:45 PM
I'm confused, whats is this feature suppose to do? What difference does it make if you choose your email or phone number?

shandyman
Jun 15, 2012, 06:49 PM
I'm confused, whats is this feature suppose to do? What difference does it make if you choose your email or phone number?

On iOS 5, if you iMessage someone's number, the iMessage only goes to the iPhone. If you iMessage email, I goes iPhone, iPad or mountain lion. With iMessage in iOS 6, I messaging the mobile will also do all 3 devices.

Most people have people's mobile number more than their email address.

212rikanmofo
Jun 15, 2012, 06:54 PM
Ahh, so thats what they mean by unified appleid? That makes things simpler than. It should always go to all your devices, and you shouldn't have to worry about sending an iMessage to a mobile number or email.

shandyman
Jun 15, 2012, 07:04 PM
Ahh, so thats what they mean by unified appleid? That makes things simpler than. It should always go to all your devices, and you shouldn't have to worry about sending an iMessage to a mobile number or email.

Yea, think apple got the message that it didn't totally work as promised as it would only do so via email addresses, so they sorted it.

bgro
Jun 15, 2012, 10:11 PM
Working perfectly now after reinstalling ios6 and setting up both my iPhone and iPad as new devices.

bepperk
Jun 16, 2012, 04:58 AM
i've the same problem.
i have an iphone ios6 and OSX M-LionDP4.
if someone can help me please. :)

shandyman
Jun 16, 2012, 05:39 AM
i've the same problem.
i have an iphone ios6 and OSX M-LionDP4.
if someone can help me please. :)

Afaik you can't do numbers in ML DP4, that's prob not happening until the next DP or release

bepperk
Jun 16, 2012, 05:54 AM
Afaik you can't do numbers in ML DP4, that's prob not happening until the next DP or release

neither trying to resetting messages in mac?

shandyman
Jun 16, 2012, 08:06 AM
neither trying to resetting messages in mac?

Nope, people have said that mountain lion does not have the unifying apple ID and number feature in DP4, so no amount of resetting will work. You gotta wait for the next DP or official release. For now it's iPhone, iPod touch, iPad only

bepperk
Jun 17, 2012, 02:19 AM
Nope, people have said that mountain lion does not have the unifying apple ID and number feature in DP4, so no amount of resetting will work. You gotta wait for the next DP or official release. For now it's iPhone, iPod touch, iPad only

thank you.