PDA

View Full Version : Trying to Restore iPod Classic and Get "Can't Unmount Disk" Error




mBurns
Jun 14, 2012, 09:57 AM
Hi folks. Long story short, I purchased a 160 Gb classic like 3.5 years ago and maybe used it a dozen times. I ultimately ended up putting it back in its box and decided last night to try to restore and use it. Every time I try to restore it, I get the "Can't unmount disk" error once I intiate the restore through iTunes. I have also tried putting the iPod into Disk Mode and restoring it through iTunes that way. Finally, after getting frusturated, I tried to restore it through Disk Utility to no avail. Anyone have any suggestions? From my research it sounds like some data block segments may be going bad.... Oddly enough, I can still sync my entire music collection to the device but cannot restore it. Any guidance would be much appreciated....



Ccrew
Jun 18, 2012, 07:42 AM
Try a machine with a clean iTunes install or create a new user on your machine if another isn't available and try as that user. I've seen issues where the user profile creates a restore error on a large number of occasions and that's a cheap/free way to see if that's the issue.

mBurns
Jun 26, 2012, 04:39 PM
Try a machine with a clean iTunes install or create a new user on your machine if another isn't available and try as that user. I've seen issues where the user profile creates a restore error on a large number of occasions and that's a cheap/free way to see if that's the issue.

I finally got it working properly when I tried it again the next day and restored it multiple times on two different machines. Ended up selling it on CL because I realized why I only used it a dozen times or so.... I have too many players! :P

botwa
Jun 28, 2012, 06:36 AM
it's funny that you experienced such problems.
funny because I had such problems too.
and I solved them by using my laptop with iTunes instead of PC.
and my friend just bought the same iPod too and she has these problems!
your iPod is 3.5 y.o. mine is 2.5. and my friend's is about 10 days old.
Shouldn't they fixed this bug in apple? really? looks like it's quite common.

I remember I restored my iPod like 5 times a day. it was SO ANNOYING until I switches to laptop.

mBurns
Jun 29, 2012, 10:03 AM
it's funny that you experienced such problems.
funny because I had such problems too.
and I solved them by using my laptop with iTunes instead of PC.
and my friend just bought the same iPod too and she has these problems!
your iPod is 3.5 y.o. mine is 2.5. and my friend's is about 10 days old.
Shouldn't they fixed this bug in apple? really? looks like it's quite common.

I remember I restored my iPod like 5 times a day. it was SO ANNOYING until I switches to laptop.

Due to the lack of suggestions I received here, I ultimately ended up researching the problem online and received no fulfilling solution/answer other than that the newer iPod Classics (7th gen) fixed many of the bugs/diosyncrasies of the older gen. YMMV.