PDA

View Full Version : DNS Lion Server




kingdonk
Jun 18, 2012, 09:07 AM
After using lion server locally, having read all the manuals and articles/posts on it i seem to be having problems setting it up with my domain name.

Ive registered my domain name with crazy domains.com.au and use their dns services.

my name servers are pointed to ns1.dnspackage.com 203.170.87.1 and ns2.dnspackage.com 173.230.148.111

i haven't created a host record which allows me to have anything.mydomain.com.au and my ip address
i havent entered anything in here because it isn't a A, MX or CNAME record, thats why i had to upgrade to their DNS services.
Should i be entering server.mydomain.com.au and my fixed ip from my service provider here?

EDIT: i decided to edit this host record before sleep to see if any change will of happened by the morning and it already has.
I entered server.mydomain.com.au and pointed this to my ip address so i can now access my server from within the network and outside my network with domain.com.au www.domain.com.au and the external ip address.

on their DNS page I've got primary web forwarders

mydomain.com.au pointed to my static ip address
www.mydomain.com.au pointed to my static ip address
and a mx record for mail.mydomain.com.au pointed to my static ip address.

no txt record added. Do i need this?

Is this ok unto now?

on my server the computer name is wikiserver
localhost name: wiki
Hostname: domainname.com.au

on the DNS i have:

www.domain.com.au as a primary zone
Name servers
Zone www.domain.com.au
Name Server www.domain.com.au.
Mail Exchangers
Hostname
www.domain.com.au priority 10

Ive got a second primary zone, the same as the above but without the www. before the domain name.
then the two reverse zones are
6.0.0.10.in-addr.arp.
name server 6.0.0.10.in-addr.arp. name server hostname domain.com.au
reverse mapping domain.com.au.

then the second is the same as above but with the name server being 0.0.10.in-addr.arpa and with the www. in front of the domain name.

i can see the above is wrong but just need some direction.

Also i notice in tutorials that they say to have server.mydomain.com.au but is that necessary as i want domain.com.au and www.domain.com.au to go to the default web site then if i create any new sites i just want it to be subdomain.mydomain.com.au
Do i just create that on the server or do i need to keep going to my domain registrar and adding subdomains there?

Before sending email from the server webmail kinda worked, who ever you sent the e-mail to outside of the server (to gmail) the e-mail address came up as admin@com.au but after the above edit change i am unable to send e-mail out, even to the admin account sending the e-mail and the SMTP log says
illegal address syntax from unknown (ip address) in mail command: admin@ipaddress where as my external ip address would be like 120.130.140.0 but its showing admin@130.140.0, and a warning that the address is not listed for hostname bigpond.bigpond but as you can see above, there is no bigpond.bigpond hostname.

I have noticed the alerts in server.app informing me that my hostname has changed from domain.com.au to domain.bigpond. what would change this?

Thanks in advance for any help.