PDA

View Full Version : Osx Lion: auto-start networking issue, please help!




firey
Jun 23, 2012, 06:42 AM
Hi there, I hope someone can help me!

I'll try and keep this short and concise:

First problem: Osx windows networking was not working, the only way to fix it each time was to go into the system prefs, disable networking, then re-enabling networking. Doing this allowed my other computers to access the mac, but I had to do this every time, after every reboot.

- I thought that installing SMBup (http://eduo.info/apps/smbup) which installs the old samba system that snow leopard used, would fix my problem -

Now: Samba doesn't automatically start either! I have to load the SMBup control panel every time I turn on my mac, and tell it to start the service again. And sometimes it will just disable itself randomly.

Summary: It seems I am having the same issue whether I use the default osx lion networking, or samba - the network service just won't start unless I force them to.

Please! some osx guru out there, help me out!



codeus
Jun 23, 2012, 07:14 AM
Don't know about smbup but modifying Lion's smb service will make things hard to troubleshoot.

If it's just a glitch with the service at startup then maybe its trying to start before a dependant service us up - check /var/log/system.log for clues.

A simple workaround would be to write a script and run it with launchd at start up: -

#!/bin/bash
serveradmin stop smb
sleep 30
serveradmin start smb

This will shut down smb, wait 30 secs then start it again.

eduo
Sep 21, 2012, 06:27 PM
Hello. SMBUp developer here.

I'm sorry to be so late, but I found this thread by sheer luck.

SMBUp tries its best to disable Apple's SMB services (with launchctl, no dirty workarounds here) but there's a "bug" (to me) where the GUI is never updated. Nothing I can do programmatically seems to affect the state of the checkbox that starts OS X's SMB.

What this means, effectively, is that if the sharing preference pane is ever opened OS X will take the checkbox as an order and reinstante SMB's plist scripts for launchd.

Since Apple's scripts come before third parties, SMBUp's scripts for launching samba can't ever start and it fails. You can then start it by hand (as the application gains admin privileges and kicks Apple's SMB services around again when you do this).

The best solution for this is to go into Sharing preference pane and make sure SMB Windows File Sharing is disabled. Then go into SMBUp and have it reset the config files. Since it's disabled in the GUI it's unlikely it'll re-start itself again "randomly" (actually it's not random, it's whenever the OS reads that setting, usually by opening System Preferences).