PDA

View Full Version : MBA 13" i7, dimming itself




tigres
Jun 26, 2012, 09:52 AM
Hey all,

Without derailing another thread, who is having an issue with their MBA auto dimming itself down to darkness?

I work on an external monitor all day (no issues here), then at home (not connected to an external monitor) my screen will dim itself to #2 from #7 (in dark room BTW). I crank it up to 7, and about 3 minutes or less, it's back down again- all this happens right before my eyes and actively working. Before I know it, I am squinting before I realize the screen is dark again. Then, I crank up the brightness and it repeats the dimming.

Now, I know I can uncheck the auto brightness box in Sys pref's, but being my 3rd MBA, I see no reason to justify this, as it should work as on my previous machines. That said, I was always running SL, so it may be an OS X issue as I did set up from TM backup.

I hate to return this thing; but I am interested if any others are having such issues. The poll is to give me credence on what others are experiencing, or if I have a bad light sensor.:confused:

Also, should anyone recommend a fix, or test (already did a PRAM and SMC reset) like a bad plist or kext file perhaps... whatever.

Many thanks for any suggestions.



jojoba
Jun 26, 2012, 09:55 AM
I'm not sure if this is the same thing as you're describing, but if I don't work on my MBA for a little while (e.g., if I'm reading something while I'm writing), the screen dims itself after x minutes (don't know exactly how long, have never timed it), and then eventually goes to sleep. When I don't want that to happen, I use Caffeine. This is the only MBA I've had, so don't have anything to compare it to. It's a 2011.

ijen0311
Jun 26, 2012, 10:01 AM
Same as above.

tigres
Jun 26, 2012, 10:04 AM
I'm not sure if this is the same thing as you're describing, but if I don't work on my MBA for a little while (e.g., if I'm reading something while I'm writing), the screen dims itself after x minutes (don't know exactly how long, have never timed it), and then eventually goes to sleep. When I don't want that to happen, I use Caffeine. This is the only MBA I've had, so don't have anything to compare it to. It's a 2011.

Modified my post for clarity.
thx

jojoba
Jun 26, 2012, 10:08 AM
Modified my post for clarity.
thx

OK, I see - I don't use the auto brightness feature so can't, say, sorry.

Arnieaz
Jun 26, 2012, 10:12 AM
If you got to System Preferences -> Energy Saver -> And uncheck the
Automatically reduce brightness before display goes to sleep

This should fix it?

tigres
Jun 26, 2012, 07:16 PM
If you got to System Preferences -> Energy Saver -> And uncheck the
Automatically reduce brightness before display goes to sleep

This should fix it?

no go.

bummer, looks like it is a potential hardware issue:(

backwardsrain
Jun 26, 2012, 09:08 PM
My brand new 13/128/8 gb air does the same thing. I had to turn off the "Automatically adjust brightness" or else it would constantly dim itself to the point I could hardly see. I just assumed it was set up that way to save battery life. And I'm sure there are some people who can see fine when it's dimmed. Unchecking that box completely fixed the issue though.