PDA

View Full Version : New ipod classic firmware downgrade?




sirdugh
Jun 26, 2012, 11:35 PM
Thanks in advance for helping the newb.

I just bought a new car stereo and 160 gb ipod classic because I can't stand listening to the radio any more.

The first radio I purchased from crutchfield.com had issues. The ipod would play fine at first, but after I cycled the ignition off and back on, the ipod would play at double speed. They switched it out for the same model.....same issue. They gave me a different JVC model, same issue...... I know that I could switch it out for another brand but the JVC's actually have the features that I'm looking for.

I'm beginning to think that these JVC stereos don't support the latest iPod firmware as my small old iPods play just fine. So, would it make sense to downgrade the firmware? My internet research seems to indicate that I could downgrade from 2.0.4 to 2.0.3 or 2.0.2. However, I can't find them. Any advice as to a)whether downgrading might actually help or b)where I might locate the downloads for 2.0.3 and/or 2.0.2 would be greatly appreciated.



PinkyMacGodess
Jun 27, 2012, 05:37 AM
I'm beginning to think that these JVC stereos don't support the latest iPod firmware as my small old iPods play just fine. So, would it make sense to downgrade the firmware? My internet research seems to indicate that I could downgrade from 2.0.4 to 2.0.3 or 2.0.2. However, I can't find them. Any advice as to a)whether downgrading might actually help or b)where I might locate the downloads for 2.0.3 and/or 2.0.2 would be greatly appreciated.

Downdrading is something I haven't tried, however I have some experience with using iPod/iPhone in cars. I used Alpine, and now the Toyota factory unit in my FJ.

It's very much up to what model iPod you have as opposed to the firmware. I played around with some of the older iPods I have and found it interesting what was supported and what wasn't. Nano's, no; Touch, not the newest; mini, surprisingly yes; iPhone 3g, no; iPhone 4, no(!), iPhone 4s, yes. It made no sense but that's the game they play. I ended up buying a new iPod Classic and it worked (although my first gen classic didn't) and works but the stock FJ radio takes a while to read the track list, and it then takes a while to scroll through the list to select what I want to listen to. The FJ radio is a JVC from what I can tell. I'm surprised that the Classic isn't supported. I don't think downgrading the firmware would fix this, if you can find the earlier firmware. If you upgraded the firmware using one of your computers, there is a chance that the older firmware might be in the computer, but finding it...

I have thought of trying an external USB hard drive with the FJ and see if it will play tunes off it. But having sold car audio out of high school, the industry is fickle and capricious. What they support from one version to the next is what they support. Sometimes it makes no sense, but they go where they think the money is, or something like that...

NewAnger
Jun 27, 2012, 05:51 PM
I have two cars with Pioneer decks in them purchased simply to work with my iPods.

The first one is a DVD touchscreen that I bought back in 2008. To this date, it works with my 2004 iPod Photo, my current model iPod Classic and my iPhone 4S and 3GS. The only problem with the iPhones is that they will not charge. The deck even plays videos from the iPod/iPhones on it's screen with no problems.

In my other car I have a two month old Pioneer that works with my iPod Classic as well as my iPhones. The Manual states that the supported firmware for the phones must be 5.0 but I have 5.1.1 on them with no problems. Even bluetooth works.

It might be worth your time to get a new deck since they are easily found for under $150 depending on where you look. I have the utmost respect for Pioneer, my Chevy came with a Pioneer 7 speaker system from the factory and the built in amp connected to my deck with no issues.