PDA

View Full Version : USB flash drive won't mount on iMac




afd
Jun 29, 2012, 05:30 AM
I have a Verbatim flash drive that won't mount on my iMac, it's running latest version of Lion and is a 2011 TB entry level iMac. The drive worked with the iMac when I got it but now nothing happens when I plug it in. I've tried it with a USB hub and plugged in directly and tried Disc Utility and System Information. the drive does work with a XP laptop and a 12" Powerbook.
Any suggestions for getting it to work again?



ScoobyMcDoo
Jun 29, 2012, 10:54 AM
When you plug it in, check console.app for (hopefully helpful) messages.

afd
Jun 29, 2012, 02:45 PM
thanks for that suggestion, unfortunately absolutely nothing....

----------

does get pretty warm though.

TYancy
Jul 13, 2012, 12:17 PM
None of my thumb drives or USB hard drives appear on my Lion desktop. I've set things so that they should appear but they do not.

The only way I can access a USB drive is to launch Disk Utility, select the volume and select open, or to open it via a sidebar. The icons simply will not mount on my desktop. No problem with any of my onboard hard drives

I've addressed all possible preferences. I've been doing corporate IT for years and am stumped by this one. Judging by Google search results, this is a common problem.

Unless anyone has any other suggestions, I'm reverting to Snow Leopard.

MisterMe
Jul 13, 2012, 05:56 PM
Do other volumes mount properly on your Desktop?