PDA

View Full Version : Unable to unmount hard drive




EODgeier
Jul 5, 2012, 08:57 AM
I have a MacBook air (2011 aug model) with lion and my wd my passport 2tb won't unmount. I've tried adding partition, force unmount lsof | egrep 'name of drive' the way described on here(but I think that's for snow lep), and I downloaded disk warrior but it still says it can't unmount because another application is using it. I'm sure it's corrupted somewhere in it but if I could just get it to unmount I believe disk warrior can rebuild it. I have been able to erase it so I don't need any files off of it. Is there a different force unmount procedure to use with lion that could help me? I also get an error message sometimes that says (-50).



Fishrrman
Jul 5, 2012, 09:32 AM
Have you tried:
1. Power down, all the way to off.
2. Unplug the drive
3. Restart the Mac

What happens?

Have you tried:
1. Restart the Mac
2. Plug in the drive
3. Let the drive icon mount on the desktop
4. Drag the icon to the trash to unmount it

What happens?

EODgeier
Jul 5, 2012, 09:44 AM
When I plug it back in it appears In finder as normal. If I drag it to trash it wants to eject not unmount. If I try to drag a file to it I get error code -50. When I try to use disk utility or disk warrior it says can't unmount used by another app. Close the files and try again but nothing it using it.