PDA

View Full Version : Can't connect Denon AVR-1912 with any Apple router




tomyt3
Jul 9, 2012, 07:55 PM
Hi guys, i've been trying for several hours and seems impossible to connect my new Denon AVR 1912 with Airport Express nor Time Capsule.
I tried with a D-Link router to check if the problem was on the AVR, but everything worked perfectly with d-link. I even upgraded firmware, but when trying to connect it via any of these Apple products i keep getting the no network message.
I also tried deactivating the DHCP option on the AVR and configuring manually the ip, and on the airport utility did the same, i reserved that ip for the denon and entered the AVR mac adress. Same message

Help please!!!



98EXL
Aug 28, 2012, 05:04 PM
I know this was forever ago in internet time, still not working? I've seen the network be defective out of the box before. Also try doing a microprocessor reset.

http://www.helpowl.com/q/Denon/AVR1912/Troubleshooting/reset-microprocessor/86394

That usually takes care of most problems with the Denon AVRs

marine0816
Sep 3, 2012, 05:45 PM
Try this

http://forums.verizon.com/t5/FiOS-Internet/Itunes-Sharing-not-working-over-wireless/td-p/197152/highlight/true/page/2

Anna stacy
Sep 4, 2012, 02:31 AM
Yes am also facing some issues. Recently I bought new Denon AVR 1912. At my end Airplay component doesn't work properly. Although HDMI connection and internet radion work fine, but i am unable to find Airplay icon on my ipod.