PDA

View Full Version : Safari 8.0 crashes when a website is opened




scootermafia
Jul 12, 2012, 04:30 AM
Mountain Lion GM is installed, upgrade install (yeah, I know). I've cleaned every possible cache, etc. The problem happens on the guest account too. Here is the crash log. I can open Safari and look at preference menus, etc but going to any site makes the site start to open then it immediately crashes. I shortened the crash log a bit.

Process: Safari [897]
Path: /Applications/Safari.app/Contents/MacOS/Safari
Identifier: com.apple.Safari
Version: 6.0 (8536.25)
Build Info: WebBrowser-7536025000000000~2
Code Type: X86-64 (Native)
Parent Process: launchd [140]
User ID: 502

Date/Time: 2012-07-12 04:14:19.533 -0500
OS Version: Mac OS X 10.8 (12A269)
Report Version: 10

Interval Since Last Report: 2624 sec
Crashes Since Last Report: 2
Per-App Interval Since Last Report: 194 sec
Per-App Crashes Since Last Report: 1
Anonymous UUID: BE88F983-E545-4D6F-B95C-0CDD00807C2E

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

VM Regions Near 0:
-->
__TEXT 000000010f168000-000000010f169000 [ 4K] r-x/rwx SM=COW /Applications/Safari.app/Contents/MacOS/Safari

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 ??? 000000000000000000 0 + 0
1 com.hetima.SafariStand 0x000000011775f730 STWK_ui_createNewPage + 88
2 com.apple.WebKit2 0x00007fff8f17a577 void CoreIPC::handleMessage<Messages::WebPageProxy::DidReceiveContentLengthForResource, WebKit::WebPageProxy, void (WebKit::WebPageProxy::*)(unsigned long long, unsigned long long, unsigned long long)>(CoreIPC::ArgumentDecoder*, WebKit::WebPageProxy*, void (WebKit::WebPageProxy::*)(unsigned long long, unsigned long long, unsigned long long)) + 53
3 com.apple.WebKit2 0x00007fff8f17080a WebKit::WebProcessProxy::didReceiveMessage(CoreIPC::Connection*, CoreIPC::MessageID, CoreIPC::ArgumentDecoder*) + 144
4 com.apple.WebKit2 0x00007fff8f204372 WebKit::WebConnectionToWebProcess::didReceiveMessage(CoreIPC::Connection*, CoreIPC::MessageID, CoreIPC::ArgumentDecoder*) + 194
5 com.apple.WebKit2 0x00007fff8f170715 CoreIPC::Connection::dispatchMessage(CoreIPC::Connection::Message<CoreIPC::ArgumentDecoder>&) + 175
6 com.apple.WebKit2 0x00007fff8f1b3403 CoreIPC::Connection::dispatchOneMessage() + 139
7 com.apple.WebCore 0x00007fff88f9dc19 WebCore::RunLoop::performWork() + 201
8 com.apple.WebCore 0x00007fff88f9e1f7 WebCore::RunLoop::performWork(void*) + 71
9 com.apple.CoreFoundation 0x00007fff8f555841 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
10 com.apple.CoreFoundation 0x00007fff8f555165 __CFRunLoopDoSources0 + 245
11 com.apple.CoreFoundation 0x00007fff8f5784e5 __CFRunLoopRun + 789
12 com.apple.CoreFoundation 0x00007fff8f577dd2 CFRunLoopRunSpecific + 290
13 com.apple.HIToolbox 0x00007fff87b41774 RunCurrentEventLoopInMode + 209
14 com.apple.HIToolbox 0x00007fff87b41512 ReceiveNextEventCommon + 356
15 com.apple.HIToolbox 0x00007fff87b413a3 BlockUntilNextEventMatchingListInMode + 62
16 com.apple.AppKit 0x00007fff8a52dfa3 _DPSNextEvent + 685
17 com.apple.AppKit 0x00007fff8a52d862 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
18 com.apple.Safari.framework 0x00007fff864ce363 -[BrowserApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 162
19 com.apple.AppKit 0x00007fff8a524c03 -[NSApplication run] + 517
20 com.apple.AppKit 0x00007fff8a4c9656 NSApplicationMain + 869
21 com.apple.Safari.framework 0x00007fff8669d734 SafariMain + 166
22 libdyld.dylib 0x00007fff85ef47e1 start + 1

Thread 1:
0 libsystem_kernel.dylib 0x00007fff903526d6 __workq_kernreturn + 10
1 libsystem_c.dylib 0x00007fff8964cf2c _pthread_workq_return + 25
2 libsystem_c.dylib 0x00007fff8964ccf3 _pthread_wqthread + 412
3 libsystem_c.dylib 0x00007fff896371b1 start_wqthread + 13

Thread 2:: Dispatch queue: com.apple.libdispatch-manager
0 libsystem_kernel.dylib 0x00007fff90352d16 kevent + 10
1 libdispatch.dylib 0x00007fff8ea8de26 _dispatch_mgr_invoke + 883
2 libdispatch.dylib 0x00007fff8ea8da2a _dispatch_mgr_thread + 54

Thread 3:
0 libsystem_kernel.dylib 0x00007fff903526d6 __workq_kernreturn + 10
1 libsystem_c.dylib 0x00007fff8964cf2c _pthread_workq_return + 25
2 libsystem_c.dylib 0x00007fff8964ccf3 _pthread_wqthread + 412
3 libsystem_c.dylib 0x00007fff896371b1 start_wqthread + 13


Model: MacBookAir4,1, BootROM MBA41.0077.B0F, 2 processors, Intel Core i5, 1.6 GHz, 4 GB, SMC 1.74f1
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 384 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353737334448302D4348392020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353737334448302D4348392020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xE9), Broadcom BCM43xx 1.0 (5.106.98.81.20)
Bluetooth: Version 4.0.9f8 10405, 2 service, 11 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD TS128C, 121.33 GB
USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0xfd100000 / 2
USB Device: FaceTime Camera (Built-in), apple_vendor_id, 0x850a, 0xfa200000 / 3
USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0xfa100000 / 2
USB Device: BRCM20702 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0xfa110000 / 5
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821f, 0xfa113000 / 6
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0249, 0xfa120000 / 4



Watabou
Jul 12, 2012, 04:35 AM
Looking at the crash log, it looks like you have a plugin called SafariStand. Uninstall it and see if Safari works again.

I searched SafariStand on google and it looks like it changes some behavior of Safari and that might be interfering with it. Check that you don't have anything under ~/Library/Application Support/SIMBL/Plugins/

Delete it if you do

scootermafia
Jul 12, 2012, 04:41 AM
That totally just fixed the problem. I don't know how I didn't see the "stand" menu that was present in Safari. Somehow with Safaristand I completely forgot I even had it (it never showed itself when I had Lion installed, it was just lurking in the background and materialized with the ML install) so it was active. If anyone else gets Safari weirdness, go to library/application support/SIMBL/plugins and delete everything in there to fix this issue.