PDA

View Full Version : Still no iMessage file transfer in GM build




lancastor
Jul 15, 2012, 08:43 AM
File transfer (pictures etc.) in iMessage is still broken in the GoldMaster Build.

I think iMessage is still not working in Mountain Lions Final release. :(



cmChimera
Jul 15, 2012, 08:55 AM
File transfer (pictures etc.) in iMessage is still broken in the GoldMaster Build.

I think iMessage is still not working in Mountain Lions Final release. :(

I've been able to send files in messages. I've sent pictures, and even word documents. What issue are you having?

lancastor
Jul 15, 2012, 09:58 AM
Messages on Mac doens't send or receive pictures.

iLog.Genius
Jul 15, 2012, 10:47 AM
Not sure if you're having a specific problem or just having an issue with sending pictures/files on Mac through iMessage overall but I had zero issues with the beta and no problems with GM - can send files over iMessage with no problems.

cmChimera
Jul 15, 2012, 12:17 PM
Messages on Mac doens't send or receive pictures.

Yes it does. You may need to reinstall, or deactivate imessage and reactivate. It might be easier to diagnose if you post exactly what is going on instead of the very broad, "it doesn't work".

JCA90
Jul 15, 2012, 10:24 PM
I think I can explain, since I too have been having the same issue with the beta at least, I have not installed ML GM.
Basically whenever you try to send any file, be it a picture, document, song, what have you, Messages will (at least for me) log me out of all my current accounts (in my case AIM, Gtalk, and iMessage) and then log me back in and not send the file. Also, when I try to send a file to anyone on AIM it does the same. I uninstalled the beta and iChat worked fine transferring files again. Reinstalled Messages, issue returns.

NewAnger
Jul 15, 2012, 11:43 PM
Works great in the GM release. I set it up and sent a message to my phone for the first time with a photo attachment.

lancastor
Jul 16, 2012, 12:11 PM
Transfers stays forever in "waiting" state. I cannot send files via Messages on Mac and I cannot receive files on Mac.

I hope file transfer is possible in the final release of Mountain Lion.

By the way: Logging off and re-login my iCloud Account doesn't help.

lancastor
Jul 17, 2012, 10:46 AM
So, I must completely wipe my whole system to get Messages to work? :confused:

lancastor
Jul 17, 2012, 11:00 AM
Here is a detailed error message:

17.07.12 17:58:39,887 com.apple.imfoundation.IMRemoteURLConnectionAgent[12343]: [Warning] Denying xpc connection, task does not have entitlement: com.apple.private.imcore.imremoteurlconnection (IMTransferAgent:1607)
17.07.12 17:58:39,888 com.apple.imfoundation.IMRemoteURLConnectionAgent[12343]: [Warning] Denying xpc connection, task does not have entitlement: com.apple.private.imcore.imremoteurlconnection (IMTransferAgent:1607)
17.07.12 17:58:39,889 com.apple.imtransferservices.IMTransferAgent[1607]: [Warning] Remote loader crashed for request: <NSMutableURLRequest http://init-p01md.apple.com/bag>
17.07.12 17:58:39,889 com.apple.imtransferservices.IMTransferAgent[1607]: [Warning] Bag loading failed! Error (__kIMRemoteURLConnectionErrorDomain:-1): Der Vorgang konnte nicht abgeschlossen werden. (__kIMRemoteURLConnectionErrorDomain-Fehler -1.) (null)
17.07.12 17:58:39,892 com.apple.imfoundation.IMRemoteURLConnectionAgent[12343]: [Warning] Denying xpc connection, task does not have entitlement: com.apple.private.imcore.imremoteurlconnection (IMTransferAgent:1607)
17.07.12 17:58:39,899 com.apple.imtransferservices.IMTransferAgent[1607]: [Warning] Remote loader crashed for request: <NSMutableURLRequest http://init.ess.apple.com/WebObjects/VCInit.woa/wa/getBag?ix=1>
17.07.12 17:58:39,899 com.apple.imtransferservices.IMTransferAgent[1607]: [Warning] Bag loading failed! Error (__kIMRemoteURLConnectionErrorDomain:-1): Der Vorgang konnte nicht abgeschlossen werden. (__kIMRemoteURLConnectionErrorDomain-Fehler -1.) (null)
17.07.12 17:58:39,900 com.apple.imfoundation.IMRemoteURLConnectionAgent[12343]: [Warning] Denying xpc connection, task does not have entitlement: com.apple.private.imcore.imremoteurlconnection (IMTransferAgent:1607)

satchow
Jul 17, 2012, 11:18 AM
Transfers stays forever in "waiting" state. I cannot send files via Messages on Mac and I cannot receive files on Mac.

I hope file transfer is possible in the final release of Mountain Lion.

By the way: Logging off and re-login my iCloud Account doesn't help.

I was having a similar problem in iMessages Beta on Lion, but once I upgraded to Mountain Lion it started working again.

iLog.Genius
Jul 17, 2012, 01:11 PM
Ok. Let's be clear here. When sending files, are you using the iChat/AIM protocol or is this iMessage? For iMessage you can just drag/drop into the conversation window (don't use menu). I guess you could try and do the same thing if you're using the iChat/AIM protocol.

lancastor
Jul 17, 2012, 02:20 PM
I'm using iMessage and I'm dragging files directly into the conversation window. It worked great in DP1, DP2 and DP3. But it's broken now.

benguild
Jul 17, 2012, 06:54 PM
I'm using iMessage and I'm dragging files directly into the conversation window. It worked great in DP1, DP2 and DP3. But it's broken now.

I still drag or paste images into the chat prompt and it works fine? However I did a clean install/upgrade to GM from Lion.

Nozuka
Jul 18, 2012, 01:31 AM
mine is working fine too. but i also did a clean install.

lancastor
Jul 22, 2012, 08:59 AM
I have found a temporally solution:

1. Delete all files and directorys from /~/Library/Messages
2. Reboot your Mac

Now iMessages transfers files for 2-3 days. After that you have to delete the files again.

chrfr
Jul 23, 2012, 09:26 AM
I have found a temporally solution:

1. Delete all files and directorys from /~/Library/Messages
2. Reboot your Mac

Now iMessages transfers files for 2-3 days. After that you have to delete the files again.

It's been working all along for me on several computers without having to do this. I'd suggest checking logs when the transfers fail to see if there's anything in there that might help solve the real problem.

lancastor
Jul 23, 2012, 01:26 PM
It's been working all along for me on several computers without having to do this. I'd suggest checking logs when the transfers fail to see if there's anything in there that might help solve the real problem.

I posted the error logfiles in this thread already.

chrfr
Jul 23, 2012, 02:19 PM
I posted the error logfiles in this thread already.

So you did. Since they mention entitlements, the errors seem to indicate some issue with sandboxing. What happens when you make a new user account?

senohpoxas88
Jul 23, 2012, 05:10 PM
For some reason on the GM, I cannot even sign into iMessage. It worked fine for me on DP4, but as soon as I moved I have no access to using iMessage anymore.

I have a co-worker who is in the same boat. Anyone else experiencing this?

lancastor
Jul 24, 2012, 10:23 AM
It's weird. After exactly three days you have to wipe the /Messages directory to enable file transfers again. :confused:

matt2053
Jul 24, 2012, 10:39 AM
What if you right click the file in finder, go to Share > Messages. Does it work then, or is it the same behavior?

lancastor
Jul 29, 2012, 05:37 AM
It's a "Standby" issue. Logoff and re-login and file transfer is working again after hibernation.

cptodd
Jul 31, 2012, 12:00 AM
I too am having this very same issue. I can't send or receive picts to Messages though it works fine in iMessage. It exhibits the same behavior that others have outlined.

edg-R
Aug 2, 2012, 11:46 PM
I also have this problem once in a while. Up until now I didn't have a workaround for it.

Thank you lancastor for the tips.

Hopefully they get this resolved soon. This was the very issue I was hoping they would fix once it was RTM.

Another issue I have is that when I use facebook chat (via Jabber), there's a certain contact who never EVER shows up on Messages for mac. He can message me and I get it in facebook.com and on Facebook Messages for iPhone but it doesn't show up on Messages for Mac. I can start a conversation with him by sending him a message, but if he replies, it only goes to facebook.com and my phone. No clue about this one. I've tried deleting the jabber account and making a new one. Deleting his conversation. Restarting my computer. No luck.

lancastor
Aug 6, 2012, 09:50 AM
Issue still occurs on a completely fresh re-installed OS X ML. Current working fix: Log off from OS X and re-login. DONE.

But I hope Apple is working in that iMessage issue. I think it occurs only when using standby/hibernation. But I'm not 100% sure if standy is the real root cause of this issue.

lancastor
Aug 10, 2012, 01:27 PM
Here is a solution from Apple Discussions:

https://discussions.apple.com/message/19190885#19190885

Considering that reinstalling the operating system is NOT a solution, I searched for something myself.

Pictures are controlled by xpcd, imagent and Messages, and it seems that when the problem arises is because they're using the wrong Apple server.

While this may be solved by Apple in a update (I hope so), in the meantime you can do a workaround (it worked for me on two different machines, and even days old images appeared).

In your Library, there is a folder called Preferences (that is /Users/<your_username>/Library/Preferences). There you should delete com.apple.imagent.plist com.apple.imservice.iMessage.plist and com.apple.imessage.bag.plist, with Messages CLOSED. Then reboot so Messages creates new ones. Also delete all file starting with com.apple.imagent, com.apple.imservice, com.apple.imessage and com.apple.iChat that end in .lock.

If even then it still is not working, deleting all files starting with com.apple.imagent, com.apple.imservice, com.apple.imessage and com.apple.iChat 100% for sure. But when you reboot you'll find you need to input again your login data for iMessage, FaceTime, Yahoo chat, AIM chat, Google Talk and Jabber (if you used them on Messages/iChat).

Icy1007
Aug 10, 2012, 02:46 PM
File transfer in Messages works perfectly for me. Can send files, pictures, etc just fine. No need to delete any files.

shanezam203
Feb 5, 2013, 12:43 PM
I'm using iMessage and I'm dragging files directly into the conversation window. It worked great in DP1, DP2 and DP3. But it's broken now.

I'm having the same issue where I can Message fine on my iMac with iMessage but I can not send picture files anymore. I can drag and drop and send them, but they never get through to other person and I don't see them as Sent on my iPhone or iPad.

any idea how to fix this?