PDA

View Full Version : Warcraft III on 10.8




meme1255
Jul 15, 2012, 04:50 PM
Please, could someone try if Warcraft III 1.26a works on Mountain Lion? It is my most played game over LAN ..



molson2k
Jul 15, 2012, 05:06 PM
Please, could someone try if Warcraft III works on Mountain Lion? It is my most played game over LAN ..

It's impossible. The only way to play Warcraft III and/or Warcraft III: The Frozen Throne is to install the game on Snow Leopard, patch the game up so it becomes an Intel-native app. Then upgrade to Lion and/or Mountain Lion.

You cannot do a fresh install of Warcraft III on Lion or Mountain Lion.

meme1255
Jul 15, 2012, 05:09 PM
I meant playing, I'm playing fine on Lion! --> I have already installed ..;)

molson2k
Jul 15, 2012, 05:13 PM
I meant playing, I'm playing fine on Lion! --> I have already installed ..;)

Then it will work just fine.

meme1255
Jul 15, 2012, 05:15 PM
Then it will work just fine.



Did you tried it? I've read that The Frozen Throne crashes, but that was DP2 .. So it doesn't now? ;) If so, it looks like I can update!

thestickman
Jul 15, 2012, 05:55 PM
It's impossible. The only way to play Warcraft III and/or Warcraft III: The Frozen Throne is to install the game on Snow Leopard, patch the game up so it becomes an Intel-native app. Then upgrade to Lion and/or Mountain Lion.

You cannot do a fresh install of Warcraft III on Lion or Mountain Lion.

You can download the game client from Blizzard. Took 90 minutes on our U-verse connection. Works perfect.

iLog.Genius
Jul 16, 2012, 08:37 AM
It doesn't work. Warcraft III launches and works fine but there seems to be an issue with Frozen Throne. It SHOULD work but I guess there's a bug that prevents it from loading. Hopefully a patch is released to address this.

RoelJuun
Jul 16, 2012, 11:17 AM
You can download the game client from Blizzard. Took 90 minutes on our U-verse connection. Works perfect.

Could you please tell me what to do exactly? I've read about that method before after the Lion problems but couldn't find it on the Blizzard website…A link perhaps? (Of course my copy is legal so I've got a product key)

iMacFarlane
Jul 16, 2012, 03:03 PM
Warcraft III clients on the Blizzard.net will download an installer to your hard drive. It will not work because it is for the PowerPC environment, killed by Lion. If you already had Warcraft III installed when you upgraded to Lion, Warcraft III runs, but the Frozen Throne icon has the international "no" symbol over it (circle with a hash through it) and says the obligatory "Frozen Throne can't run because the PowerPC environment is no longer supported" message.

And, to top it all off, Warcraft III, although it does launch, is virtually unplayable because most of the images on screen have no textures. Can't read much, can't see much. Broken.

So, how are you playing Reign of Chaos without black textures? How are you launching Frozen Throne at all?

Would LOVE to get my Warcraft III back . . .

iLog.Genius
Jul 16, 2012, 03:18 PM
Warcraft III clients on the Blizzard.net will download an installer to your hard drive. It will not work because it is for the PowerPC environment, killed by Lion. If you already had Warcraft III installed when you upgraded to Lion, Warcraft III runs, but the Frozen Throne icon has the international "no" symbol over it (circle with a hash through it) and says the obligatory "Frozen Throne can't run because the PowerPC environment is no longer supported" message.

And, to top it all off, Warcraft III, although it does launch, is virtually unplayable because most of the images on screen have no textures. Can't read much, can't see much. Broken.

So, how are you playing Reign of Chaos without black textures? How are you launching Frozen Throne at all?

Would LOVE to get my Warcraft III back . . .

Maybe your post isn't as clear as you intended it to be but Warcraft III/Frozen Throne do work in Lion (no issues, assuming you patched everything before you upgraded to Lion). As for Mountain Lion, nothing has changed from Lion so both should work if you upgraded. Or so I thought. Like I said earlier, RoC works with zero issues but FT just crashes and gives "Warcraft III Quit Unexpectedly" error.

iMacFarlane
Jul 16, 2012, 05:02 PM
Maybe your post isn't as clear as you intended it to be but Warcraft III/Frozen Throne do work in Lion (no issues, assuming you patched everything before you upgraded to Lion). As for Mountain Lion, nothing has changed from Lion so both should work if you upgraded. Or so I thought. Like I said earlier, RoC works with zero issues but FT just crashes and gives "Warcraft III Quit Unexpectedly" error.

Well, I never knowingly patched them. I downloaded them onto my shiny new iMac back in 2010 and they worked great. Played them here and there and was pleased to know I'd get through Frozen Throne someday (Finished RoC campaign and the Bonus WoW style supermap, can't remember what it was called, though).

You're right, my problems with the textures must be because I never patched them from Snow Leopard.

Icy1007
Jul 16, 2012, 05:37 PM
WC3 and the Frozen Throne work just fine on my 10.7 install. I would suspect it will work on 10.8.

iMacFarlane
Jul 16, 2012, 05:45 PM
Wow, the madness continues . . .

After reading about the patches, I thought I'd run Warcraft III to try to patch it from within the game. Patch downloads, then crashes. I go to manually execute the patch, and the patching program is PPC only, so no go. Mother of God. Can't Blizzard just post the fully patched games for download? You need a battle.net account and a valid game key, so there's the proof you bought the damn thing. Crikey.

SiDVacant
Jul 17, 2012, 01:22 PM
im playing Warcraft III ROC and Frozen Throne on Mountain Lion GM

works fine.

meme1255
Jul 17, 2012, 01:52 PM
SiD: Thanks ;)

Tigrao
Jul 18, 2012, 10:08 PM
Warcraft III: The Frozen Throne also crashes for me on Mountain Lion. I've tried a few things to get it to work, included copying the installed, working game from a Lion machine. Nothing will work. It continues to crash. RoC opens just fine though. Weird!

iLog.Genius
Jul 18, 2012, 11:00 PM
Warcraft III: The Frozen Throne also crashes for me on Mountain Lion. I've tried a few things to get it to work, included copying the installed, working game from a Lion machine. Nothing will work. It continues to crash. RoC opens just fine though. Weird!

My experience. Seeing as how Warcraft III works, I hope Blizzard comes through with a patch or something to make Frozen Throne work.

MartiNZ
Jul 18, 2012, 11:56 PM
Wow, this all sounds even more frustrating than just the Lion transition. I'm in a situation right now where I'm trying to get my Mac WC3 install copied so over to friends with a new iMac and a separate licence. Still such a good LAN game indeed, especially in this age of otherwise "always online" games!

meme1255
Jul 19, 2012, 04:20 AM
Windows version over WINE should work fine but... I would like native version - Are you trying it on GM? :( Could you post crash report here?

Tigrao
Jul 19, 2012, 12:26 PM
Windows version over WINE should work fine but... I would like native version - Are you trying it on GM? :( Could you post crash report here?

First snippet of the crash report:

Process: Warcraft III [9789]
Path: /Applications/Warcraft III Folder/Warcraft III.app/Contents/MacOS/Warcraft III
Identifier: com.blizzard.WarcraftIII
Version: 1.0
Code Type: X86 (Native)
Parent Process: launchd [147]
User ID: 485413366

Date/Time: 2012-07-19 11:21:01.933 -0600
OS Version: Mac OS X 10.8 (12A269)
Report Version: 10
Sleep/Wake UUID: AFBDC2DA-C21B-4AA7-BEAB-22BC065A1F87

Interval Since Last Report: 56079 sec
Crashes Since Last Report: 2
Per-App Crashes Since Last Report: 1
Anonymous UUID: BECE203E-2337-4693-AF36-6C337D12AF1E

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000000000375d000

Full crash report: http://pastebin.com/qNfkgZCX

SiDVacant
Jul 19, 2012, 04:55 PM
I forgot.

Blizzard's official 1.26a Frozen Throne does not work on Mountain Lion.

So I had to modify Frozen Throne.app. then works fine.

If you want modified file. email me. Ripper@me.com

iLog.Genius
Jul 19, 2012, 06:19 PM
Can you PM me the file? Thanks.

Tigrao
Jul 20, 2012, 12:14 PM
Can you PM me the file? Thanks.

Why not share with the entire community?

iLog.Genius
Jul 20, 2012, 11:42 PM
Why not share with the entire community?

Or that. I just noticed his post count, you can't PM so just post a link in this thread.

SiDVacant
Jul 21, 2012, 02:18 AM
https://www.dropbox.com/s/qoznxp5nforcgqs/The%20Frozen%20Throne.zip

iLog.Genius
Jul 21, 2012, 08:57 AM
https://www.dropbox.com/s/qoznxp5nforcgqs/The%20Frozen%20Throne.zip

Appreciate the effort but it doesn't work.

I get a "Sorry, could not launch Warcraft III" error.

SiDVacant
Jul 21, 2012, 10:44 AM
Appreciate the effort but it doesn't work.

I get a "Sorry, could not launch Warcraft III" error.


you need move <Frozen Throne.app> to your warcraft III directory

warcraft III location must be </Applications/Warcraft III/>

not <Warcraft III Folder or else>

iLog.Genius
Jul 21, 2012, 12:10 PM
you need move <Frozen Throne.app> to your warcraft III directory

warcraft III location must be </Applications/Warcraft III/>

not <Warcraft III Folder or else>

Ok let me try that.

EDIT: Yes, it worked. Seems like I let the installer install to "Warcraft III Folder" where as you have it in "Warcraft III". Thanks.

UPDATE:Game works...but can't connect to Battle.net. Any ideas with that?

UPDATE 2: had to delete all the plists in Preferences folder. Now everything works.

SiDVacant
Jul 21, 2012, 12:21 PM
i can connect battle.net and play

----------

Ok let me try that.

EDIT: Yes, it worked. Seems like I let the installer install to "Warcraft III Folder" where as you have it in "Warcraft III". Thanks.

UPDATE:Game works...but can't connect to Battle.net. Any ideas with that?

UPDATE 2: had to delete all the plists in Preferences folder. Now everything works.

good for you

meme1255
Jul 21, 2012, 12:30 PM
Thanks for really good news! ;) If you can connect to battle.net, in my opinion is almost sure that LAN games will work!

PS: I really want to know why official FT is crashing... Do you know the reason, SiDVacant? :confused:

slynger
Jul 21, 2012, 03:30 PM
so I'm a little late in this thread; but am I reading this correctly that WC3 will install under ML. I only have the game discs and couldn't install under Lion. Or is it working under Parallel, I'm a little confused at this part??

RoelJuun
Jul 21, 2012, 07:09 PM
Wirelessly posted

It should work when tou've installed the game on snow leopard (32 bit installer) and have upgraded all the way to Mountain Lion (maybe with the help of some modified files as posted before in this thread). If Blizzard just updates the installer to 64 bit and will put some effort in bug hunting it would be nice...ah well, Mac users..

MartiNZ
Jul 25, 2012, 09:26 PM
I've just tried the linked download but not got it to work on the ML release despite being in /Applications/Warcraft III. Not sure what else might be amiss. Anyone else tried this?

Tigrao
Jul 25, 2012, 10:45 PM
I've just tried the linked download but not got it to work on the ML release despite being in /Applications/Warcraft III. Not sure what else might be amiss. Anyone else tried this?

It worked great for me. I installed the game back on Leopard on a 2008 MacBook. That MacBook has been upgraded to Lion since then. I copied the game files from that machine over to my 2011 MacBook Air running Mountain Lion. Using the linked zip file and renaming my game folder to /Applications/Warcraft III got it running perfectly!

MartiNZ
Jul 26, 2012, 02:31 AM
Damn. Oddly after trying that and then later restarting, it did load once, just using the original frozen throne launcher ... but just once. Very curious error, hopefully an official fix comes. Can't get the linked one to work at all :(.

acharetidis
Jul 26, 2012, 08:25 AM
https://www.dropbox.com/s/qoznxp5nforcgqs/The%20Frozen%20Throne.zip

The linked file didn't work for me either. I deleted the preference files, the path is Applications/Warcraft III, but The Frozen Throne app still crashes when it is launched.

SiDVacant could you possibly tell us what you modified so we can do it our selves? Maybe it's because of different macs.

iLog.Genius
Jul 26, 2012, 08:30 AM
Small problem I found is while trying to connect to Battle.net, it won't work unless you re-select the region and then try to connect again.

Xavier
Jul 26, 2012, 09:15 AM
It doesn't run for me at all. It bounces in the dock for a bit then says "Warcraft 3 unexpectedly quit." I hope Blizzard releases an update for this soon.

SiDVacant
Jul 26, 2012, 01:40 PM
if not work

go The Frozen Throne.app right click Show package contents

force open file "/Contents/MacOS/The Frozen Throne"

canucksfan88
Jul 26, 2012, 01:57 PM
if not work

go The Frozen Throne.app right click Show package contents

force open file "/Contents/MacOS/The Frozen Throne"

confirmed this works. i think i will play and wait for a official patch - assuming that comes one day haha

Xavier
Jul 26, 2012, 04:58 PM
if not work

go The Frozen Throne.app right click Show package contents

force open file "/Contents/MacOS/The Frozen Throne"

Thanks for the find! This works. Odd that it doesn't work normally though.

meme1255
Jul 26, 2012, 06:05 PM
Found how add this from /macOS to Dock: rename it to frozenthrone.app, add it into dock & then get info it and delete .app extension. Works! Hooray! And you don't notice it isn't normal app if you give it frozen throne icon ;) if you don't know how to do that, write me PM :).

PS: C&C:Generals works too! More game tesst later :)

acharetidis
Jul 27, 2012, 02:18 AM
Alright guys, i found the solution for my case because i tried everything everyone has said so far and nothing worked for me.

In the Frozen Throne application there was a problem with a "broken" alias file. Click Show Package Contens -> Contents -> Resources -> The Frozen Throne (not the .icns file, but the one with no extension). That file was a broken alias for some reason, so i copied this file from my Snow Leopard macbook Warcraft installation and now everything works fine. I don't need to force open the Frozen Throne exec or anything.

Thanks to all for the solutions you posted and i hope i helped too!

appletechpro
Jul 27, 2012, 11:35 AM
Not sure why everyone is having issues...

I upgraded from Lion --> ML
Warcraft III Frozen Throne still opens without any issues and can connect to Battle.net

My set-up:

OS X 10.8
Optibay HDD containing Warcraft III Application folder from a Snow Leopard install
Fully updated W3

Repo
Jul 27, 2012, 03:14 PM
if not work

go The Frozen Throne.app right click Show package contents

force open file "/Contents/MacOS/The Frozen Throne"

Yes! This fixed it for me. Thank you!

Just FYI: When I launched TFT from my dock, it would attempt to open then "quit unexpectedly." When I selected to "reopen" it, ROC would launch (successfully) instead.

When I initially upgraded to ML, TFT still worked without a hitch. A few resets later seems to have broken that.

Beezzy
Jul 27, 2012, 04:45 PM
I have WCIII running on the bootcamp side of my Mac on Win7 cause I wanted to play SW:TOR really bad lol

MartiNZ
Jul 27, 2012, 06:34 PM
Man, so ML has caused some curious issues launching things, and it is not consistent ><. The force open binary file didn't work for me :(. This is a 2011 iMac fwiw.

I'm trying to get it working for my cousins to do LAN play with a Windows machine. Boot camp may be the best option in the end, especially for other games as well.

Also found that Littlewing's pinball games don't work on this ML install - they just open with a black screen. You can still control it but pinball kind of relies on sight :). And you never could do windowed mode or get into the background with their games.

Philippone
Jul 28, 2012, 12:11 PM
if not work

go The Frozen Throne.app right click Show package contents

force open file "/Contents/MacOS/The Frozen Throne"
At first I downloaded your file and my Frozen Throne worked again. It's been flawless couple of days and now I restarted my laptop and it does not work again!(( man, u gotta do something about it.
Tried to force open through Contents/... Same thing occurs. Fail to open.

acharetidis
Jul 28, 2012, 01:56 PM
Stoped working for me too. It worked two random times, i quit the app and then the same error. If a fix doesn't come, i don't think i'll be able to play.

SiDVacant
Jul 28, 2012, 02:00 PM
redownload file and repeat again.

i dont know why

MartiNZ
Jul 28, 2012, 05:16 PM
Well what was your file trying to do to the original? I really think at this point that ML is being inconsistent; things are changing between restarts in this regard, pain of an OS lol.

fr00tl00p
Jul 29, 2012, 12:45 AM
All right guys, I just got back from a LAN party with my friends, and ML is messing up Frozen Throne. Here's what I've gathered so far:

Launching "The Frozen Throne.App" causes it to crash about ~95% of the time. (I'm being serious here, just spam the button and after about 15 tries it'll launch.)
If you click "Reopen" on the dialog, it will launch Reign of Chaos, also odd.

If you right click "The Frozen Throne.App" and click view package contents, then navigate to "Contents/MacOS/The Frozen Thone" and open that, it opens for me every time.

Oh, and to make this even more confusing, if you move the location of the "Warcraft III" folder to somewhere else, and then try launching "The Frozen Throne.App", It'll launch, once. And after that it'll go back to crashing most of the time.

My best guess is the Gate Keeper (A new security feature in 10.8) is causing this.

Under Lion I never had any problems opening the App.

--To Install Under Lion (And ML)--
Since PPC apps were deprecated in 10.7, you must install and patch Warcraft from Snow Leopard or lower and copy the files to to Lion or higher. (Or upgrade after you install.) If you have Lion or higher, than I would recommend using Virtual Box to create a VM with Snow Leopard and use that to install it, and then copy the files from that.


I hope this post helped someone!

appletechpro
Jul 29, 2012, 07:52 AM
Launching "The Frozen Throne.App" causes it to crash about ~95% of the time. (I'm being serious here, just spam the button and after about 15 tries it'll launch.)
If you click "Reopen" on the dialog, it will launch Reign of Chaos, also odd.

If you right click "The Frozen Throne.App" and click view package contents, then navigate to "Contents/MacOS/The Frozen Thone" and open that, it opens for me every time.

I can verify this behavior on my end. I even tried re-installing the game in a Snow Leopard instance, and copying over the files once again.

Oddly enough, right after I had upgraded to ML it was working, then after a day or two I could no longer open The Frozen Throne.app -- now I can't play the game at all since attempting to open Contents/MacOS/The Frozen Throne now results in the same application crash. If I click re-open on the crash window, I'm able to load Warcraft III RoC.

My best guess is the Gate Keeper (A new security feature in 10.8) is causing this.

Gatekeeper is disabled on my machine yet the issue persists. I also had tried trashing my com.blizzard.WarcraftIII Preferences file to not avail.

fr00tl00p
Jul 29, 2012, 05:33 PM
Gatekeeper is disabled on my machine yet the issue persists. I also had tried trashing my com.blizzard.WarcraftIII Preferences file to not avail.

I don't believe that going into System Preferences and changing it so that you can install apps from anywhere actually disables Gate Keeper Completely, I'm still trying to look into it. Did you try moving the entire WIII folder to a different location and launching it then?

appletechpro
Jul 29, 2012, 09:56 PM
I don't believe that going into System Preferences and changing it so that you can install apps from anywhere actually disables Gate Keeper Completely, I'm still trying to look into it. Did you try moving the entire WIII folder to a different location and launching it then?

Unfortunately, it doesn't appear to matter where I attempt to launch the program from, either my Snow Leopard partition containing the actual installation, or the rsync'd folder of the W3 installed under /Applications on my ML installation, etc.

For now I'm just booting into Snow Leopard whenever I want to play, which is less than optimal. Hopefully Blizzard patches TFT soon...

meme1255
Jul 30, 2012, 04:26 PM
If they release patch (I don't think so), I hope that it will be just modified 1.26a :)

calientedrama
Jul 31, 2012, 01:32 PM
Hello folks!

I have found a solution!

Go to "Replays" folder and double click "Last Replay".

Your last replay will open.

Then go Menu-->End Game-->Quit Mission.

Frozen Throne is open now. Let me know if it works for you.

GL HF!!!!

appletechpro
Jul 31, 2012, 04:44 PM
Hello folks!

I have found a solution!

Go to "Replays" folder and double click "Last Replay".

Your last replay will open.

Then go Menu-->End Game-->Quit Mission.

Frozen Throne is open now. Let me know if it works for you.

GL HF!!!!

You sir, are a gentleman and a scholar.

Schakra
Aug 4, 2012, 12:41 PM
Hello folks!

I have found a solution!

Go to "Replays" folder and double click "Last Replay".

Your last replay will open.

Then go Menu-->End Game-->Quit Mission.

Frozen Throne is open now. Let me know if it works for you.

GL HF!!!!

You are a genius! :)
Thanks!

Mutassem
Aug 12, 2012, 11:22 PM
Hello folks!

I have found a solution!

Go to "Replays" folder and double click "Last Replay".

Your last replay will open.

Then go Menu-->End Game-->Quit Mission.

Frozen Throne is open now. Let me know if it works for you.

GL HF!!!!

This patch didn't work for you ?? FrozenThrone.app ?
https://www.dropbox.com/s/qoznxp5nforcgqs/The%20Frozen%20Throne.zip

calientedrama
Aug 13, 2012, 04:10 AM
This patch didn't work for you ?? FrozenThrone.app ?
https://www.dropbox.com/s/qoznxp5nforcgqs/The%20Frozen%20Throne.zip

Nope! It worked only for a couple of times and then...

The only stable solution I have found is the one that I mentioned above.

pdafan
Aug 13, 2012, 10:31 AM
Nope! It worked only for a couple of times and then...

The only stable solution I have found is the one that I mentioned above.

Don't you guys get a blackened mini map and border?
It can launch but the mini map is a black box.

calientedrama
Aug 13, 2012, 12:19 PM
Don't you guys get a blackened mini map and border?
It can launch but the mini map is a black box.

We didn't have any problem with a macbook pro mid 2009, with an iMac mid2007 and with an imac 2010.

However, we did have this problem with a macbook air mid 2012 without being able to solve the problem.

pdafan
Aug 14, 2012, 01:15 AM
We didn't have any problem with a macbook pro mid 2009, with an iMac mid2007 and with an imac 2010.

However, we did have this problem with a macbook air mid 2012 without being able to solve the problem.

Thanks.
Mine is a Mac mini 2011.
I had WC3/TFT up running since late 2011 on Lion but always had this black-out mini map issue.
Was so happy to see that ML might have resolved the issue until I tried last night. Disappointed once again.
:(

Icy1007
Aug 14, 2012, 01:17 AM
All right guys, I just got back from a LAN party with my friends, and ML is messing up Frozen Throne. Here's what I've gathered so far:

Launching "The Frozen Throne.App" causes it to crash about ~95% of the time. (I'm being serious here, just spam the button and after about 15 tries it'll launch.)
If you click "Reopen" on the dialog, it will launch Reign of Chaos, also odd.

If you right click "The Frozen Throne.App" and click view package contents, then navigate to "Contents/MacOS/The Frozen Thone" and open that, it opens for me every time.

Oh, and to make this even more confusing, if you move the location of the "Warcraft III" folder to somewhere else, and then try launching "The Frozen Throne.App", It'll launch, once. And after that it'll go back to crashing most of the time.

My best guess is the Gate Keeper (A new security feature in 10.8) is causing this.

Under Lion I never had any problems opening the App.

--To Install Under Lion (And ML)--
Since PPC apps were deprecated in 10.7, you must install and patch Warcraft from Snow Leopard or lower and copy the files to to Lion or higher. (Or upgrade after you install.) If you have Lion or higher, than I would recommend using Virtual Box to create a VM with Snow Leopard and use that to install it, and then copy the files from that.


I hope this post helped someone!

The Frozen Throne opens every time for me. I've had no issues with the game.

ryansebiz
Aug 18, 2012, 05:23 PM
I'm running Snow Leopard 10.6.8 on my MBP. RoC installs and updates, but when I try to install TfT I get this error:

http://i.imgur.com/k8NGE.png

I deleted all the Blizzard plist files in ~/Library/Preferences but this error persists.

Any ideas how I can install TfT?

fr00tl00p
Aug 18, 2012, 11:17 PM
I'm running Snow Leopard 10.6.8 on my MBP. RoC installs and updates, but when I try to install TfT I get this error:

Image (http://i.imgur.com/k8NGE.png)

I deleted all the Blizzard plist files in ~/Library/Preferences but this error persists.

Any ideas how I can install TfT?

Judging from the error, it seems simply that the disc cannot be read. (Either dirty or scratched.) I know you can find links from Blizzard that will let you download the installer if you put in your CD key.

EDIT: Actually, it looks like you've already done that, which leads me to believe that the file is corrupt. You should try downloading it again.

ryansebiz
Aug 20, 2012, 01:40 PM
EDIT: Actually, it looks like you've already done that, which leads me to believe that the file is corrupt. You should try downloading it again.

That did the trick - thank you!

calientedrama
Aug 24, 2012, 02:40 PM
After the last update (10.8.1) Warcraft opens without problems!!


EDIT:

Although yesterday opened 3-4 times without a problem, today the problem still exists (this game will drive me crazy)!

In addition, if you try to open the last replay (as I mentioned above) you get a message that this is a powerpc application and is no longer supported.

To deal with this issue, right click and the click get info--->open with ---> select reign of chaos ---> change all.

Repo
Sep 4, 2012, 02:34 PM
Hello folks!

I have found a solution!

Go to "Replays" folder and double click "Last Replay".

Your last replay will open.

Then go Menu-->End Game-->Quit Mission.

Frozen Throne is open now. Let me know if it works for you.

GL HF!!!!

God bless you.

WoWisfun
Sep 4, 2012, 03:58 PM
Try control-click on the frozen throne. click on show package contents. click on The Frozen Throne and it works! if u dont see it click on MacOS folder and it should be in there! weird that it doesn't work when you click on the app.

halbouni
Sep 20, 2012, 07:08 PM
hey guys !!
m new in mac and i jes bought the new macbook pro with retina display with the latest version.. i did download the warcraft III ROC and TFT but how to install and play ?? plz i need some help here with details cause my english is not that good :) msg me on my mail plz
m_halbouni@hotmail.com ( remember in details plz )

Freida
Sep 21, 2012, 05:12 PM
hey guys !!
m new in mac and i jes bought the new macbook pro with retina display with the latest version.. i did download the warcraft III ROC and TFT but how to install and play ?? plz i need some help here with details cause my english is not that good :) msg me on my mail plz
m_halbouni@hotmail.com ( remember in details plz )

I would like to know if there is install workaround too.
Any progress on that now?

halbouni
Sep 21, 2012, 10:33 PM
I would like to know if there is install workaround too.
Any progress on that now?

:S not really i havent received any mail yet..m workin on it .
as soon as i get s solution i will mail it to u.. and plz if u find any mail it to me :)

shazadkhan
Oct 8, 2012, 12:03 AM
redownload file and repeat again.

i dont know why

So I did this...and it worked...except:

1. It started Reign of Chaos, and not Frozen Throne
2. I can't update it.

Next Gen Nerd
Oct 20, 2012, 10:37 AM
I plan to buy Warcraft III Rein of Chaos and The Frozen Throne from Best Buy today, will it not work on my Mountain Lion (10.8.2) Mac Book Pro?
If I try a transfer method from another Mac (below 10.6) that had installed Warcraft 3 RoC and TFT to my ML Mac, will it then work?

marzzbar
Nov 6, 2012, 03:49 PM
You could also use Wineskin to install and run the windows version. I wrote a blog post detailing the process: http://marzzbar.wordpress.com/2012/11/06/how-to-play-classic-blizzard-games-on-mac-os-x-mountain-lion/

Operationlvy
Dec 19, 2012, 02:27 AM
Just got a new Mac and transferred over Warcraft III via Migration Assistant (along with all applications, but not the users).


When connecting to Bnet, it gives the "Tried to install to HD, check if space is available" error. This error was common with Vista, the fix was to run it as an administrator.


I assume this error is because of an administrator user issue, since I created a new user on the new Mac and transferred only the Applications with Migration Assistant.


Any way to get around this and not have to re-install via the methods described in this thread?

8000rpm
Mar 20, 2013, 05:30 PM
Any official updates? I bought a retina and ill be selling it of I can't get TFT to play. I have it installed on an 11 iMac at home and on several ssds I swap from alienwares I've bought recently so I have several installed patched and playable copies.

I downloaded from bnet but it downloads somewhere and there's no icons to click .. Not sure where to begin ...

8000rpm
Mar 20, 2013, 09:32 PM
I do have a copy of snow leopard I purchased a long time ago.. Can I reinstall snow leopard.. Install TFT patch it and then upgrade it to the current os?

8000rpm
Mar 21, 2013, 08:50 PM
Well I just copied the wc3 folder onto a USB stick from my iMac and pasted it into the app folder on my new retina mbp 15. Clicked the TFT logo and it fires up and works perfectly :)

I'm not one to give advice but what I did is :

On an older Mac (2011 iMac 27)
Log onto bnet
Download wc3
Download TFT (into wc3 folder)
Open TFT let it update and played a quick game online

Copy entire wc3 folder and paste onto thumb drive
Copy/paste from thumb drive into app folder in MacBook Pro
Open app folder, click into wc3 folder and click the TFT icon.

Hope it helps anyone.

Schranke
Mar 22, 2013, 02:24 AM
Well I just copied the wc3 folder onto a USB stick from my iMac and pasted it into the app folder on my new retina mbp 15. Clicked the TFT logo and it fires up and works perfectly :)

I'm not one to give advice but what I did is :

On an older Mac (2011 iMac 27)
Log onto bnet
Download wc3
Download TFT (into wc3 folder)
Open TFT let it update and played a quick game online

Copy entire wc3 folder and paste onto thumb drive
Copy/paste from thumb drive into app folder in MacBook Pro
Open app folder, click into wc3 folder and click the TFT icon.

Hope it helps anyone.

if this help i need to find some 1 with SL since i do not have one anymore..
damm i miss wc3

sniffs
Mar 22, 2013, 01:15 PM
Well I just copied the wc3 folder onto a USB stick from my iMac and pasted it into the app folder on my new retina mbp 15. Clicked the TFT logo and it fires up and works perfectly :)

I'm not one to give advice but what I did is :

On an older Mac (2011 iMac 27)
Log onto bnet
Download wc3
Download TFT (into wc3 folder)
Open TFT let it update and played a quick game online

Copy entire wc3 folder and paste onto thumb drive
Copy/paste from thumb drive into app folder in MacBook Pro
Open app folder, click into wc3 folder and click the TFT icon.

Hope it helps anyone.

Couldn't this theoritically work for Diablo II And D2: LOD?

meme1255
Jun 13, 2013, 04:42 PM
Someone with 10.9 DP1 to test it? :)

Dominique89
Jul 29, 2013, 03:12 AM
I am on a 10.8 macbook pro and installed warcraft and frozen throne by installing it on an older version and moving it across. But I am still having problems actually playing the game.

The game starts up fine but if I go into settings it freaks out and I have to force quit the application.

I play this game mostly at lans but the lan function isn't working properly either. I cant see others games and I also cant start a game myself. When I try it just resets to the main screen. I tried installing the modified files from SiDVacant but it still doesn't fix my issue.

Any ideas :mad:

hlongo
Aug 2, 2013, 10:38 AM
We have been trying to play warcraft 3 on our PC against a player in the same home on his mac. Any suggestions?

meme1255
Aug 3, 2013, 04:59 AM
Do you have same versions, same IP-subnet?

Tigrao
Aug 12, 2013, 02:33 PM
Someone with 10.9 DP1 to test it? :)

The game itself works fine on single player, but when clicking local area connection it gives an error saying "could not connect to network."

meme1255
Aug 12, 2013, 02:57 PM
I hope that you're joking :(:(:mad:

Tigrao
Aug 21, 2013, 11:08 AM
I hope that you're joking :(:(:mad:

Unfortunately, I am not joking. I am hoping it is just my machine, but I don't have another 10.9 machine to test with. I may end up having a Mountain Lion and a Mavericks partition on my machine after the final release, just so I can continue to play Warcraft III network games.

Jovian9
Oct 18, 2013, 07:43 PM
Update to this thread for those who love WC3:

2013 27" iMac
OSX Mavericks (GM build)

Tonight I downloaded and installed WC3 ROC and WC3 TFT directly from my battle.net account on Blizzards website directly to a G4 iMac running OSX Tiger 10.4.11. I installed the patches and ran the game (everything was working as well as battle.net).

I copied the entire WC3 folder (in the applications folder) onto a thumb drive and put it onto my new iMac. After first running WC3 it took a moment and the screen flashed a few times and the game started. I changed the settings to match the display and it is running great and looks great. Both ROC and TFT are working fine and playable.

.....except battle.net. It will not connect. I've attached the error. For me this is okay b/c I don't use that aspect of the game. But for others this will obviously be an issue.

Tigrao
Oct 23, 2013, 10:54 AM
2013 27" iMac
OSX Mavericks (GM build)


.....except battle.net. It will not connect. I've attached the error. For me this is okay b/c I don't use that aspect of the game. But for others this will obviously be an issue.

Yeah... Mavericks obviously changed something with the networking layer and Warcraft 3 doesn't even know that there is a network card in the system anymore. I hope that we can figure out how to make the game recognize a network card in Mavericks...

proov
Oct 23, 2013, 10:56 AM
same error for me.... could not connect the network or battle.net :(

goMac
Oct 29, 2013, 04:32 PM
Mavericks removed Open Transport, which was shared with OS 9 about a decade ago. Given that WCIII was coded for OS 9 and OS X, and it's pretty old, I'm thinking there is a good chance Open Transport being cut killed the network capabilities.

iLog.Genius
Nov 1, 2013, 09:16 AM
Mavericks removed Open Transport, which was shared with OS 9 about a decade ago. Given that WCIII was coded for OS 9 and OS X, and it's pretty old, I'm thinking there is a good chance Open Transport being cut killed the network capabilities.

This. Apple isn't going to fix this (they removed Open Transport for their reasons) which leaves Blizzard to write an update/patch and Warcraft III being such an old game, it's not likely they'll be doing this anytime soon.

iG.
Nov 3, 2013, 07:00 AM
Hi everyone,

I would like to thank all of you for your input, but I am still facing a problem with Warcraft 3. I own a 13' MB Pro (OS X 10.8.5) bought in september of this year and I successfully installed War3 by copying the files from my previous MB Unibody bought four years ago (OS X 10.6). The game runs just fine and I can log onto Bnet but some icons and the in-game minimap are black.

I tried re-installing the game, same thing happens.
I tried the PC version from my brother and downloaded that chinese file, same problem.

The game plays just fine but I am not enjoying the online gaming since I can't use the minimap (which makes it incredibly hard to win as you can expect). And I can't use my previous MacBook to play since my mum is using it and I am living in another town.

Does anyone know how to fix this problem?? I really want to play that game again. I guess I'll just move to StarCraft II if there is no solution...

Thanks for reading

meme1255
Nov 3, 2013, 07:17 AM
Is there someway how to copy 10.8 network layer (maybe as some kind of symlink for W3) ?

Btw.: How about using wineskin wrapper? Is network working in wrapper? I'll take a look on it :)

Triskelon1488
Jan 19, 2014, 10:54 AM
I got Zero hour working with open transport, would someone smart post the code to get Warcraft 3 TFT to work with mavericks? I've tried and failed.

http://forums.macrumors.com/showthread.php?t=1660889