PDA

View Full Version : AVCHD folders showing as a Package




labtopia
Jul 18, 2012, 01:19 PM
has anyone got an idea of how to keep the new finder from showing folders with avchd content as packages?

i just want finder to show folders as folders. this seems to be really dumb thing they've done and i cannot seem to find a preference somewhere.



timdafweak
Jul 18, 2012, 09:42 PM
has anyone got an idea of how to keep the new finder from showing folders with avchd content as packages?

i just want finder to show folders as folders. this seems to be really dumb thing they've done and i cannot seem to find a preference somewhere.

I am sorry, I don't have an answer to this, but WOW am amazed at how well my MTS files play with QuickTime without the need of any codecs. In fact iPhoto can play the movies natively! I have waited for this so long.

labtopia
Jul 18, 2012, 09:46 PM
yeah but this is a nightmare for data management- on a file level why in gods name would want an os to do this?

i have defaultapp app and have dissabled the com.avchd, waiting for a download to finish to reboot and see if this fixes this problem.

iThinkergoiMac
Jul 19, 2012, 04:54 AM
You can always just right-click (ctrl-click/two finger click) and choose "Show Package Contents..."

labtopia
Jul 20, 2012, 08:44 AM
You can always just right-click (ctrl-click/two finger click) and choose "Show Package Contents..."

that's not really an option, i need to browse folders and files in the file system as folders and files. interestingly the same files on an NTFS partition are handled correctly and dont show this bundleing.

iThinkergoiMac
Jul 20, 2012, 12:00 PM
OK... what DOES happen when you double-click it?

labtopia
Jul 20, 2012, 12:10 PM
OK... what DOES happen when you double-click it?

they have it set to open in QT player, not very usefull for a content creator. i've tried to use defaultapp.app to disable the com.avchd plist (which is set to QT default) but that doesnt do it.

i'm hoping when this releases next week, this will be in the flood of issues and an answer to fix will pop up.

iThinkergoiMac
Jul 20, 2012, 12:26 PM
they have it set to open in QT player, not very usefull for a content creator. i've tried to use defaultapp.app to disable the com.avchd plist (which is set to QT default) but that doesnt do it.

What do you edit with? Final Cut and iMovie both convert the files first (or SHOULD, if you're using FCPX, I think it'll edit AVCHD natively, but that's slow) so having the file structure doesn't seem to be relevant. Are you using Premiere?

Without trying to critique whatever setup you have too much, editing native AVCHD is pretty slow, so you should ideally be transcoding to an intermediate format before editing, which would mean you'd be setting up your own file structure anyway.

TomLenham
Aug 23, 2012, 07:53 AM
This is crazy - there has to be a way to disable it! I'm working professionally on Avid, and I can no longer import any footage at all!

----------

[QUOTE= Without trying to critique whatever setup you have too much, editing native AVCHD is pretty slow, so you should ideally be transcoding to an intermediate format before editing, which would mean you'd be setting up your own file structure anyway.[/QUOTE]

I don't think it matters if he's transcoding or not - the point is that the NLE cannot see the files to import. That would be the same in FCP/Avid/Premiere

Small White Car
Aug 23, 2012, 08:15 AM
that's not really an option, i need to browse folders and files in the file system as folders and files. interestingly the same files on an NTFS partition are handled correctly and dont show this bundleing.

Ok, so what happens if you 'show package contents' and just drag the videos to another folder?

vladster
Aug 23, 2012, 11:43 AM
has anyone got an idea of how to keep the new finder from showing folders with avchd content as packages?

i just want finder to show folders as folders. this seems to be really dumb thing they've done and i cannot seem to find a preference somewhere.

Install alternate file browser, like muCommander and browse it just like a directory.

KleinesLicht
Sep 6, 2012, 07:57 AM
Hi,

I had the same problem, my temporary solution was to rename the folders with the "mucommander" from "AVCHD" and "BDMV" to "AVCHDD" and "BDMVV". After that I was able to watch the .mts files again with the finder. :D

Mfg.:
Tom

Blashyrkh2124
Sep 17, 2012, 02:54 AM
I'd like to get this forum active again as there still doesn't seem to be a solution and this is irritating as hell!

Isn't there a sudo command or anything? =P

selsyn
Sep 20, 2012, 07:52 AM
Hey all,

Someone on the Appleboards wrote an apple script to access your AVCHD files.
https://discussions.apple.com/message/19111053#19111053

After running it, you may then drag/drop (move) the files to the parent folder, (that you are able to access, where the in-accessible PRIVATE and AVCHD [QT 'package' files] live.)

I did a silent video of a working example here:
http://youtu.be/nZlTzddiEOk

It was in response to another guy that said Apple's position on this is "Use iMovie to import your AVCHD's"! Really... or are they kidding... I do like the fact they are *finally* implementing AVCHD in QT, but iMovie imports take *forever*!

I'm a professional media maker on Avid/Mac and I can't believe this is Apple's stance. I need to access the AVCHD files *I* created in *my* camera!

I'm pouring over all the .com and .plist files in Mountain to see if I can change this behavior internally. No luck as of yet.


jk

dcorban
Sep 20, 2012, 09:07 AM
The idea is that no one would work directly with the MTS files since they need to be transcoded. Also, for playback, the entire package is usually required. The package format ensures everything is there for proper playback and importing into apps.

Did anyone explain why the "show package contents", then dragging files out does not work?

selsyn
Sep 20, 2012, 09:24 AM
The idea is that no one would work directly with the MTS files since they need to be transcoded.
Did anyone explain why the "show package contents", then dragging files out does not work?

I see, so we can't use the transcoder of *our* choice, it has to be yours... hmm.

I've got a few hundred daily directories, and several hundred more camera roll numbered directories inside those. All stored on a master raw-footage drive. I can't be bothered with renaming folders, show package contents, or working with iMovie. This script involved less clicks.

I guess you never heard of Avid's ability to AMA Link via a plugin to preview avchd content in our NLE *before* a transcode.

It's too bad I'm locked out of accessing my folder structure on the card. At the very least give us the option to disable such a big-brother ownership of all that is AVCHD.

I just hope Apple will do the right thing here.



thanks for your input,
jk

labtopia
Dec 26, 2012, 07:16 AM
yeah, still apple doesnt seem to care about anything but forcing users to use their OS the way they think they should.

i'll try the muCommander and the applescript and see if this introduces too many steps to get to the files, we are a professional post facility and unnecessary steps hamper productive workflow.

this issue is what is preventing me from upgrading all of my editorial systems still.

thanks for the comments to my original post.

dave