PDA

View Full Version : VERY BAD Fullscreen Video Playback




natd1993
Jul 19, 2012, 03:55 PM
Any flash video I play in fullscreen in ML is choppy and unwatchable. This was not the case in Lion. And yes, I know I shouldn't be using Adobe Flash, but some sites demand it. Anyone else experiencing this, even better, a fix?



JS82712
Jul 19, 2012, 03:57 PM
Any flash video I play in fullscreen in ML is choppy and unwatchable. This was not the case in Lion. And yes, I know I shouldn't be using Adobe Flash, but some sites demand it. Anyone else experiencing this, even better, a fix?

Nope, no issues here; perhaps you should reinstall flash?

natd1993
Jul 19, 2012, 04:15 PM
Nope, no issues here; perhaps you should reinstall flash?

Thanks for the tip, but no luck. I've noticed that if I change my monitors rez to 720p from 1080, the playback is alot smoother. Anyone got any suggestions?

EDIT:

I fixed it. Right clicked on a choppy flash video to see the 'Flash Player settings' menu. I clicked on the 'Enable Hardware Acceleration' toggle, and everything back to normal. :)

Ddyracer
Jul 19, 2012, 05:36 PM
Thanks for the tip, but no luck. I've noticed that if I change my monitors rez to 720p from 1080, the playback is alot smoother. Anyone got any suggestions?

EDIT:

I fixed it. Right clicked on a choppy flash video to see the 'Flash Player settings' menu. I clicked on the 'Enable Hardware Acceleration' toggle, and everything back to normal. :)

Glad to hear that. Was it unchecked by default?

natd1993
Jul 20, 2012, 04:25 AM
Glad to hear that. Was it unchecked by default?

It must've been, seeing as I had no problems under Lion, only ML, in which I had to change the setting.

johndoe123abc
Jul 20, 2012, 07:17 AM
This has been a problem for me too. Originally on Lion the solution was to disable hardware acceleration. I tried the same approach on ML, but it no longer works for me, even on latest version of flash and clean ML install.

Regular video e.g. non fullscreen works fine, no lag at all. Anyone else come up with a solution?

natd1993
Jul 20, 2012, 07:22 AM
This has been a problem for me too. Originally on Lion the solution was to disable hardware acceleration. I tried the same approach on ML, but it no longer works for me, even on latest version of flash and clean ML install.

Regular video e.g. non fullscreen works fine, no lag at all. Anyone else come up with a solution?

I've been enabling it in Mountain Lion instead of disabling it, try that perhaps?

chevalier433
Jul 20, 2012, 07:45 AM
Any flash video I play in fullscreen in ML is choppy and unwatchable. This was not the case in Lion. And yes, I know I shouldn't be using Adobe Flash, but some sites demand it. Anyone else experiencing this, even better, a fix? Maybe a software conflict have you installed perian?

johndoe123abc
Jul 20, 2012, 07:53 AM
No plugins installed. Clean install aside from Flash. Enabling or disabling hardware acceleration does not solve the problem.

I may try disabling safari extensions. Presently I only run 1password and adblock, so I would've thought it was unlikely, but I will check it.

That said, any other ideas?

natd1993
Jul 20, 2012, 08:01 AM
No plugins installed. Clean install aside from Flash. Enabling or disabling hardware acceleration does not solve the problem.

I may try disabling safari extensions. Presently I only run 1password and adblock, so I would've thought it was unlikely, but I will check it.

That said, any other ideas?

Note that you should restart Safari (I presume) or your browser of choice, after changing the 'Enabling Hardware Acceleration' setting, for the change to take effect.

Sylon
Jul 20, 2012, 08:02 AM
Very weird that it was unchecked. On Lion, at least for me, "Enable Hardware Acceleration" is checked by default.

johndoe123abc
Jul 20, 2012, 08:59 AM
Note that you should restart Safari (I presume) or your browser of choice, after changing the 'Enabling Hardware Acceleration' setting, for the change to take effect.

Oh, I was unaware it required a browser restart. Will try, but I think the problem persisted when I tried that.

johndoe123abc
Jul 20, 2012, 01:19 PM
My results are spotty. Sometimes fullscreen is fine with hardware acceleration enabled, but come out of it and go back in and it lags. :(

jlrathke
Jul 20, 2012, 09:48 PM
And yes, I know I shouldn't be using Adobe Flash, but some sites demand it.

I've only been using OS X for about a year now, and only for the last 3 months or so exclusively at the house, but I'm curious about this comment. Why shouldn't the OP be using flash? Is it because of the whole malware thing a month or so back?

Thanks,

Jerry

johndoe123abc
Jul 21, 2012, 04:12 AM
I've only been using OS X for about a year now, and only for the last 3 months or so exclusively at the house, but I'm curious about this comment. Why shouldn't the OP be using flash? Is it because of the whole malware thing a month or so back?

Thanks,

Jerry

Flash shouldn't be used because:

1. The most frequent causes of crashes on Macs.
2. The most likely cause of a security exploit.
3. Incredibly poor performance and memory usage (99% CPU at times).

Steve Jobs was absolutely right. Flash is an abomination, certainly on the Mac. The sooner streaming sites replace it with native HTML5 video, the better.

jlrathke
Jul 21, 2012, 06:41 AM
Flash shouldn't be used because:

1. The most frequent causes of crashes on Macs.
2. The most likely cause of a security exploit.
3. Incredibly poor performance and memory usage (99% CPU at times).

Steve Jobs was absolutely right. Flash is an abomination, certainly on the Mac. The sooner streaming sites replace it with native HTML5 video, the better.

Thanks for the information. What is the best alternative then when a site tells me Flash is required?

Thanks,

Jerry

natd1993
Jul 21, 2012, 06:45 AM
What is the best alternative then when a site tells me Flash is required?

In Safari you can install an extension called 'ClickToFlash' which automatically stops all flash from loading (until you click on it), but it also comes with a built in HTML5 player that will enable wherever possible. You can get it by clicking the Safari menu, and then the 'Safari Extensions' option.

jlrathke
Jul 21, 2012, 07:05 AM
In Safari you can install an extension called 'ClickToFlash' which automatically stops all flash from loading (until you click on it), but it also comes with a built in HTML5 player that will enable wherever possible. You can get it by clicking the Safari menu, and then the 'Safari Extensions' option.

Awesome...thanks!

Jerry

johndoe123abc
Jul 21, 2012, 08:34 AM
Sadly there's no direct alternative. YouTube has really helped push HTML5, but virtually all other streaming services are predominately flash related e.g. PutLocker, and I also think paid streaming services too.

The problem, or rather it isn't a problem, but the content producers say it is, is that HTML5 video is completely open. There's no way of securing content. Flash gives you that as does Silverlight, but as you might expect, they both suck.

eagandale4114
Jul 21, 2012, 06:48 PM
Thanks for the information. What is the best alternative then when a site tells me Flash is required?

Thanks,

Jerry

For youtube and safari check this (http://forums.macrumors.com/showthread.php?t=1403890) out.

Sime66
Feb 28, 2013, 04:37 AM
I've been banging my head against the wall for 24 hours now and this works for me.

I have an old MacBook Pro, 10.6.8, newest version of Chrome, Safari and Firefox, and a new Focusrite USB audio interface (Scarlett 2i2).

Installed the newest Flash player (11 something) and the Focusrite yesterday and everything went bad. Choppy fullscreen video, no audio in Chrome etc etc. So anyway, now it's all fine:

MAC/FLASH: Choppy video, no audio FIX.

1. UNINSTALL FLASH PLAYER. It sucks.

2. Bin the whole Macromedia folder from ~/Library/Preferences.

3. USE CHROME FOR FLASH SITES (has built in flash player - close Chrome when not in use to shut its flash player, to save CPU power).

4. ALSO: Have a USB audio interface? AUDIO MIDI SETUP: 44.1kHz OUTPUT.


That's it. Everything is now smooth in fullscreen in Chrome, and great audio through the Focusrite box.
*fingers crossed*

-------
Simon

jaxrc
Mar 2, 2013, 09:45 PM
I've got one of the newest macbooks running 10.8 and seemingly out of nowhere, I'm encountering the exact problems detailed here. In any full screen flash video, the video suddenly becomes very laggy and choppy.

I'm running up-to-date Chrome and Flash, and I've also tried the "Enable Hardware Acceleration" fix (which was already checked) but to no avail. Does anyone else have any ideas?

grumpybob
Mar 9, 2013, 11:32 AM
So I decided to not be a leech and share my fix (signed up here just to post this answer)...

Not sure if this is still happening to anyone and maybe my problem was isolated but I fixed the issue on my machine and thought I'd share...

I was having MAJOR lag issues with streaming video online on my machine. To the point that the videos were unwatchable because of the jittery, choppiness, and generally overall poor performance.

After troubleshooting for an hour I found that MY problem was stemming from a google chrome issue. I am all fixed now and here is where I found the solution.

https://productforums.google.com/for...me/zRDBYF_yLdE

Make sure you restart Chrome once you've followed the instructions for the fix to take affect.

Although I know some people have way larger issues then just a crummy flash setting on Chrome but I hope this helps someone...

----------

I've got one of the newest macbooks running 10.8 and seemingly out of nowhere, I'm encountering the exact problems detailed here. In any full screen flash video, the video suddenly becomes very laggy and choppy.

I'm running up-to-date Chrome and Flash, and I've also tried the "Enable Hardware Acceleration" fix (which was already checked) but to no avail. Does anyone else have any ideas?

See my reply above... so frustrating but this will fix your problem!

jaxrc
Mar 9, 2013, 06:45 PM
https://productforums.google.com/for...me/zRDBYF_yLdE



The link that you provided is broken. Thank you for posting a fix though, I hope it works for me! :P